View Issue Details

IDProjectCategoryView StatusLast Update
0005746Kali Linux[All Projects] Kali Package Bugpublic2020-07-26 15:19
ReporterqapBuH Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status newResolutionopen 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005746: tp link tl-wn722n V2 monitor mode on kali linux 5.2.0
DescriptionI'm new to Linux, so I don't understand much. I need to enable Monitor mode on my device, but I get an error:
Error for wireless request "Set Mode" (8B06) : SET failed on device wlan0 ; Invalid Argument;
What to do?
Version: kali linux 5.2.0
Adapter tp link tl-wn722n v2



2019-10-21 01:56

reporter   ~0011210

ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlam0 up
iwconfig and than look for monitor in output


2019-10-21 10:33

reporter   ~0011211

That's what gives

37r9gzwaR8A.jpg (392,885 bytes)


2019-10-21 13:12

reporter   ~0011212

You're doing wrong.First make sure your interface is not up than try "iwconfig wlan0 mode monitor".
ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up

type these commands one-by-one and post screenshot


2019-10-21 13:34

reporter   ~0011214

See my screen


2019-10-21 13:43


9SqUKnKftw0.jpg (400,596 bytes)


2019-10-22 03:14

reporter   ~0011215

Try these steps
systemctl stop NetworkManager.service
iwconfig wlan0 mode monitor
iwconfig - and look for mode:monitor

If that doesnt work for you than watch this video
You need to compile and install drivers form this repository


2019-10-22 08:17

reporter   ~0011216

When you try to turn on the mod, it gives the same thing. And when you install the drivers gives this

91RQAYzVOAk.jpg (475,426 bytes)


2019-11-11 18:04

reporter   ~0011293

My drivers doesn't support kernel v5+ at this point. Working with rtl8812au and the wifite2 at the moment, but have a new version of the rtl8188eus to maintain when I've got more time again


2020-07-12 20:09

reporter   ~0013082

I get this:
watch@watch:~$ sudo ifconfig wlan0 down
watch@watch:~$ sudo iwconfig wlan0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device wlan0 ; Operation not permitted.


2020-07-26 15:19

reporter   ~0013145

This one worked for me on the Kali Linux 2020.2 VMware Image

Issue History

Date Modified Username Field Change
2019-10-19 11:06 qapBuH New Issue
2019-10-21 01:56 usama Note Added: 0011210
2019-10-21 10:33 qapBuH File Added: 37r9gzwaR8A.jpg
2019-10-21 10:33 qapBuH Note Added: 0011211
2019-10-21 13:12 usama Note Added: 0011212
2019-10-21 13:34 qapBuH Note Added: 0011214
2019-10-21 13:43 qapBuH File Added: 9SqUKnKftw0.jpg
2019-10-22 03:14 usama Note Added: 0011215
2019-10-22 08:17 qapBuH File Added: 91RQAYzVOAk.jpg
2019-10-22 08:17 qapBuH Note Added: 0011216
2019-11-11 18:04 kimocoder Note Added: 0011293
2020-07-12 20:09 watch Note Added: 0013082
2020-07-26 15:19 jupiops Note Added: 0013145