View Issue Details

IDProjectCategoryView StatusLast Update
0005804Kali Linux[All Projects] General Bugpublic2019-11-21 15:46
ReporterFrankSpierings Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.3 
Target VersionFixed in Version 
Summary0005804: Package Chromium missing after `apt upgrade`
DescriptionThe package for the browser Chromium is no longer available through package management after a `apt upgrade` command. The .deb files are still available in the repository: http://http.kali.org/pool/main/c/chromium/. The version located in the http repo directory is: 76.0.

Steps To ReproduceReproduce through a Docker container:
 
- `docker pull kalilinux/kali-linux-docker`
- `NAME=kali-test; docker run --rm -it --name ${NAME} --hostname ${NAME} kalilinux/kali-linux-docker bash`

Run the information command on the package:

- `apt-cache show chromium`

Partial output:

```
Package: chromium
Version: 76.0.3809.100-1
```

Update apt:

`apt update`

Run the information command on the package:

- `apt-cache show chromium`

Partial output:

```
N: Can't select versions from package 'chromium' as it is purely virtual
N: No packages found
```
Additional InformationThe version seems to be removed by Debian: https://pkg.kali.org/pkg/chromium. Debian 10 itself uses chromium 78.0. https://tracker.debian.org/pkg/chromium

Activities

FrankSpierings

2019-11-21 13:13

reporter  

proof.png (1,389,537 bytes)

FrankSpierings

2019-11-21 14:14

reporter   ~0011337

Small correction: `apt upgrade` should be `apt update`

rhertzog

2019-11-21 14:26

administrator   ~0011338

I'm importing chromium from debian unstable but we are lacking a build for armhf. Not sure that the package will migrate to kali-rolling.

rhertzog

2019-11-21 15:46

administrator   ~0011339

I re-added the former version of chromium.

Issue History

Date Modified Username Field Change
2019-11-21 13:13 FrankSpierings New Issue
2019-11-21 13:13 FrankSpierings File Added: proof.png
2019-11-21 14:14 FrankSpierings Note Added: 0011337
2019-11-21 14:26 rhertzog Assigned To => rhertzog
2019-11-21 14:26 rhertzog Status new => assigned
2019-11-21 14:26 rhertzog Note Added: 0011338
2019-11-21 15:46 rhertzog Status assigned => resolved
2019-11-21 15:46 rhertzog Resolution open => fixed
2019-11-21 15:46 rhertzog Note Added: 0011339