View Issue Details

IDProjectCategoryView StatusLast Update
0005811Kali Linux[All Projects] General Bugpublic2019-12-01 13:34
Reportercohst Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityalways
Status assignedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0005811: msfconsole does not start without sudo permissions
DescriptionSince today's upgrade, msfconsole does not start without sudo/root permission.

cohst@kali-linux:~$ msfconsole
Traceback (most recent call last):ork console...|
    28: from /usr/bin/msfconsole:49:in `<main>'
    27: from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    26: from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    25: from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
    24: from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
    23: from /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize'
    22: from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths'
    21: from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each'
    20: from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths'
    19: from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path'
    18: from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each'
    17: from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path'
    16: from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules'
    15: from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each'
    14: from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules'
    13: from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:256:in `load_modules'
    12: from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:256:in `each'
    11: from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:259:in `block in load_modules'
    10: from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:109:in `recalculate'
     9: from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:109:in `each_pair'
     8: from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:122:in `block in recalculate'
     7: from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:122:in `each_pair'
     6: from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:186:in `block (2 levels) in recalculate'
     5: from /usr/share/metasploit-framework/lib/msf/core/payload.rb:212:in `size'
     4: from /usr/share/metasploit-framework/lib/msf/core/payload/windows/encrypted_reverse_tcp.rb:66:in `generate'
     3: from /usr/share/metasploit-framework/lib/msf/core/payload/windows/encrypted_reverse_tcp.rb:177:in `get_compiled_shellcode'
     2: from /usr/share/metasploit-framework/lib/metasploit/framework/compiler/mingw.rb:15:in `compile_c'
     1: from /usr/share/metasploit-framework/lib/metasploit/framework/compiler/mingw.rb:27:in `build_cmd'
/usr/share/metasploit-framework/lib/metasploit/framework/compiler/mingw.rb:27:in `write': Permission denied @ rb_sysopen - /usr/share/metasploit-framework/reverse_pic_stager.c (Errno::EACCES)
cohst@kali-linux:~$

Seems to be a permission Problem with new Kali Version.

Please have a look at this.

Thanks

Activities

sbrun

2019-11-26 10:27

manager   ~0011351

I don't reproduce this issue with a user without sudo permissions.

The file /usr/share/metasploit-framework/reverse_pic_stager.* is not provided by the metasploit-framework package.
Maybe you should have a look to the file.

cohst

2019-11-26 20:54

reporter   ~0011356

I dont' know what really the problem is, but is definitely a Problem after an upgrade. I have now deleted the virtual machine, restored it from backup, started and checked and Metasploit-Framework starts normal, without sudo permission. I did apt-get update and apt-get dist-upgrade and after updating reboot and check and the same message comes up, but the file /usr/share/metasploit-framework/reverse_pic_stager.* is not available in Folder /usr/share/metasploit-framework/ … It's not there.

A working Workaround of course is to set all permission of /usr/share to cohst (chown -R cohst:cohst /user/share). That works, because now the folder only needs normal permissions. But this is my private test machine at home in my lab. I cannot do this for security reasons with the pentest Server in our Company. So could you please again have a look what can be the reason, for this behaviour?

rhertzog

2019-11-27 09:27

administrator   ~0011370

What's sure is that the code in ./lib/metasploit/framework/compiler/mingw.rb definitely tries to write in the metasploit installation directory.

Now I don't know why it would execute it on initial startup.. the reverse_pic_stager.exe is only referenced in lib/msf/core/payload/windows/encrypted_reverse_tcp.rb

I think it's worth reporting to the upstream metasploit developers. Can you open a ticket in https://github.com/rapid7/metasploit-framework/issues ?

cohst

2019-12-01 13:34

reporter   ~0011504

I have updated the machine today again with latest content. The problem proceeds.

Here the full framework log from "/root/.msf4/logs", if that helps you or the developers of Metasploit Framework:

[09/01/2017 16:41:51] [i(0)] core: Trying to continue despite failed database creation: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?

[09/01/2017 16:41:51] [e(0)] core: DB.connect threw an exception: could not connect to server: Connection refused
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
could not connect to server: Connection refused
    Is the server running on host "localhost" (127.0.0.1) and accepting
    TCP/IP connections on port 5432?

[09/03/2017 10:06:13] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x3e6acdc>
Did you mean? match
[09/03/2017 10:06:21] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- /usr/share/metasploit-framework/plugins/xssf

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:07:45] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x33096a4>
Did you mean? match
[09/03/2017 10:07:53] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:19:30] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x541c2ec>
Did you mean? match
[09/03/2017 10:19:45] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:27:20] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x13a64c4>
Did you mean? match
[09/03/2017 10:27:27] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:30:26] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x7101204>
Did you mean? match
[09/03/2017 10:30:32] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:31:33] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x4dccd9c>
Did you mean? match
[09/03/2017 10:31:39] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:43:13] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x1e3c280>
Did you mean? match
[09/03/2017 10:43:19] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:43:50] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssfmaster: cannot load such file -- /usr/share/metasploit-framework/plugins/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:45:03] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x388a948>
Did you mean? match
[09/03/2017 10:45:10] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssfmaster: cannot load such file -- xssf/xssftunnel

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssfmaster.rb:7:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:48:33] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x42a5590>
Did you mean? match
[09/03/2017 10:48:39] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:49:06] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssfmaster: cannot load such file -- xssf/xssftunnel

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssfmaster.rb:7:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 10:49:17] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssfgui: uninitialized constant Msf::Xssf::XssfDatabase

/usr/share/metasploit-framework/plugins/xssfgui.rb:7:in `<module:XssfGui>'
/usr/share/metasploit-framework/plugins/xssfgui.rb:6:in `<module:Xssf>'
/usr/share/metasploit-framework/plugins/xssfgui.rb:5:in `<module:Msf>'
/usr/share/metasploit-framework/plugins/xssfgui.rb:4:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 14:27:41] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x1b7e714>
Did you mean? match
[09/03/2017 14:32:33] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x4da1ad4>
Did you mean? match
[09/03/2017 14:32:51] [e(0)] core: Error loading plugin /usr/share/metasploit-framework/plugins/xssf: cannot load such file -- xssf/xssfmaster

/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/plugins/xssf.rb:1:in `<top (required)>'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in `require_with_backports'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `block in require'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:240:in `load_dependency'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/activesupport-4.2.9/lib/active_support/dependencies.rb:274:in `require'
/usr/share/metasploit-framework/lib/msf/core/plugin_manager.rb:52:in `load'
/usr/share/metasploit-framework/lib/msf/base/simple/framework.rb:36:in `load'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:774:in `load_plugin'
/usr/share/metasploit-framework/lib/msf/ui/console/command_dispatcher/core.rb:794:in `cmd_load'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:430:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:392:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:386:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:205:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:50] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[09/03/2017 14:39:54] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x4a89e3c>
Did you mean? match
[09/09/2017 13:56:42] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x648447c>
Did you mean? match
[09/09/2017 16:08:41] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x20652c8>
Did you mean? match
[09/16/2017 14:24:35] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x66264b0>
Did you mean? match
[09/16/2017 14:29:06] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x6bfd4b0>
Did you mean? match
[09/16/2017 14:29:11] [e(0)] core: Exploit failed (multi/handler): Rex::BindFailed The address is already in use or unavailable: (0.0.0.0:4444).
[09/16/2017 14:31:57] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.py NoMethodError undefined method `match?' for #<String:0x67a3e14>
Did you mean? match
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:54] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:06:55] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[11/26/2017 14:24:54] [w(0)] core: monitor_rsock: exception during read: IOError stream closed
[11/26/2017 14:24:57] [d(0)] core: monitor_rsock: EOF in rsock
[11/26/2017 14:24:57] [w(0)] core: monitor_rsock: exception during read: Errno::EBADF Bad file descriptor
[11/26/2017 14:24:57] [e(0)] core: thread exception: WebConsoleShell critical=false error: TypeError no implicit conversion of nil into String
  source:
    /usr/share/metasploit-framework/lib/msf/ui/web/console.rb:72:in `initialize'
    /usr/share/metasploit-framework/lib/msf/ui/web/driver.rb:67:in `new'
    /usr/share/metasploit-framework/lib/msf/ui/web/driver.rb:67:in `create_console'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/rpc_console.rb:29:in `rpc_create'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:153:in `block in process'
    /usr/lib/ruby/2.3.0/timeout.rb:91:in `block in timeout'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `block in catch'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `catch'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `catch'
    /usr/lib/ruby/2.3.0/timeout.rb:106:in `timeout'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:153:in `process'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:91:in `on_request_uri'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:72:in `block in start'
    /usr/share/metasploit-framework/lib/rex/proto/http/handler/proc.rb:38:in `on_request'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:368:in `dispatch_request'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:302:in `on_client_data'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:161:in `block in start'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:48:in `on_client_data'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:199:in `block in monitor_clients'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:197:in `each'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:197:in `monitor_clients'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:73:in `block in start'
    /usr/share/metasploit-framework/lib/rex/thread_factory.rb:22:in `block in spawn'
    /usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:100:in `block in spawn'
[11/26/2017 14:24:57] [e(0)] core: Call Stack
/usr/share/metasploit-framework/lib/rex/ui/text/input/buffer.rb:56:in `gets'
/usr/share/metasploit-framework/lib/rex/ui/text/bidirectional_pipe.rb:121:in `gets'
/usr/share/metasploit-framework/lib/rex/ui/text/bidirectional_pipe.rb:151:in `pgets'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:189:in `run'
/usr/share/metasploit-framework/lib/msf/ui/web/console.rb:72:in `block in initialize'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:100:in `block in spawn'
[11/26/2017 14:24:57] [w(0)] core: monitor_rsock: the remote socket is nil, exiting loop
[11/26/2017 14:24:57] [w(0)] core: monitor_rsock: the remote socket is nil, exiting loop
[11/26/2017 16:54:10] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[11/26/2017 16:54:20] [e(0)] core: Exploit failed (unix/webapp/php_include): The following options failed to validate: RHOST.
[11/26/2017 16:55:41] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[11/26/2017 17:00:32] [e(0)] core: thread exception: WebConsoleShell critical=false error: TypeError no implicit conversion of nil into String
  source:
    /usr/share/metasploit-framework/lib/msf/ui/web/console.rb:72:in `initialize'
    /usr/share/metasploit-framework/lib/msf/ui/web/driver.rb:67:in `new'
    /usr/share/metasploit-framework/lib/msf/ui/web/driver.rb:67:in `create_console'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/rpc_console.rb:29:in `rpc_create'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:153:in `block in process'
    /usr/lib/ruby/2.3.0/timeout.rb:91:in `block in timeout'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `block in catch'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `catch'
    /usr/lib/ruby/2.3.0/timeout.rb:33:in `catch'
    /usr/lib/ruby/2.3.0/timeout.rb:106:in `timeout'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:153:in `process'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:91:in `on_request_uri'
    /usr/share/metasploit-framework/lib/msf/core/rpc/v10/service.rb:72:in `block in start'
    /usr/share/metasploit-framework/lib/rex/proto/http/handler/proc.rb:38:in `on_request'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:368:in `dispatch_request'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:302:in `on_client_data'
    /usr/share/metasploit-framework/lib/rex/proto/http/server.rb:161:in `block in start'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:48:in `on_client_data'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:199:in `block in monitor_clients'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:197:in `each'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:197:in `monitor_clients'
    /usr/share/metasploit-framework/vendor/bundle/ruby/2.3.0/gems/rex-core-0.1.12/lib/rex/io/stream_server.rb:73:in `block in start'
    /usr/share/metasploit-framework/lib/rex/thread_factory.rb:22:in `block in spawn'
    /usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:100:in `block in spawn'
[11/26/2017 17:03:59] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[11/26/2017 17:05:59] [w(0)] core: No connection received before the handler completed
[11/26/2017 17:10:19] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[11/26/2017 17:20:25] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[11/26/2017 17:21:57] [w(0)] core: monitor_rsock: exception during read: IOError sysread for buffered IO
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[03/24/2018 15:52:40] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/dos/http/slowloris.rb failed to load due to the following error:
Errno::ENOENT
No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/dos/http/slowloris.rb
Call stack:
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `initialize'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `open'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:126:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:90:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:548:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:510:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:208:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[03/24/2018 15:52:41] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/dos/tcp/claymore_dos.rb failed to load due to the following error:
Errno::ENOENT
No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/dos/tcp/claymore_dos.rb
Call stack:
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `initialize'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `open'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:126:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:90:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:548:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:510:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:208:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[03/24/2018 15:52:50] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/ssl/bleichenbacher_oracle.rb failed to load due to the following error:
Errno::ENOENT
No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/ssl/bleichenbacher_oracle.rb
Call stack:
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `initialize'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `open'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:126:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:90:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:548:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:510:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:208:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[03/24/2018 15:52:50] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/wproxy/att_open_proxy.rb failed to load due to the following error:
Errno::ENOENT
No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/wproxy/att_open_proxy.rb
Call stack:
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `initialize'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `open'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:126:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:90:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:548:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:510:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:208:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[03/24/2018 15:53:05] [e(0)] core: /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.rb failed to load due to the following error:
Errno::ENOENT
No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.rb
Call stack:
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `initialize'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `open'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:78:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:126:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:90:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:85:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:548:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:510:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:504:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:208:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:48:in `<main>'
[07/21/2018 16:59:05] [i(0)] core: windows/x64/powershell_reverse_tcp: iteration 1: Successfully encoded with encoder x64/xor (size is 1583)
[07/21/2018 17:05:19] [e(0)] core: Exploit failed (windows/smb/ms17_010_eternalblue_doublepulsar): No encoders encoded the buffer successfully.
[10/31/2018 21:09:36] [d(0)] core: Created user based module store
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[10/31/2018 21:09:38] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:38] [d(0)] core: Updated user based module store
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[01/19/2019 17:43:41] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load:
Please change the modules class name from Metasploit3 to MetasploitModule
[05/20/2019 21:52:49] [d(0)] core: Updated user based module store
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[05/20/2019 21:54:57] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:39] [d(0)] core: Updated user based module store
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:46:42] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/10/2019 14:53:26] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/admin/teradata/teradata_odbc_sql.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/admin/teradata/teradata_odbc_sql.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:29] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/dos/http/slowloris.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/dos/http/slowloris.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:29] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/dos/smb/smb_loris.rb failed to load due to the following error: Msf::Modules::Error Failed to load module (dos/smb/smb_loris from /usr/share/metasploit-framework/modules/auxiliary/dos/smb/smb_loris.rb) due to invalid module class name (must be MetasploitModule)
[11/10/2019 14:53:30] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/dos/tcp/claymore_dos.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/dos/tcp/claymore_dos.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:30] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/gather/get_user_spns.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/gather/get_user_spns.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:37] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/http/onion_omega2_login.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/http/onion_omega2_login.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:40] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module'
/usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules'
/usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
/usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
/usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
/usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:42] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/dcomexec.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/dcomexec.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:42] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/secretsdump.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/secretsdump.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:43] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/wmiexec.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/smb/impacket/wmiexec.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:44] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/ssl/bleichenbacher_oracle.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/ssl/bleichenbacher_oracle.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:45] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/teradata/teradata_odbc_login.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/teradata/teradata_odbc_login.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:53:46] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/wproxy/att_open_proxy.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/wproxy/att_open_proxy.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:54:04] [e(0)] core: /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/exploits/linux/smtp/haraka.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/10/2019 14:54:27] [e(0)] core: /usr/share/metasploit-framework/modules/exploits/windows/smb/ms17_010_eternalblue_win8.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/exploits/windows/smb/ms17_010_eternalblue_win8.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:222:in `block in demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `each_pair' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:219:in `demand_load_modules' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:89:in `each_module' /usr/share/metasploit-framework/plugins/wmap.rb:2247:in `block in load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:2245:in `load_wmap_modules' /usr/share/metasploit-framework/plugins/wmap.rb:513:in `block in cmd_wmap_run' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index' /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each' /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single' /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/13/2019 20:07:42] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:42] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:42] [w(0)] core: Session 1 has died
[11/13/2019 20:07:44] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:44] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:44] [w(0)] core: Session 2 has died
[11/13/2019 20:07:45] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:46] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:46] [w(0)] core: Session 3 has died
[11/13/2019 20:07:46] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:46] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:47] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:50] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:50] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:50] [w(0)] core: Session 4 has died
[11/13/2019 20:07:50] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:50] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:50] [w(0)] core: Session 5 has died
[11/13/2019 20:07:51] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:51] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:51] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:51] [w(0)] core: Session 6 has died
[11/13/2019 20:07:52] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:52] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:55] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:56] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:56] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:56] [w(0)] core: Session 7 has died
[11/13/2019 20:07:56] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:56] [w(0)] core: Session 8 has died
[11/13/2019 20:07:56] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:56] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:57] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:07:57] [w(0)] core: Session 9 has died
[11/13/2019 20:07:57] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:07:57] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:08:01] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:08:02] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:08:02] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:08:02] [w(0)] core: Session 10 has died
[11/13/2019 20:08:02] [e(0)] core: Session with no session_host/target_host/tunnel_peer
[11/13/2019 20:08:02] [w(0)] core: Session 11 has died
[11/13/2019 20:08:02] [e(0)] core: Exploit failed (multi/handler): Interrupt
[11/13/2019 20:08:02] [w(0)] core: Exception in scheduler thread Rex::TimeoutError Operation timed out.
[11/13/2019 20:22:59] [e(0)] core: Exploit failed (multi/handler): Interrupt
[11/27/2019 20:51:20] [d(0)] core: Updated user based module store
[11/27/2019 20:51:21] [e(0)] core: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb failed to load due to the following error: NameError uninitialized constant Msf::Payload::Windows::EncryptedPayloadOpts Call stack: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:12:in `<module:MetasploitModule>' /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:9:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:140:in `block in load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:567:in `namespace_module_transaction' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:178:in `load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:49:in `block (2 levels) in each_module_reference_name' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:40:in `block in each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `foreach' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:51:23] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[11/27/2019 20:52:00] [e(0)] core: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb failed to load due to the following error: NameError uninitialized constant Msf::Payload::Windows::EncryptedPayloadOpts Call stack: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:12:in `<module:MetasploitModule>' /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:9:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:140:in `block in load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:567:in `namespace_module_transaction' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:178:in `load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:49:in `block (2 levels) in each_module_reference_name' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:40:in `block in each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `foreach' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:05:58] [e(0)] core: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb failed to load due to the following error: NameError uninitialized constant Msf::Payload::Windows::EncryptedPayloadOpts Call stack: /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:12:in `<module:MetasploitModule>' /usr/share/metasploit-framework/modules/payloads/stages/windows/encrypted_shell.rb:9:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:51:in `module_eval_with_lexical_scope' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:140:in `block in load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:567:in `namespace_module_transaction' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:178:in `load_module' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:49:in `block (2 levels) in each_module_reference_name' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch' /usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:40:in `block in each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `foreach' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:30:in `each_module_reference_name' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each' /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver' /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start' /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start' /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:06:23] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:53:in `block (2 levels) in each_module_reference_name'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:42:in `block in each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `foreach'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:06:23] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:53:in `block (2 levels) in each_module_reference_name'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:42:in `block in each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `foreach'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:06:23] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:246:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:53:in `block (2 levels) in each_module_reference_name'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:133:in `block in find'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `catch'
/usr/share/metasploit-framework/vendor/bundle/ruby/2.5.0/gems/rex-core-0.1.13/lib/rex/file.rb:132:in `find'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:42:in `block in each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `foreach'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:31:in `each_module_reference_name'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:245:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:135:in `block in load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:133:in `load_modules'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each'
/usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:161:in `initialize'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
/usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
/usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
/usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:07:36] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize' /usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/exchange_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [w(0)] core: Removing invalid module reference from cache: scanner/msmail/exchange_enum
[12/01/2019 14:07:36] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize' /usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/host_id.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [w(0)] core: Removing invalid module reference from cache: scanner/msmail/host_id
[12/01/2019 14:07:36] [e(0)] core: /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.rb failed to load due to the following error: Errno::ENOENT No such file or directory @ rb_sysopen - /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.rb Call stack: /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `initialize' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `open' /usr/share/metasploit-framework/lib/msf/core/modules/loader/directory.rb:77:in `read_module_content' /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module' /usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize' /usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata' /usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files' /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize' /usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [e(0)] core: Unable to load module /usr/share/metasploit-framework/modules/auxiliary/scanner/msmail/onprem_enum.go Errno::ENOENT No such file or directory - go /usr/lib/ruby/2.5.0/open3.rb:199:in `spawn'
/usr/lib/ruby/2.5.0/open3.rb:199:in `popen_run'
/usr/lib/ruby/2.5.0/open3.rb:95:in `popen3'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:62:in `send'
/usr/share/metasploit-framework/lib/msf/core/modules/external/bridge.rb:18:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:25:in `exec'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:47:in `describe'
/usr/share/metasploit-framework/lib/msf/core/modules/external.rb:13:in `meta'
/usr/share/metasploit-framework/lib/msf/core/modules/external/shim.rb:7:in `generate'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/executable.rb:88:in `read_module_content'
/usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:127:in `load_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:91:in `block in load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `each'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:86:in `load_cached_module'
/usr/share/metasploit-framework/lib/msf/core/module_set.rb:45:in `create'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:61:in `block (3 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:57:in `block (2 levels) in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `each'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:54:in `block in refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `synchronize'
/usr/share/metasploit-framework/lib/msf/core/modules/metadata/cache.rb:51:in `refresh_metadata'
/usr/share/metasploit-framework/lib/msf/core/module_manager/cache.rb:124:in `refresh_cache_from_module_files'
/usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:166:in `block in initialize'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:07:36] [w(0)] core: Removing invalid module reference from cache: scanner/msmail/onprem_enum
[12/01/2019 14:09:45] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/android/steal_sdcard_file.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:45] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/chrome/filejacking.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:45] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/elastix/Elastix_PBX_voip_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/ie/command.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/iphone/skype_call.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/alert.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/change_interval.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/check_connected.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/cookie.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/csrf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/detect_properties.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/get_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_applet.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/load_pdf.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/logkeys.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/prompt.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/redirect.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/save_page.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/tabnapping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/visited_pages.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/webcam_capture.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/misc/xss_get_bounce.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/connection_speed.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/distributed_dos.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ie/ipconfig.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_network.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ms_windows_html5/scan_ports.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/ping.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/network/web_services.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/bypass_sop_ie6.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/old_browsers/trace_method_results.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/ghostify.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:09:46] [w(0)] core: /usr/share/metasploit-framework/modules/auxiliary/xssf/public/persistence/iframize.rb generated a warning during load: Please change the module's class name from Metasploit3 to MetasploitModule
[12/01/2019 14:10:36] [e(0)] core: thread exception: ScannerHost(scanner/http/trace)-192.168.1.6 critical=false error: NoMethodError undefined method `id' for nil:NilClass
  source:
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:105:in `block in run'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `loop'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `run'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:140:in `job_run_proc'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:82:in `run_simple'
    /usr/share/metasploit-framework/plugins/wmap.rb:1747:in `local_module_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:1864:in `rpc_round_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:676:in `block (2 levels) in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `each_key'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `block in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:10:36] [e(0)] core: Call Stack
/usr/share/metasploit-framework/lib/msf/core/auxiliary/report.rb:295:in `report_vuln'
/usr/share/metasploit-framework/modules/auxiliary/scanner/http/trace.rb:47:in `run_host'
/usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:111:in `block (2 levels) in run'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:10:36] [e(0)] core: Auxiliary failed: NoMethodError undefined method `id' for nil:NilClass
[12/01/2019 14:14:33] [e(0)] core: thread exception: ScannerHost(scanner/http/trace)-192.168.1.6 critical=false error: NoMethodError undefined method `id' for nil:NilClass
  source:
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:105:in `block in run'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `loop'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `run'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:140:in `job_run_proc'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:82:in `run_simple'
    /usr/share/metasploit-framework/plugins/wmap.rb:1747:in `local_module_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:1864:in `rpc_round_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:676:in `block (2 levels) in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `each_key'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `block in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:14:33] [e(0)] core: Call Stack
/usr/share/metasploit-framework/lib/msf/core/auxiliary/report.rb:295:in `report_vuln'
/usr/share/metasploit-framework/modules/auxiliary/scanner/http/trace.rb:47:in `run_host'
/usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:111:in `block (2 levels) in run'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:14:33] [e(0)] core: Auxiliary failed: NoMethodError undefined method `id' for nil:NilClass
[12/01/2019 14:17:06] [e(0)] core: thread exception: ScannerHost(scanner/http/trace)-192.168.1.6 critical=false error: NoMethodError undefined method `id' for nil:NilClass
  source:
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:105:in `block in run'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `loop'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `run'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:140:in `job_run_proc'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:82:in `run_simple'
    /usr/share/metasploit-framework/plugins/wmap.rb:1747:in `local_module_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:1864:in `rpc_round_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:676:in `block (2 levels) in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `each_key'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `block in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:17:06] [e(0)] core: Call Stack
/usr/share/metasploit-framework/lib/msf/core/auxiliary/report.rb:295:in `report_vuln'
/usr/share/metasploit-framework/modules/auxiliary/scanner/http/trace.rb:47:in `run_host'
/usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:111:in `block (2 levels) in run'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:17:06] [e(0)] core: Auxiliary failed: NoMethodError undefined method `id' for nil:NilClass
[12/01/2019 14:20:06] [e(0)] core: thread exception: ScannerHost(scanner/http/trace)-192.168.1.6 critical=false error: NoMethodError undefined method `id' for nil:NilClass
  source:
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:105:in `block in run'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `loop'
    /usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:92:in `run'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:140:in `job_run_proc'
    /usr/share/metasploit-framework/lib/msf/base/simple/auxiliary.rb:82:in `run_simple'
    /usr/share/metasploit-framework/plugins/wmap.rb:1747:in `local_module_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:1864:in `rpc_round_exec'
    /usr/share/metasploit-framework/plugins/wmap.rb:676:in `block (2 levels) in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `each_key'
    /usr/share/metasploit-framework/plugins/wmap.rb:631:in `block in cmd_wmap_run'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `each_with_index'
    /usr/share/metasploit-framework/plugins/wmap.rb:472:in `cmd_wmap_run'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:523:in `run_command'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:474:in `block in run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `each'
    /usr/share/metasploit-framework/lib/rex/ui/text/dispatcher_shell.rb:468:in `run_single'
    /usr/share/metasploit-framework/lib/rex/ui/text/shell.rb:158:in `run'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    /usr/bin/msfconsole:49:in `<main>'
[12/01/2019 14:20:06] [e(0)] core: Call Stack
/usr/share/metasploit-framework/lib/msf/core/auxiliary/report.rb:295:in `report_vuln'
/usr/share/metasploit-framework/modules/auxiliary/scanner/http/trace.rb:47:in `run_host'
/usr/share/metasploit-framework/lib/msf/core/auxiliary/scanner.rb:111:in `block (2 levels) in run'
/usr/share/metasploit-framework/lib/msf/core/thread_manager.rb:106:in `block in spawn'
[12/01/2019 14:20:06] [e(0)] core: Auxiliary failed: NoMethodError undefined method `id' for nil:NilClass

Issue History

Date Modified Username Field Change
2019-11-24 17:25 cohst New Issue
2019-11-26 10:27 sbrun Assigned To => sbrun
2019-11-26 10:27 sbrun Status new => feedback
2019-11-26 10:27 sbrun Note Added: 0011351
2019-11-26 20:54 cohst Note Added: 0011356
2019-11-26 20:54 cohst Status feedback => assigned
2019-11-27 09:27 rhertzog Note Added: 0011370
2019-12-01 13:34 cohst Note Added: 0011504