View Issue Details

IDProjectCategoryView StatusLast Update
0005840Kali Linux[All Projects] General Bugpublic2019-11-29 13:31
Reportercrahan Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.4 
Target VersionFixed in Version2020.1 
Summary0005840: Xfce does not group the default Xfce menu categories under 'Usual applications'
DescriptionAll default Xfce menu categories are configured in /etc/xdg/menus/applications-merged/kali-applications.menu to be moved under the 'Usual applications' category. This does not happen in Xfce however.

The way to fix this is to change the following in /etc/xdg/menus/xfce-applications.menu:

1. Add an entry for the 'Usual Applications' menu ('<Menuname>Usual Applications</Menuname>')

    <Layout>
        <Filename>xfce4-run.desktop</Filename>
        <Separator/>
        <Filename>exo-terminal-emulator.desktop</Filename>
        <Filename>exo-file-manager.desktop</Filename>
        <Filename>exo-mail-reader.desktop</Filename>
        <Filename>exo-web-browser.desktop</Filename>
        <Separator/>
        <Menuname>Settings</Menuname>
        <Separator/>
        <Menuname>Usual Applications</Menuname>
        <Separator/>
        <Merge type="all"/>
        <Separator/>
        <Filename>xfce4-about.desktop</Filename>
        <Filename>xfce4-session-logout.desktop</Filename>
    </Layout>

2. At the end of the file (before the closing </menu> tag add both the 'Usual Applications' definition as well as all the move instructions. Be sure to edit the move entry for 'Internet' and change 'Internet' to 'Network' as that is what the internal name of the category really is.

    <Menu>
        <Name>Usual Applications</Name>
        <Directory>usual-apps.directory</Directory>
        <!-- This is the target of <Move> at the end ... -->
    </Menu>

    <!-- Move default top-level menus one level deeper -->
    <Move>
        <Old>Accessories</Old>
        <New>Usual Applications/Accessories</New>
    </Move>
    ...
    <Move>
        <Old>Hamradio</Old>
        <New>Usual Applications/Hamradio</New>
    </Move>

Once fixed the 'Usual applications' icon will be missing. This can be resolved by removing the .png extension for the icon entry in /usr/share/desktop-directories/usual-apps.directory.
Steps To Reproduce1. Start Kali
2. Log in
3. Open the Xfce menu

Activities

crahan

2019-11-29 01:43

reporter  

yes.jpg (195,042 bytes)
yes.jpg (195,042 bytes)
no.jpg (219,791 bytes)
no.jpg (219,791 bytes)

crahan

2019-11-29 09:01

reporter   ~0011474

Adding a correct screenshot to show the correctly grouped categories. The previous screenshot did not show the actual contents of the menu entry.

yes - corrected.png (815,819 bytes)

rhertzog

2019-11-29 13:31

administrator   ~0011478

Thanks for the suggestion. I used a slightly different approach... since I have to override the xfce-applications.menu file, I created the nested structure directly in that file without resorting to "Move" instructions. The result is available in kali-menu 2020.1.0.

Issue History

Date Modified Username Field Change
2019-11-29 01:43 crahan New Issue
2019-11-29 01:43 crahan File Added: yes.jpg
2019-11-29 01:43 crahan File Added: no.jpg
2019-11-29 09:01 crahan File Added: yes - corrected.png
2019-11-29 09:01 crahan Note Added: 0011474
2019-11-29 10:23 rhertzog Assigned To => rhertzog
2019-11-29 10:23 rhertzog Status new => assigned
2019-11-29 13:31 rhertzog Status assigned => resolved
2019-11-29 13:31 rhertzog Resolution open => fixed
2019-11-29 13:31 rhertzog Fixed in Version => 2020.1
2019-11-29 13:31 rhertzog Note Added: 0011478