View Issue Details

IDProjectCategoryView StatusLast Update
0005965Kali Linux[All Projects] General Bugpublic2020-01-13 17:56
Reporterradualexandrupopescu Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2020.1 
Summary0005965: PAM/GDM does not allow root to login after last update
DescriptionFor some reason, after the last update (2019-12-31T02:30:00+0200) GDM refuses to allow me to login.

/var/log/auth.log contains lines like:
Dec 31 03:02:16 kali gdm-password]: pam_succeed_if(gdm-password:auth): requirement "user != root" not met by user "root"
Steps To ReproduceUpdate to current version of packages
Try to log in
Additional InformationCommenting out lines like
auth required pam_succeed_if.so user != root quiet_success
from /etc/pam.d/gdm-* seems to fix the issue.

Should mention this is an old VM I keep updating/upgrading: Kali-Linux-2016.2-vm-amd64

Activities

rhertzog

2020-01-03 19:55

administrator   ~0011799

That's because you removed "kali-root-login", we dropped the dependency in preparation of the switch to a default non-root user but I did not anticipate that it would be removed by "apt autoremove". I have added a "Suggests: kali-root-login" to (hopefully) keep the package installed for users that already have it.

You have to "apt install kali-root-login" to fix that. Or maybe you should add normal user and make it a member of the sudo group and keep using that instead.

See https://www.kali.org/news/kali-default-non-root-user/

Issue History

Date Modified Username Field Change
2019-12-31 01:26 radualexandrupopescu New Issue
2020-01-03 19:55 rhertzog Assigned To => rhertzog
2020-01-03 19:55 rhertzog Status new => resolved
2020-01-03 19:55 rhertzog Resolution open => fixed
2020-01-03 19:55 rhertzog Fixed in Version => 2020.1
2020-01-03 19:55 rhertzog Note Added: 0011799