View Issue Details

IDProjectCategoryView StatusLast Update
0005981Kali Linux[All Projects] General Bugpublic2020-01-08 08:39
ReporterArszilla Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionreopened 
Product Version2019.4 
Target VersionFixed in Version 
Summary0005981: Kali Live Build Won't Build A Proper ISO
DescriptionI am attempting to build a custom, Kali i3-gaps ISO with my dotfiles and settings. The files that are being used for the build can be viewed at:

- https://gitlab.com/Arszilla/kali-i3-gaps
- https://github.com/Arszilla/kali-i3-gaps

The main differences vs the Kali Gitlab account is that I am trying to set Hack Nerd Font as the default font while installing i3-gaps and polybar as well as some other programs and alike. Towards the end of the build, xorriso starts building the ISO, however, libisofs starts throwing various "Cannot add" errors. I've tried using Kali's own repo and building any ISO variant; headless, i3wm, minimal etc as well as using a VM to build both Kali Gitlab's ISOs and my custom ISO but they suffer from the same issue.

I initiate the build using `./build.sh --variant i3wm --verbose`. Do note that my repo was based on the Kali Docs; following the guide there.

I have attached my build log for the ISO I started building several hours ago at this report.

Activities

Arszilla

2020-01-07 01:13

reporter  

kali-linux-rolling-i3wm-amd64.log (1,165,771 bytes)

rhertzog

2020-01-07 13:06

administrator   ~0011826

Those messages are not errors, they are only a warning. Your image got built. Closing the ticket.

Arszilla

2020-01-07 16:27

reporter   ~0011831

Apologies, I forgot to attach 2 images that were vital to this report; depicting the issue. The ISO does indeed get build but it's unusable. I cannot initiate "Install" or Graphical" install.

Install: https://prnt.sc/qkgm39
Graphical Install: http://prnt.sc/qkglyh

This is the main issue. Once again, I apologize for forgetting to attach these images.

rhertzog

2020-01-08 08:39

administrator   ~0011833

You need to downgrade your version of cpio to the version currently available in kali-rolling, aka 2.12+dfsg-9+b1.

The version that you have was shortly available in Kali but we downgraded it back to a former version because of this bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=946267

Issue History

Date Modified Username Field Change
2020-01-07 01:13 Arszilla New Issue
2020-01-07 01:13 Arszilla File Added: kali-linux-rolling-i3wm-amd64.log
2020-01-07 13:06 rhertzog Assigned To => rhertzog
2020-01-07 13:06 rhertzog Status new => closed
2020-01-07 13:06 rhertzog Resolution open => fixed
2020-01-07 13:06 rhertzog Note Added: 0011826
2020-01-07 16:27 Arszilla Status closed => feedback
2020-01-07 16:27 Arszilla Resolution fixed => reopened
2020-01-07 16:27 Arszilla Note Added: 0011831
2020-01-08 08:39 rhertzog Status feedback => closed
2020-01-08 08:39 rhertzog Note Added: 0011833