View Issue Details

IDProjectCategoryView StatusLast Update
0005982Kali LinuxGeneral Bugpublic2020-12-01 10:50
ReporterRapt0r Assigned Tosbrun  
Status assignedResolutionopen 
Summary0005982: Ettercap Segmentation Fault

Everytime i run ettercap 0.8.3 i keep getting a Segmentation Fault.

If i run it from the kali menu, it loads up but as soon as i click on the little tick to continue it closes the program.

So i tried running it in a terminal to see what happens and i get this:

root@Kali:~# ettercap -G

ettercap 0.8.3 copyright 2001-2019 Ettercap Development Team

Ooops ! This shouldn't happen...
Segmentation Fault...

Please recompile in debug mode, reproduce the bug and send a bugreport

Have a nice day!

I am running the latest version of Kali (as of 07/01/2020) and doing an apt-get upgrade and apt-get dist-upgrade updated ettercap as well but still the same issue persists

Steps To Reproduce

Everytime i try to open ettercap and try to use




2020-01-07 16:21

manager   ~0011830

I just tried the command on an amd64 machine:
root@Kali:~# ettercap -G
I don't get a segfault.

Can you check if you have the latest version? (dpkg -s ettercap-common)
As it's a Debian package, if you still have the issue with the latest version (1:0.8.3-6), you should report the issue directly in Debian (with the details about pacakge version, architecture...):
See Filing a Bug Report in Debian



2020-01-08 08:44

administrator   ~0011834

Since this is not reproducible on our side, before fiiing a bug to Debian you should install debug packages and generate a backtrace of the segfault. You might want to double check if you can reproduce it on a clean install too.



2020-01-09 09:31

reporter   ~0011844


I've the same issue + latest version.




2020-01-09 10:12

manager   ~0011845

@atdtphreaker thanks for your feedback.
But as we don't reproduce the issue, we can't debug it. We (Kali or Debian) need a backtrace as @rhertzog explained.



2020-01-09 10:19

reporter   ~0011846


You're welcome. I understand that you don't 'reproduce' the issue, but I just wanted to inform you so it is known + documented.

Thank, I appreciate your time.



2020-01-09 16:16

reporter   ~0011847

I think you need to modify your /etc/ettercap/etter.conf


if you use iptables:

#redir_command_on = "iptables -t nat -A PREROUTING -i %iface -p tcp -s %source -d %destination --dport %port -j REDIRECT --to-port %rport"
#redir_command_off = "iptables -t nat -D PREROUTING -i %iface -p tcp -s %source -d %destination --dport %port -j REDIRECT --to-port %rport"

pendant for IPv6 - Note that you need iptables v1.4.16 or newer to use IPv6 redirect

#redir6_command_on = "ip6tables -t nat -A PREROUTING -i %iface -p tcp -s %source -d %destination --dport %port -j REDIRECT --to-port %rport"
#redir6_command_off = "ip6tables -t nat -D PREROUTING -i %iface -p tcp -s %source -d %destination --dport %port -j REDIRECT --to-port %rport"



2020-01-09 22:52

reporter   ~0011857

i did a backtrace and this is the result i got:

root@kali:~# gdb --args ettercap -G
GNU gdb (Debian 8.3.1-1) 8.3.1
Copyright (C) 2019 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
Find the GDB manual and other documentation resources online at:

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ettercap...
(No debugging symbols found in ettercap)
(gdb) bt
No stack.
(gdb) run
Starting program: /usr/bin/ettercap -G
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/".

ettercap 0.8.3 copyright 2001-2019 Ettercap Development Team

[New Thread 0x7ffff45c7700 (LWP 3553)]
[New Thread 0x7ffff3dc6700 (LWP 3554)]
[New Thread 0x7ffff0a06700 (LWP 3555)]
[Detaching after fork from child process 3556]
[Detaching after fork from child process 3557]

Thread 1 "ettercap" received signal SIGSEGV, Segmentation fault.
strstr_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strstr-sse2-unaligned.S:40
40 ../sysdeps/x86_64/multiarch/strstr-sse2-unaligned.S: No such file or directory.
(gdb) bt
#0 0x00007ffff7dad62d in
strstr_sse2_unaligned () at ../sysdeps/x86_64/multiarch/strstr-sse2-unaligned.S:40
0000001 0x00007ffff7f6bb5b in str_replace () at /lib/
#2 0x00007ffff7f610f8 in ec_redirect () at /lib/
#3 0x00007ffff7f6a666 in ssl_wrap_init () at /lib/
0000004 0x000055555555796b in main ()

can someone please explain the problem as this has gone slightly over my head

Issue History

Date Modified Username Field Change
2020-01-07 10:19 Rapt0r New Issue
2020-01-07 16:21 sbrun Assigned To => sbrun
2020-01-07 16:21 sbrun Status new => feedback
2020-01-07 16:21 sbrun Note Added: 0011830
2020-01-08 08:44 rhertzog Note Added: 0011834
2020-01-09 09:31 atdtphreaker Note Added: 0011844
2020-01-09 10:12 sbrun Note Added: 0011845
2020-01-09 10:19 atdtphreaker Note Added: 0011846
2020-01-09 16:16 atdtphreaker Note Added: 0011847
2020-01-09 22:52 Rapt0r Note Added: 0011857
2020-01-09 22:52 Rapt0r Status feedback => assigned
2020-12-01 10:48 g0tmi1k Priority high => normal
2020-12-01 10:50 g0tmi1k Severity major => minor