View Issue Details

IDProjectCategoryView StatusLast Update
0006033Kali Linux[All Projects] Tool Upgrade Requestpublic2020-02-24 09:48
ReporterRoseDeSable Assigned Tosbrun  
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2020.2 
Summary0006033: Shellter can't call windows debugger in wine after the dist-upgrade yesterday
DescriptionThe following PEB flags have been reset:

1. PEB.BeingDebugged

2. PEB.NtGlobalFlag

wine: Unhandled exception 0x80000003 in thread 31 at address 004277C6 (thread 0031), starting debugger...

WMEM_ERROR_01 || Please Report To Author.

Last_Error_Code: 5 || Permission denied

BP_ERROR_02 || Please Report To Author.

Last_Error_Code: 5 || Permission denied

Here are the versions and releases of the both packets

 wine 5.0~rc3-1 all Windows API implementation - standard suite

 shellter 7.1-0kali5 amd64 Dynamic shellcode injection tool and dynamic PE infector



2020-01-31 07:04

reporter   ~0011980

If I start shellter the first time after a reboot of my system, the following message appears:

000f:err:service:process_send_command receiving command result timed out
0024:err:ntdll:RtlpWaitForCriticalSection section 0x7bea3100 "loader.c: loader_section" wait timed out in thread 0024, blocked by 0026, retrying (60 sec)


2020-02-03 14:27

reporter   ~0012000

If I have no directory .wine, I receive a lot of error messages by initializing wine

wine: created the configuration directory '/root/.wine'
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0012:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0012:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0012:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0012:err:ole:get_local_server_stream Failed: 80004002
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
0014:err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
0014:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
0014:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
0014:err:ole:get_local_server_stream Failed: 80004002
Could not find Wine Gecko. HTML rendering will be disabled.
wine: configuration in L"/root/.wine" has been updated.


2020-02-04 07:19

reporter   ~0012002

Good Morning,
 the problem with wine is solved, after I did the following steps:

rm -r .wine
find ~/.local/share -name "*wine*" | xargs --no-run-if-empty rm -r
rm -f ~/.local/share/mime/packages/x-wine*
rm -f ~/.local/share/mime/application/x-wine-extension*
rm -f ~/.local/share/applications/mimeinfo.cache
update-desktop-database ~/.local/share/applications
update-mime-database ~/.local/share/mime/

I don't exactly know, what I did, but i had a success.

source of the tips:


2020-02-04 07:21

reporter   ~0012003

Another thing: The error message after the reboot doesn't appear after the doing in my last notice.


2020-02-17 10:23

reporter   ~0012286

The problems with wine exist in this elder note of "Shellter Bugs"


Shellter 6.3 – Wine mode Bug
April 26, 2016

A recent change in Shellter 6.3 introduced a silly bug that will cause an “RMEM_ERROR_01” error when used in Wine.
I am currently testing the fix for this as well, but in the meantime use version 6.2 in Wine.



It seems to be, as if the bug returned after the upgrade to 7.1 of shellter


2020-02-18 17:55

reporter   ~0012306

Shellter dev has acknowledged and identified the issue. Currently working on the fix.


2020-02-18 23:15

reporter   ~0012307

Hi all,

I will release the new version as soon as possible.

This issue was caused by an update to the Wine itself, which broke the way Shellter identifies it and operates in "Wine Mode".

This is not related with the bug that RoseDeSable mentioned (Shellter 6.3 – Wine mode Bug, April 26, 2016) as this was indeed a bug in Shellter itself.



2020-02-24 09:10

reporter   ~0012328

Good Morning,
 after the upgrade of shellter this morning, the problem is solved. Shellter is correctly running.



2020-02-24 09:48

manager   ~0012329

it's fixed in new version 7.2-0kali1

Issue History

Date Modified Username Field Change
2020-01-28 09:42 RoseDeSable New Issue
2020-01-28 09:42 RoseDeSable Status new => assigned
2020-01-28 09:42 RoseDeSable Assigned To => sbrun
2020-01-31 07:04 RoseDeSable Note Added: 0011980
2020-02-03 14:27 RoseDeSable Note Added: 0012000
2020-02-04 07:19 RoseDeSable Note Added: 0012002
2020-02-04 07:21 RoseDeSable Note Added: 0012003
2020-02-17 10:23 RoseDeSable Note Added: 0012286
2020-02-18 17:55 ronin Note Added: 0012306
2020-02-18 23:15 kyREcon Note Added: 0012307
2020-02-24 09:10 RoseDeSable Note Added: 0012328
2020-02-24 09:48 sbrun Status assigned => resolved
2020-02-24 09:48 sbrun Resolution open => fixed
2020-02-24 09:48 sbrun Fixed in Version => 2020.2
2020-02-24 09:48 sbrun Note Added: 0012329
2021-05-31 13:37 rhertzog Category Tool Upgrade => Tool Upgrade Request