View Issue Details

IDProjectCategoryView StatusLast Update
0006056Kali Linux[All Projects] General Bugpublic2020-03-14 11:36
ReporterTroy8203 Assigned To 
Status newResolutionopen 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006056: graphic error
DescriptionAl realizar cualquier acción que implique un cambio gráfico (por ejemplo, colocar el mouse sobre el botón o abrir un panel), aparecen píxeles en la pantalla.
Additional InformationIt happens after starting the operating system for the second time, the features of my laptop: amd ryzen 3 2200g



2020-02-02 04:36


Stygian Blue

2020-03-11 23:41

reporter   ~0012407

I am having the same problem. This is occurring on a new install on a new ASUS laptop with an integrated Radeon GPU. Specs of the laptop:
-ASUS VivoBook 15 F512DA
-Ryzen R5-3500U Processor
-AMD Radeon Vega 8 Integrated GPU
-256GB SSD

The pixelation or graphic artifacts occur any time something on the screen changes, even typing text in the terminal. It makes the computer nearly unusable. I have attached two images: the first shows what happens when doing a simple search in APT-CACHE: the results are completely obscured by the artifacts. Waiting about 3-5 seconds for a full screen refresh causes the screen to then be correct (second image).

The same graphic errors also appear when booting from a Kali Live USB.

01 Graphic Artifacts.jpg (467,577 bytes)
02 After Full Refresh.jpg (391,070 bytes)

Stygian Blue

2020-03-11 23:51

reporter   ~0012408

I have also tried the following methods to "ignore" the integrated GPU:
-Added "radeon.modeset=0" to GRUB_CMDLINE_LINUX_DEFAULT. This had NO EFFECT.
-Added "nomodeset" to GRUB_CMDLINE_LINUX_DEFAULT. This caused the machine to fail boot. I had to boot into recovery mode, and the graphical bugs still existed.

Until this bug is fixed, is there a way to force Kali to boot into an SVGA mode or to ignore the integrated GPU?


2020-03-12 01:48

reporter   ~0012409

Hello guys, I have a similar problem. When I open certain programs, the window is not displayed correctly, the text next to the icons is not visible and only appears when I click on it and some parts of the window are blank. I tried to change the graphical interface, so I tested it on Xfce, Gnome and Kde, even so the problem persists.

Acer Aspire ES1-572
i3-6100U CPU @ 2.30GHz × 4
Intel HD Graphics 520 (Skylake GT2)


2020-03-14 10:28

reporter   ~0012414

I have the same issue.showing error amdgpu requires firmware.
Ryzen 5 3400g
Gigabyte b450m ds3h
8gb ram (647,430 bytes)

Stygian Blue

2020-03-14 11:36

reporter   ~0012415

I loaded Windows 10 just to update MoBo, CPU, and BIOS firmware. No change after the updates.

Issue History

Date Modified Username Field Change
2020-02-02 04:36 Troy8203 New Issue
2020-02-02 04:36 Troy8203 File Added: 83910300_487868245438559_4948881018913292288_n.jpg
2020-02-02 04:36 Troy8203 File Added: 83965459_3085164261502669_7958053596048654336_n.jpg
2020-03-11 23:41 Stygian Blue File Added: 01 Graphic Artifacts.jpg
2020-03-11 23:41 Stygian Blue File Added: 02 After Full Refresh.jpg
2020-03-11 23:41 Stygian Blue Note Added: 0012407
2020-03-11 23:51 Stygian Blue Note Added: 0012408
2020-03-12 01:48 abimaelsb File Added: Captura de tela de 2020-03-11 22-39-12.png
2020-03-12 01:48 abimaelsb File Added: Captura de tela de 2020-03-11 22-40-55.png
2020-03-12 01:48 abimaelsb Note Added: 0012409
2020-03-14 10:28 Rithib File Added:
2020-03-14 10:28 Rithib Note Added: 0012414
2020-03-14 11:36 Stygian Blue Note Added: 0012415