View Issue Details

IDProjectCategoryView StatusLast Update
0006118Kali Linux[All Projects] Tool Upgradepublic2020-02-20 15:58
ReporterBlack4God Assigned Tosbrun  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006118: Metasploit need to upgrade
DescriptionI can't open metasploit .what happen to it ?
this is showing to me :
[*] Bundler failed to load and returned this error:

   'cannot load such file -- bundler/setup'

[*] You may need to uninstall or upgrade bundler
Steps To ReproduceI have watch some video and I tried it
first step :
               sudo apt-get install gem
second step :
              gem install bundler
third step:
              bundle install
but , I got an error here
Could not locate Gemfile

Additional Informationplease solve it ......

Relationships

duplicate of 0006115 resolvedsbrun metasploit bug 

Activities

Black4God

2020-02-20 15:19

reporter  

sbrun

2020-02-20 15:58

manager   ~0012325

the issue is fixed in metasploit-framework version 5.0.74-0kali2

You need to update metasploit:
sudo apt update
sudo apt dist-upgrade

Check which version you have:
dpkg -s metasploit-framework

And you should uninstall bundler you have installed with gem, with a command like "gem uninstall bundler"

Issue History

Date Modified Username Field Change
2020-02-20 15:19 Black4God New Issue
2020-02-20 15:19 Black4God Status new => assigned
2020-02-20 15:19 Black4God Assigned To => sbrun
2020-02-20 15:19 Black4God File Added: Screenshot 2020-02-20 00:54:48.png
2020-02-20 15:49 sbrun Relationship added duplicate of 0006115
2020-02-20 15:58 sbrun Status assigned => closed
2020-02-20 15:58 sbrun Resolution open => duplicate
2020-02-20 15:58 sbrun Note Added: 0012325