View Issue Details

IDProjectCategoryView StatusLast Update
0006172Kali Linux[All Projects] Kali Package Bugpublic2020-03-10 08:39
Reportercohst Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.1 
Target VersionFixed in Version2020.2 
Summary0006172: arachni doesn't work anymore after upgrade
DescriptionAfter I did the normal apt-get update && apt-get dist-upgrade and reboot, arachni doesn't work anymore. I received the following error message while starting arachni (equal if I start it with sudo or without).

cohst@kali-linux:~$ arachni -h
Traceback (most recent call last):
        6: from ./arachni:10:in `<main>'
        5: from ./arachni:10:in `require_relative'
        4: from /usr/share/arachni/ui/cli/framework.rb:9:in `<top (required)>'
        3: from /usr/share/arachni/ui/cli/framework.rb:9:in `require_relative'
        2: from /usr/share/arachni/lib/arachni.rb:10:in `<top (required)>'
        1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- bundler/setup (LoadError)
cohst@kali-linux:~$ sudo arachni -h
[sudo] password for cohst:
Traceback (most recent call last):
        6: from ./arachni:10:in `<main>'
        5: from ./arachni:10:in `require_relative'
        4: from /usr/share/arachni/ui/cli/framework.rb:9:in `<top (required)>'
        3: from /usr/share/arachni/ui/cli/framework.rb:9:in `require_relative'
        2: from /usr/share/arachni/lib/arachni.rb:10:in `<top (required)>'
        1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- bundler/setup (LoadError)
cohst@kali-linux:~$

Seems to be a problem with the rubygems.


Steps To ReproduceStart arachni via Shell.

Activities

cohst

2020-03-08 13:26

reporter  

kali screenshot.JPG (147,344 bytes)
kali screenshot.JPG (147,344 bytes)

sbrun

2020-03-10 08:39

manager   ~0012398

fixed with version 1.5.1-0kali5+b1

Issue History

Date Modified Username Field Change
2020-03-08 13:26 cohst New Issue
2020-03-08 13:26 cohst File Added: kali screenshot.JPG
2020-03-08 13:48 sbrun Assigned To => sbrun
2020-03-08 13:48 sbrun Status new => assigned
2020-03-10 08:39 sbrun Status assigned => resolved
2020-03-10 08:39 sbrun Resolution open => fixed
2020-03-10 08:39 sbrun Fixed in Version => 2020.2
2020-03-10 08:39 sbrun Note Added: 0012398