View Issue Details

IDProjectCategoryView StatusLast Update
0006244Kali Linux[All Projects] Kali Package Bugpublic2020-04-14 12:15
Reporterwolfthefallen Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2020.1 
Target VersionFixed in Version 
Summary0006244: King Phisher update bug fix
DescriptionPlease update the kali apt install to mirror the https://github.com/securestate/king-phisher master branch.

There is an error in the current version in the Kali repository preventing the server from successfully loading. This is due to how GeoIP database King Phisher now requires an account to download. We have patched is issue to allow the use of King Phisher to continue to operate correctly.
Steps To Reproducecd ./king-phisher
./KingPhisherServer -L DEBUG -c config.yml

WARNING the specified geoip database does not exist, downloading a new copy
ERROR geoip database download failed (could not connect to the server)
CRITICAL server failed to build with error: could not download the geoip database


Activities

sbrun

2020-04-14 12:15

manager   ~0012617

new version 1.15.0+git20200315-0kali1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2020-03-31 12:23 wolfthefallen New Issue
2020-04-06 09:33 sbrun Assigned To => sbrun
2020-04-06 09:33 sbrun Status new => assigned
2020-04-14 12:15 sbrun Status assigned => resolved
2020-04-14 12:15 sbrun Resolution open => fixed
2020-04-14 12:15 sbrun Note Added: 0012617