View Issue Details

IDProjectCategoryView StatusLast Update
0006525Kali Linux[All Projects] General Bugpublic2020-07-22 09:07
Reporterm1ker1n Assigned Todaniruiz  
PrioritynoneSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006525: Little problem when I drag my files from Desktop on terminal.
DescriptionThere's a little bug, I suppose it's all because of language (in my situation it's Russian). In English Desktop is "Desktop", in Russian Desktop is "Рабочий стол". As we can see it has a space between words so when I drag my file called test on terminal " " (space) remains " " not "\ ". Since that file can't be executed. System tries to find directory "Рабочий" but it doesn't exist.
Steps To ReproduceThis bug can be reproduced only using Russian. Just drag any file from Desktop to terminal.

Activities

m1ker1n

2020-06-27 13:28

reporter  

image.png (15,299 bytes)
image.png (15,299 bytes)

daniruiz

2020-07-22 09:07

developer   ~0013102

The issue here is not the language but the space in the file's name. You need to wrap it between quotes or scape the space as in the second example with '\ '.
Some terminals (like gnome-terminal) add the quotes automatically, but others (like qterminal or konsole) do not. This is not an issue, just a different behavior. As a suggestion, I recommend avoiding spaces inside file names that you're going to use from the terminal.

Issue History

Date Modified Username Field Change
2020-06-27 13:28 m1ker1n New Issue
2020-06-27 13:28 m1ker1n File Added: image.png
2020-07-22 09:07 daniruiz Note Added: 0013102
2020-07-22 09:07 daniruiz Assigned To => daniruiz
2020-07-22 09:07 daniruiz Status new => closed
2020-07-22 09:07 daniruiz Resolution open => no change required