View Issue Details

IDProjectCategoryView StatusLast Update
0006596Kali Linux[All Projects] Kali Package Bugpublic2020-07-23 14:54
Reporterdejandayoff Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006596: Bettercap Web UI Results in 404
DescriptionThe Bettercap package provided in the Kali repo always results in a "404 page not found" error when attempting to use the Web UI. The issue is also discussed here: https://github.com/bettercap/bettercap/issues/731
Steps To Reproduce1) Run the following:
```
sudo apt install bettercap
sudo bettercap -eval "caplets.update; ui.update; q"
sudo bettercap -caplet http-ui
curl 127.0.0.1
```

2) Observe 404 Response
Additional InformationI was able to get this to work by running the following to install from source:

```
sudo apt-get install golang
export GOPATH=$HOME/go
source ~/.bashrc
sudo apt-get install libpcap-dev build-essential libusb-1.0-0-dev libnetfilter-queue-dev
go get github.com/bettercap/bettercap
cd $GOPATH/src/github.com/bettercap/bettercap
make build
sudo make install
sudo bettercap -eval "caplets.update; ui.update; q"
sudo bettercap -caplet http-ui
curl 127.0.0.1
```

Activities

sbrun

2020-07-23 08:56

manager   ~0013117

the issue occurs because the package bettercap-ui is not installed by bettercap or by bettercap-caplets.
And the command sudo bettercap -eval "caplets.update; ui.update; q" does nothing in Kali because we disabled the install / update.
The installation or update must be done with apt.

I added bettercap-ui as a dependency of bettercap-caplets package: issue is fixed in version 0+git20200413-0kali2 of bettercap-caplets.

I will try to update bettecap to display a message when you use the update command outside the interactive bettercap shell.

sbrun

2020-07-23 12:10

manager   ~0013119

bettercap-ui is broken too, I will fix it quickly.

sbrun

2020-07-23 14:54

manager   ~0013120

bettercap-ui fixed in version 1.3.0+really1.3.0-0kali1
bettercap fixed in version 2.28-0kali2

Issue History

Date Modified Username Field Change
2020-07-22 21:20 dejandayoff New Issue
2020-07-22 21:34 Gamb1t Assigned To => sbrun
2020-07-22 21:34 Gamb1t Status new => assigned
2020-07-23 08:56 sbrun Note Added: 0013117
2020-07-23 12:10 sbrun Note Added: 0013119
2020-07-23 14:54 sbrun Note Added: 0013120
2020-07-23 14:54 sbrun Status assigned => resolved
2020-07-23 14:54 sbrun Resolution open => fixed