View Issue Details

IDProjectCategoryView StatusLast Update
0006610Kali Linux[All Projects] General Bugpublic2020-07-30 15:08
Reporterazamet Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0006610: ERROR: Failed to build gem native extension.
Descriptionif i try to update my gems i get this error :-/
Steps To Reproducesudo gem update
Updating installed gems
Updating openssl
Building native extensions. This could take a while...
ERROR: Error installing openssl:
        ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.7.0/gems/openssl-2.2.0/ext/openssl
/usr/bin/ruby2.7 -I /usr/local/lib/site_ruby/2.7.0 -r ./siteconf20200730-30569-1qv444b.rb extconf.rb
checking for t_open() in -lnsl... no
checking for socket() in -lsocket... no
checking for openssl/ssl.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/bin/$(RUBY_BASE_NAME)2.7
        --with-openssl-dir
        --without-openssl-dir
        --with-openssl-include
        --without-openssl-include=${openssl-dir}/include
        --with-openssl-lib
        --without-openssl-lib=${openssl-dir}/lib
        --with-kerberos-dir
        --without-kerberos-dir
        --with-kerberos-include
        --without-kerberos-include=${kerberos-dir}/include
        --with-kerberos-lib
        --without-kerberos-lib=${kerberos-dir}/lib
        --with-debug
        --without-debug
        --enable-debug
        --disable-debug
        --with-nsl-dir
        --without-nsl-dir
        --with-nsl-include
        --without-nsl-include=${nsl-dir}/include
        --with-nsl-lib
        --without-nsl-lib=${nsl-dir}/lib
        --with-nsllib
        --without-nsllib
        --with-socket-dir
        --without-socket-dir
        --with-socket-include
        --without-socket-include=${socket-dir}/include
        --with-socket-lib
        --without-socket-lib=${socket-dir}/lib
        --with-socketlib
        --without-socketlib
        --with-openssl-config
        --without-openssl-config
        --with-pkg-config
        --without-pkg-config
extconf.rb:99:in `<main>': OpenSSL library could not be found. You might want to use --with-openssl-dir=<dir> option to specify the prefix where OpenSSL is installed. (RuntimeError)

To see why this extension failed to compile, please check the mkmf.log which can be found here:

  /var/lib/gems/2.7.0/extensions/x86_64-linux/2.7.0/openssl-2.2.0/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.7.0/gems/openssl-2.2.0 for inspection.
Results logged to /var/lib/gems/2.7.0/extensions/x86_64-linux/2.7.0/openssl-2.2.0/gem_make.out
Gems updated: openssl

Activities

azamet

2020-07-30 12:40

reporter   ~0013155

im sorry to saying that but it is very hard to get help here about problems but thanks for working for this distro!

sbrun

2020-07-30 15:08

manager   ~0013156

Thank you for your interest in Kali but this is not a bug report. It looks like that you need help and guidance to perform some task.

The log error explains what is missing : " checking for openssl/ssl.h... no", "Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers." and " OpenSSL library could not be found."
You need to install (at least) libssl-dev

If you still have problems with this, we have community support forums on http://forums.kali.org or on IRC with the #kali-linux channel on irc.freenode.net), please post your questions there.

Issue History

Date Modified Username Field Change
2020-07-30 12:34 azamet New Issue
2020-07-30 12:40 azamet Note Added: 0013155
2020-07-30 15:08 sbrun Assigned To => sbrun
2020-07-30 15:08 sbrun Status new => closed
2020-07-30 15:08 sbrun Resolution open => no change required
2020-07-30 15:08 sbrun Note Added: 0013156