View Issue Details

IDProjectCategoryView StatusLast Update
0006624Kali Linux[All Projects] Kali Package Bugpublic2020-08-10 08:52
Reporterpanys Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2020.2 
Target VersionFixed in Version 
Summary0006624: "WARNING: The Redis Database doesn't exist"
DescriptionWhen I try gvm-check-setup,and i get a warning "The Redis Database doesn't exist".And I check the script found that it woult created a redis database openvas-dump.rdb.So I do "runuser -u _gvm -- ls /var/lib/redis | grep openvas-dump.rdb" ,and I didn't get this database in infact.

Activities

panys

2020-08-06 07:57

reporter  

image.png (51,706 bytes)
image.png (51,706 bytes)

sbrun

2020-08-06 08:30

manager   ~0013205

Thanks for the report.

The issue is in the gvm-check-setup: we recently changed the redis configuration (/etc/redis/redis-openvas.conf) to not save the redis DB on disk, as upstream suggests.
So it's ok if you don't have the /var/lib/redis/openvas-dump.rdb

I removed this check in the gvm version 11.0.2_kali3. It will be available soon in Kali.

panys

2020-08-06 08:45

reporter   ~0013206

So the check work break is ok?Can't I delete this check in the script to continue check the next step?

sbrun

2020-08-06 08:50

manager   ~0013207

Yes you can remove this Redis DB check to continue to next step.

kali-bugreport

2020-08-08 06:45

reporter   ~0013249

@sbrun:

Instead of using the openvas-dump.tdb to check if the redis server is accessible you could do the following instead and check if it is returning "PONG":

redis-cli -s /var/run/redis-openvas/redis-server.sock ping

Issue History

Date Modified Username Field Change
2020-08-06 07:57 panys New Issue
2020-08-06 07:57 panys File Added: image.png
2020-08-06 08:30 sbrun Assigned To => sbrun
2020-08-06 08:30 sbrun Status new => resolved
2020-08-06 08:30 sbrun Resolution open => fixed
2020-08-06 08:30 sbrun Note Added: 0013205
2020-08-06 08:45 panys Status resolved => feedback
2020-08-06 08:45 panys Resolution fixed => reopened
2020-08-06 08:45 panys Note Added: 0013206
2020-08-06 08:50 sbrun Note Added: 0013207
2020-08-08 06:45 kali-bugreport Note Added: 0013249
2020-08-10 08:52 sbrun Status feedback => resolved
2020-08-10 08:52 sbrun Resolution reopened => fixed