View Issue Details

IDProjectCategoryView StatusLast Update
0006629Kali LinuxKali Package Bugpublic2023-10-10 12:28
Reportervanguard Assigned Tosbrun  
Status closedResolutionfixed 
Summary0006629: Missing package lilo is blocking build

Dear maintainers,

with the change from openvas to gvm it was time for me, to build a new livefilesystem for me. As usual I am building for amd64 and i386.

But this time, I can not complete the build, as I fell into an issue: The package lilo is no more in the repo, but required.

Could you update your preferences in git, if possible?

Second thing (there is already a bugreport existent), could you check, if the default user and password are still kali / kali in the git? At last build neither kali / kali worked, nor the default password for root in the livesystem.

Steps To Reproduce
  1. Updated my git clone using "git pull origin master"
  2. Executed command the following script:


Author Hans-J. Ullrich <[email protected]>

License: GPL

Set some variables, not active yet.

architecture: i386, amd64, arm


Distribution, you might not want to change it.


Your preferred window-manager: lxde, kde, xfce, gnome


Environmet for your local proxy


language, keyboard, locales everything you might not need to change

BOOTAPP="boot=live noconfig=sudo username=root hostname=kali ignore_uuid locales=de_DE.UTF-8 keyboard-layouts=de keyboard-variants=nodeadkeys"

Clean your system, not really necessarey, as the latter "./" does

this either.

lb clean

VERY IMPORTANT: Make sure, apt-cacher is started, even, if you are sure,

it is already running!

/etc/init.d/apt-cacher-ng stop && sleep 3 && /etc/init.d/apt-cacher-ng start

set your needed environment and preparations.

export http_proxy=http://localhost:3142/
lb config

This command starts the actual build. All commands are in one line.

However, this script might be improved, to use variables for better

configuration possibilities.

./ --arch $ARCH --distribution $DISTRO --variant $VARIANT --verbose -- --apt-http-proxy $PROXY --bootappend-live "$BOOTAPP"

these options can be used for further commands after build

for example, if you want to burn a dvd, shutdown, whatever

Examples for my personal needs below

#/etc/init.d/apt-cacher-ng stop

Suggestions for handling the built image.

cp /home/username/live-build-config/images/*.iso /home/user/

wodim /path_to_your_live_build/live-build-config/images/your_image_name.iso

Some opportunities at unattended build run, what to do after the build succeeded.

halt -p


shutdown -h now

See attached build.log please.

This issue appeared in amd64 and i386 as well.

Thank you for any hints.

Attached Files
build.log (1,219,353 bytes)




2020-08-07 10:56

manager   ~0013238

lilo is back to kali-rolling. It should be fixed soon (it can take a few hours before it's fixed on your mirror)



2020-08-07 17:26

reporter   ~0013243

Thanks for the fix and the fast response. The problem with lilo is fixed, the build worked fine. During the build I had a little issue, as the screen went off. That was weired, but the reason is, that during the build the NVidia-modules were built and astonishingly loaded by the kernel. Why? Do not know. As my Nvidia-card is not supported by this version, the screen went blank, but the build went on. I know about this behaviour dfrom the past - nbo bug!

@sbrun Could you please check the default username and password in the git for me? The documentation on the website says it is user kali and password kali, but that does not work. Tried also vagrant / vagrant , but no success. Also please check for the default password of root, as it is no more toor. Which one is it? I believe, these are somehow not correct preset in the git or I missed something.

You can close this bugreport at your will. Thanks for all the help!



2020-08-07 19:02

manager   ~0013246

We didn't change the default username and password. It's still kali / kali.

Issue History

Date Modified Username Field Change
2020-08-07 10:16 vanguard New Issue
2020-08-07 10:16 vanguard File Added: build.log
2020-08-07 10:48 sbrun Assigned To => sbrun
2020-08-07 10:48 sbrun Status new => assigned
2020-08-07 10:56 sbrun Note Added: 0013238
2020-08-07 17:26 vanguard Note Added: 0013243
2020-08-07 19:02 sbrun Status assigned => resolved
2020-08-07 19:02 sbrun Resolution open => fixed
2020-08-07 19:02 sbrun Note Added: 0013246
2023-10-10 12:28 vanguard Status resolved => closed