View Issue Details

IDProjectCategoryView StatusLast Update
0006630Kali Linux[All Projects] General Bugpublic2020-09-02 13:04
Reporterundulynoted Assigned Todaniruiz  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2020.2 
Target VersionFixed in Version2020.3 
Summary0006630: Deleting characters in command used in terminal causes weird visual issues.
DescriptionWhen pressing the up key in any terminal emulator, including Xterm, the first 20 odd characters of the previous command are left on the command line. Also, when you press the left key to go back to a character in a command, weird things happen where the line replicates above the current line.

Activities

undulynoted

2020-08-07 10:49

reporter  

2020-08-07_20-49.png (30,683 bytes)
2020-08-07_20-49.png (30,683 bytes)

kali-bugreport

2020-08-08 21:07

reporter   ~0013256

Looks more like a candidate for a bugreport to the upstream issue tracker of the used terminal

undulynoted

2020-08-13 02:11

reporter   ~0013273

At first glance you are correct, however it also happens in Xterm and Terminator.

daniruiz

2020-09-02 13:04

developer   ~0013381

This was caused by an issue with the prompt string $PS1. It is fixed now, just update and copy the file /etc/skel/.bashrc to your local directory

Issue History

Date Modified Username Field Change
2020-08-07 10:49 undulynoted New Issue
2020-08-07 10:49 undulynoted File Added: 2020-08-07_20-49.png
2020-08-08 21:07 kali-bugreport Note Added: 0013256
2020-08-13 02:11 undulynoted Note Added: 0013273
2020-09-02 13:04 daniruiz Note Added: 0013381
2020-09-02 13:04 daniruiz Assigned To => daniruiz
2020-09-02 13:04 daniruiz Status new => resolved
2020-09-02 13:04 daniruiz Resolution open => fixed
2020-09-02 13:04 daniruiz Fixed in Version => 2020.3