View Issue Details

IDProjectCategoryView StatusLast Update
0006664Kali Linux[All Projects] General Bugpublic2020-09-21 18:27
Reporterghostpapper Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version2020.3 
Target VersionFixed in Version 
Summary0006664: UI(error): ui_init(), failed to open X11 display:
DescriptionWe are facing problems with Rdesktop and Xfreerdp since version 2020. We have tried several configurations, but without success. I installed the kali 2020-3 and it has the same error. The only version of Kali that we had no problems with was in 2019.
Can anybody help me?
Steps To Reproduceroot@kali:~# xfreerdp /u:administrator /p:134679 /v:140.190.50.12
[ERROR]{[com.freerdp.client.x11] - failed to open display;
[ERROR]{[com.freerdp.client.x11] - Please check that the $DISPLAY enviroviment variable is properly set.

or


root@kali:~# rdesktop 140.190.50.12
Autoselecting keyboard map 'pt-br' from locale
UI(error): ui_init(), failed to open X11 display:

Activities

ghostpapper

2020-08-20 02:04

reporter  

01.PNG (13,846 bytes)
01.PNG (13,846 bytes)
02.PNG (26,799 bytes)
02.PNG (26,799 bytes)

ghostpapper

2020-09-19 20:15

reporter   ~0013459

Can anyone help in this matter?

Michu

2020-09-20 16:14

reporter   ~0013462

what output this command is giving (echo $DISPLAY)

Michu

2020-09-20 16:17

reporter   ~0013463

also had you tried this :
    su root
    xdpyinfo
    find the string behind "name of display" e.g., name of display:127.0.0.1:1.0 (which is "1.0")
    export DISPLAY=:1.0

ghostpapper

2020-09-21 12:56

reporter   ~0013469

I tried several ways and I can't. In kali 2019-3 it works perfectly. In Kali 2020, however, no known way worked.
I upgraded from 2019 to 2020-3 and stopped working. So now I'm using 2 kali linux. This is very unproductive.

image.png (66,731 bytes)
image.png (66,731 bytes)
image-2.png (74,317 bytes)
image-2.png (74,317 bytes)

Michu

2020-09-21 18:16

reporter   ~0013471

that's weird because when i echo variable $DISPLAY i get :1
try this (export DISPLAY=<your.own.ip>:0.0)

ghostpapper

2020-09-21 18:27

reporter   ~0013472

It really is very strange. Já tentei several forms and not with it. He thought it might be a BUG in some Gnome or Kali service.

image-3.png (113,514 bytes)
image-3.png (113,514 bytes)

Issue History

Date Modified Username Field Change
2020-08-20 02:04 ghostpapper New Issue
2020-08-20 02:04 ghostpapper File Added: 01.PNG
2020-08-20 02:04 ghostpapper File Added: 02.PNG
2020-09-19 20:15 ghostpapper Note Added: 0013459
2020-09-20 16:14 Michu Note Added: 0013462
2020-09-20 16:17 Michu Note Added: 0013463
2020-09-21 12:56 ghostpapper File Added: image.png
2020-09-21 12:56 ghostpapper File Added: image-2.png
2020-09-21 12:56 ghostpapper Note Added: 0013469
2020-09-21 18:16 Michu Note Added: 0013471
2020-09-21 18:27 ghostpapper File Added: image-3.png
2020-09-21 18:27 ghostpapper Note Added: 0013472