View Issue Details

IDProjectCategoryView StatusLast Update
0006747Kali Linux[All Projects] Feature Requestspublic2020-09-24 12:06
ReporterZealot Assigned Todaniruiz  
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0006747: pacman
Descriptionok i known apt for dbian
but apt is so slow and pacman is so fast
and pacman use for arch linux
if you know black arch & arch strike have so hacking tools
if you can add pacman to kali linux
it so good to add mirror of arch for kali
Steps To Reproducehttps://ostechnix.com/deb-pacman-a-pacman-style-frontend-for-apt-package-manager/
it is link that say how to add pacman to kali
but it can't add mirror of black arch or arch strike
And that was the only way
The system was renamed from Kali Linux to Arch Linux
And again, the problem with downloading Black Arch and Arch Strike was changing the name of the system
Additional Information1.add pacman and blackman and pacstrap to kali
2.add mirror of pacman and there systems
3.add smsc and ss7 for kali
4.ss7 have problem with kali

Activities

Zealot

2020-09-24 03:30

reporter  

daniruiz

2020-09-24 12:02

developer   ~0013485

I'm sorry but pacman can't work on Debian, as a package manager is highly tied to the distribution it comes with. They just use different repositories and different package formats, it wouldn't make sense to mix them. Plus, I don't know where you get that apt is slower, pacman can be faster sometimes but that's because it has to manage fewer dependencies, and the difference is insignificant. Belive me, I'm an arch and Kali user. And apt is way more user friendly


In fact, what you sent to provide pacman on Debian is an APT wrapper, this means, it gives you the syntax of pacman, but it's still apt.

Issue History

Date Modified Username Field Change
2020-09-24 03:30 Zealot New Issue
2020-09-24 03:30 Zealot File Added: Screenshot from 2020-09-23 23-30-06.png
2020-09-24 12:02 daniruiz Note Added: 0013485
2020-09-24 12:06 daniruiz Assigned To => daniruiz
2020-09-24 12:06 daniruiz Status new => closed
2020-09-24 12:06 daniruiz Resolution open => won't fix