View Issue Details

IDProjectCategoryView StatusLast Update
0007018Kali Linux[All Projects] Kali Package Bugpublic2021-02-18 14:35
Reportershubhanshu Assigned Tosbrun  
PriorityurgentSeveritymajorReproducibilitysometimes
Status closedResolutionunable to reproduce 
Product Version2020.4 
Target VersionFixed in Version 
Summary0007018: Powershell empire does not work after upgrade.
DescriptionAfter apt dist-upgrade powershell-empire fails to start with following error:

user@ap0calypse:~$ sudo powershell-empire
[sudo] password for user:
[*] Loading stagers from: /usr/share/powershell-empire/lib/stagers/
Traceback (most recent call last):
  File "/usr/share/powershell-empire/./empire", line 1924, in <module>
    main = empire.MainMenu(args=args)
  File "/usr/share/powershell-empire/lib/common/empire.py", line 133, in __init__
    self.stagers = stagers.Stagers(self, args=args)
  File "/usr/share/powershell-empire/lib/common/stagers.py", line 52, in __init__
    self.load_stagers()
  File "/usr/share/powershell-empire/lib/common/stagers.py", line 79, in load_stagers
    spec.loader.exec_module(mod)
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/share/powershell-empire/lib/stagers/windows/backdoorLnkMacro.py", line 13, in <module>
    from xlutils.copy import copy
  File "/usr/lib/python3/dist-packages/xlutils/copy.py", line 7, in <module>
    from xlutils.filter import process,XLRDReader,XLWTWriter
  File "/usr/lib/python3/dist-packages/xlutils/filter.py", line 10, in <module>
    import xlrd,xlwt
  File "/usr/local/lib/python3.9/dist-packages/xlwt/__init__.py", line 5, in <module>
    from .Row import Row
  File "/usr/local/lib/python3.9/dist-packages/xlwt/Row.py", line 9, in <module>
    from . import ExcelFormula
  File "/usr/local/lib/python3.9/dist-packages/xlwt/ExcelFormula.py", line 8, in <module>
    from . import ExcelFormulaParser, ExcelFormulaLexer
  File "/usr/local/lib/python3.9/dist-packages/xlwt/ExcelFormulaLexer.py", line 53, in <module>
    _re = recompile(
  File "/usr/lib/python3.9/re.py", line 252, in compile
    return _compile(pattern, flags)
  File "/usr/lib/python3.9/re.py", line 304, in _compile
    p = sre_compile.compile(pattern, flags)
  File "/usr/lib/python3.9/sre_compile.py", line 764, in compile
    p = sre_parse.parse(p, flags)
  File "/usr/lib/python3.9/sre_parse.py", line 958, in parse
    p.state.flags = fix_flags(str, p.state.flags)
  File "/usr/lib/python3.9/sre_parse.py", line 925, in fix_flags
    raise ValueError("cannot use LOCALE flag with a str pattern")
ValueError: cannot use LOCALE flag with a str pattern
Steps To Reproducesudo powershell-empire
Additional InformationRecently I upgraded my system and python upgraded from python 3.8 - python 3.9. Since then powershell-empire does not work.

Activities

shubhanshu

2021-01-30 12:31

reporter  

Screenshot from 2021-01-30 18-01-35.png (270,685 bytes)

sbrun

2021-02-03 14:31

manager   ~0014195

I don't reproduce this issue with a basic installation.

I noticed that you have at least on Python module in /usr/local/lib/python3.9.
You can try to remove this module xlwt so that the Kali packaged module will be used instead of the manually installed version.

Issue History

Date Modified Username Field Change
2021-01-30 12:31 shubhanshu New Issue
2021-01-30 12:31 shubhanshu File Added: Screenshot from 2021-01-30 18-01-35.png
2021-02-03 14:31 sbrun Assigned To => sbrun
2021-02-03 14:31 sbrun Status new => feedback
2021-02-03 14:31 sbrun Note Added: 0014195
2021-02-18 14:35 sbrun Status feedback => closed
2021-02-18 14:35 sbrun Resolution open => unable to reproduce