View Issue Details

IDProjectCategoryView StatusLast Update
0007077Kali Linux[All Projects] Kali Package Bugpublic2021-06-10 08:52
ReporterRoseDeSable Assigned Tosbrun  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0007077: gvmd doesn't start - version of lib is higher than the servers's
DescriptionHi,
 in the logfile "/var/log/gvm/gvmd.log" I find, that the version of the server module "/usr/lib/libgvm-pg-server.so" is on version 12, but the lib's version is on 13. Here are the lib-modules:

#ls -l libgvm*
lrwxrwxrwx 1 root root 22 3. Feb 15:42 libgvm-pg-server.so -> libgvm-pg-server.so.20
lrwxrwxrwx 1 root root 27 3. Feb 15:42 libgvm-pg-server.so.20 -> libgvm-pg-server.so.20.08.1
-rw-r--r-- 1 root root 38896 3. Feb 15:42 libgvm-pg-server.so.20.08.1

Bye
Rose

Activities

sbrun

2021-03-09 11:27

manager   ~0014297

Thanks for the report but I need more informations:
- please the copy the error from the logfile "/var/log/gvm/gvmd.log"
- please give us the version of gvmd
- did you run gvm-check-setup?

The versions 12 and 13 you mentioned make me think you have an issue with postgresql version:
gvmd have been compiled with postgresql 13 and you have an older postgresql version using the default port 5432.
gvm-check-setup will check this for you or you can run "pg_lsclusters" to see which version is on port 5432.

RoseDeSable

2021-03-09 12:38

reporter   ~0014298

Hello,
 it seems to be a problem with postgresql. I'm running version 12 and 13 an two seperate ports:

12 main 5432 online postgres /var/lib/postgresql/12/main /var/log/postgresql/postgresql-12-main.log
13 main 5433 online postgres /var/lib/postgresql/13/main /var/log/postgresql/postgresql-13-main.log

But chanching the port numbers for version 13 doesn't resolve my problem.

sbrun

2021-03-09 13:44

manager   ~0014299

it's not a problem, it's the "normal behaviour" of postgresql:
when you upgrade postgresql, the default port 5432 remains on the cluster of the "old" postgresql version. The newest version cluster uses another port.

It requires a user action to upgrade the clusters.
How did you change the port numbers?
To upgrade you need to use the pg_upgradecluster command.
But before that you may need to remove the empty cluster of newest postgresql version.
You can find some explanations here:
https://praderas.org/en/upgrading-postgresql-13-debian-stretch
See paragraph "Upgrading cluster"

RoseDeSable

2021-03-10 09:04

reporter   ~0014307

Ok,
 first I successfully migrate the databasecluster from postgresql version 12 to 13. After starting gvmd I receive the message "main:CRITICAL:2021-03-10 08h25.40 utc:99013: gvmd: database is wrong version". Therfore I migrate the gvmd-database with "gvmd -migrate". Successfully. I tried to start gvmd without success, because ownly the owner of the database may run the aggregate function "group_concat". What's now ?

RoseDeSable

2021-03-30 13:26

reporter   ~0014423

A nice day,
 I log into the database gvmd with "psql gvmd" unter the user postgres. The command "\df+ group_concat" shows me the definition of the function. Here I find out, that the owner of the function is "root". I change it to "_gvm" with "ALTER FUNCTION group_concat OWNER TO _gvm;" and the Greenbone Security Assistant is completely running.

Bye
Rose

Issue History

Date Modified Username Field Change
2021-03-04 11:08 RoseDeSable New Issue
2021-03-09 11:27 sbrun Assigned To => sbrun
2021-03-09 11:27 sbrun Status new => feedback
2021-03-09 11:27 sbrun Note Added: 0014297
2021-03-09 12:38 RoseDeSable Note Added: 0014298
2021-03-09 12:38 RoseDeSable Status feedback => assigned
2021-03-09 13:44 sbrun Note Added: 0014299
2021-03-10 09:04 RoseDeSable Note Added: 0014307
2021-03-30 13:26 RoseDeSable Note Added: 0014423
2021-06-10 08:52 sbrun Status assigned => closed
2021-06-10 08:52 sbrun Resolution open => no change required