View Issue Details

IDProjectCategoryView StatusLast Update
0007279Kali LinuxKali Package Bugpublic2023-10-10 12:24
Reportervanguard Assigned Tosbrun  
Status closedResolutionfixed 
Product Version2021.2 
Fixed in Version2021.3 
Summary0007279: gvm - script "gvm-check-setup" version problem

Dear maintrainers,

I believe, there is a little bug at Step 6 in the script "gvm-check-setup" of package gvm.

Please take a look at the last output:

----- snip -------------------

    OK: At least one user exists.

Step 6: Checking Greenbone Security Assistant (GSA) ...
Oops, secure memory pool already initialized
ERROR: Greenbone Security Assistant too old or too new: 21.4.1~dev1
FIX: Please install Greenbone Security Assistant >= 21.04.

ERROR: Your GVM-21.4.1 installation is not yet complete!

Please follow the instructions marked with FIX above and run this

--------- snap ---------------

As you see, I have installed version 21.4, which is (as recommended) higher or equal than 21.04 .
If I am not wrong, this should work.

dpkg -s greenbone-security-assistant | grep Version
Version: 21.4.1-0kali1

Maybe I am not correctly understanding the versionary structure, but 21.4. shoud be the same as 21.04, isn't it?

A workaround is, just to comment Step 6 out, when you are sure, you have installed the correct version of greenbone-security-assistant.

Just a minor issue, but maybe you might want to fix it though.

Best regards





2021-08-12 18:09

manager   ~0014997

See Can you try it and tell me if it solves the issue?



2021-08-12 21:44

reporter   ~0014999

This worked. Already thought, this is just a typo and in the meantime, found already the solution. However, if a solution is working for me, this does not mean,
it will work for others.

So it is best, if the change in the script will be added in the next version, so everybody can easily update.

I suggest, if you just fix this little typo and build a new package, this little issue is solved and can safely be closed.

For those, who just do not want to wait, here is the fix from the community blog:

sed -i"" 's/GSA_MAJOR="21.04"/GSA_MAJOR="21.4"/g' $(which gvm-check-setup)

Thanks for the fast help!

Best regards




2021-08-23 12:20

manager   ~0015015

fixed in gvm version

Issue History

Date Modified Username Field Change
2021-08-08 11:04 vanguard New Issue
2021-08-12 18:09 arnaudr Note Added: 0014997
2021-08-12 18:10 arnaudr Status new => confirmed
2021-08-12 18:16 arnaudr Assigned To => sbrun
2021-08-12 18:16 arnaudr Status confirmed => assigned
2021-08-12 21:44 vanguard Note Added: 0014999
2021-08-23 12:20 sbrun Note Added: 0015015
2021-08-23 12:20 sbrun Status assigned => resolved
2021-08-23 12:20 sbrun Resolution open => fixed
2021-08-23 12:20 sbrun Fixed in Version => 2021.3
2023-10-10 12:24 vanguard Status resolved => closed