View Issue Details

IDProjectCategoryView StatusLast Update
0007441Kali Linux[All Projects] General Bugpublic2021-12-03 17:25
ReporterAlexandros_Adamos Assigned ToGamb1t  
PrioritynormalSeverityminorReproducibilityalways
Status feedbackResolutionreopened 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007441: keyboard layout (language changer)
DescriptionUpgrade to the last version.
Have at least two languages for your keyboard.
Try to change keyboard layout using ALT+SHIFT
Steps To ReproduceUpgrade to the last version.
Have at least two languages for your keyboard.
Try to change keyboard layout using ALT+SHIFT

Activities

Gamb1t

2021-11-11 01:25

manager   ~0015428

Thank you for your interest in Kali but this is not a bug report. It looks like that you need help and guidance to perform some task. We have community support forums on https://forums.kali.org/ or on IRC with the #kali-linux channel on irc.oftc.net), please post your questions there.

However, FWIW, the button combination you use needs to be set. Once you set it to 'ALT+SHIFT' you should have no issues. You can set it in the keyboard language settings.

Alexandros_Adamos

2021-11-11 20:55

reporter   ~0015430

Thanks for your explanation but I'm not a new computer user. I have worked with these systems for almost twenty years, so I know how to switch languages ​​using the keyboard.

Unfortunately, I have seen many times recently that the information entered is not checked correctly by the review team.

There is an issue. Let me give you an example. If you set up the English and the Arabic keyboard layout in the latest version of Kali, the switcher will not work correctly.

The text will be in English as soon as you type. By pressing the change language key, no change will occur. You have to do it twice to switch to the second language.

It is a problem because to change the keyboard layout, you need to press the keys once. Also, the language icon at the top of the screen has to be changed, but it is no change.

How can I send you the screen record of this issue?

Gamb1t

2021-11-11 21:35

manager   ~0015431

I have just tried to reproduce this again and unfortunately am unable to have the issue that you have stated. You can use Vimeo to share what you are seeing.

Alexandros_Adamos

2021-11-30 20:04

reporter   ~0015458

It's on the Wayland. I was tasted on the Wayland. But on the Gnome Xorg, everything is fine. Are you on the Wayland or Xorg?

arnaudr

2021-12-02 10:15

manager   ~0015463

Out of curiosity: did you switch to Wayland, or was it like that by default?

The background story is that Kali goes with Xorg by default. However for a few days or weeks, due to a misconfiguration Wayland became the default for GNOME desktop. It could be that you picked a Kali weekly image at this moment, or maybe an update of your kali-rolling install switched the default to Wayland. But we fixed that, so if you update you should be back to using Xorg. Then the problem might just go away?

Alexandros_Adamos

2021-12-02 14:04

reporter   ~0015468

I updated Kali. -5.14.0-kali2-amd64 0000001 SMP Debian 5.14.9-2kali1 (2021-10-04) x86_64 GNU/Linux-
There was a problem changing the keyboard language after the update.
I checked and found out that I am on GNOME Wayland by default. I changed the environment to Xorg and the problems were solved.

arnaudr

2021-12-03 02:25

manager   ~0015469

Good to hear that! I'm closing this issue then. Thanks!

Alexandros_Adamos

2021-12-03 17:25

reporter   ~0015473

OK, Thank you but Please note that there is still the issue on the Wayland.

Issue History

Date Modified Username Field Change
2021-11-06 17:43 Alexandros_Adamos New Issue
2021-11-11 01:25 Gamb1t Assigned To => Gamb1t
2021-11-11 01:25 Gamb1t Status new => closed
2021-11-11 01:25 Gamb1t Resolution open => unable to reproduce
2021-11-11 01:25 Gamb1t Note Added: 0015428
2021-11-11 20:55 Alexandros_Adamos Status closed => feedback
2021-11-11 20:55 Alexandros_Adamos Resolution unable to reproduce => reopened
2021-11-11 20:55 Alexandros_Adamos Note Added: 0015430
2021-11-11 21:35 Gamb1t Note Added: 0015431
2021-11-30 20:04 Alexandros_Adamos Note Added: 0015458
2021-11-30 20:04 Alexandros_Adamos Status feedback => assigned
2021-12-02 10:15 arnaudr Note Added: 0015463
2021-12-02 14:04 Alexandros_Adamos Note Added: 0015468
2021-12-03 02:25 arnaudr Note Added: 0015469
2021-12-03 02:25 arnaudr Status assigned => resolved
2021-12-03 02:25 arnaudr Resolution reopened => fixed
2021-12-03 17:25 Alexandros_Adamos Status resolved => feedback
2021-12-03 17:25 Alexandros_Adamos Resolution fixed => reopened
2021-12-03 17:25 Alexandros_Adamos Note Added: 0015473