View Issue Details

IDProjectCategoryView StatusLast Update
0007447Kali Linux[All Projects] General Bugpublic2022-01-18 09:23
ReporterVT Assigned Todaniruiz  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2021.3 
Target VersionFixed in Version 
Summary0007447: Bug in kernel version linux-image-5.14.0-kali4-amd64
DescriptionMy issue is similar to this one https://bugs.kali.org/view.php?id=7445 but occurs on desktop PC, new kernel update breaks amdgpu, I cannot operate with SMplayer or any web-browser it just freezes... and booting up a system takes a couple of minutes.
Steps To ReproduceI tried to purge and reinstall the kernel but nothing helps, only reverting to previous kernel version resolves the problem.
Additional Informationhere's the output from `dmesg`

`[ 7.176348] r8169 0000:03:00.0 eth0: Link is Down
[ 7.696779] loop20: detected capacity change from 0 to 8
[ 8.799010] r8169 0000:03:00.0 eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[ 8.799030] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[ 9.137277] vboxdrv: loading out-of-tree module taints kernel.
[ 9.145641] vboxdrv: Found 8 processor cores
[ 9.164197] vboxdrv: TSC mode is Invariant, tentative frequency 3692813507 Hz
[ 9.164201] vboxdrv: Successfully loaded version 6.1.28_Debian r147628 (interface 0x00320000)
[ 9.171672] VBoxNetFlt: Successfully started.
[ 9.178432] VBoxNetAdp: Successfully started.
[ 9.280335] cgroup: cgroup: disabling cgroup2 socket matching due to net_prio or net_cls activation
[ 9.670326] wireguard: WireGuard 1.0.0 loaded. See www.wireguard.com for information.
[ 9.670328] wireguard: Copyright (C) 2015-2019 Jason A. Donenfeld <Jason@zx2c4.com>. All Rights Reserved.
[ 25.849227] loop20: detected capacity change from 0 to 126632
[ 28.313889] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 48.322440] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 68.490447] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 88.502445] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 170.518442] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 190.650037] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 201.170428] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 202.270420] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 211.270027] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 221.186354] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 222.310426] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 231.294638] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 241.510484] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 242.614431] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 261.526051] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 262.638044] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 282.806435] amdgpu 0000:08:00.0: amdgpu: failed to write reg 28b4 wait reg 28c6
[ 302.826439] amdgpu 0000:08:00.0: amdgpu: failed to write reg 1a6f4 wait reg 1a706
[ 302.827083] BUG: Bad page map in process mullvad-gu:cs0 pte:00000001 pmd:14bde0067
[ 302.827088] page:00000000277ac75e refcount:1 mapcount:-1 mapping:0000000000000000 index:0x0 pfn:0x0
[ 302.827094] flags: 0x7ffffc0001000(reserved|node=0|zone=0|lastcpupid=0x1fffff)
[ 302.827102] raw: 0007ffffc0001000 fffff87540000008 fffff87540000008 0000000000000000
[ 302.827105] raw: 0000000000000000 0000000000000000 00000001fffffffe 0000000000000000
[ 302.827107] page dumped because: bad pte
[ 302.827108] addr:000055aa31200000 vm_flags:08000875 anon_vma:0000000000000000 mapping:ffff893f76855e98 index:4e44
[ 302.827113] file:mullvad-gui fault:ext4_filemap_fault [ext4] mmap:ext4_file_mmap [ext4] readpage:ext4_readpage [ext4]
[ 302.827263] CPU: 4 PID: 2535 Comm: mullvad-gu:cs0 Tainted: G OE 5.14.0-kali4-amd64 0000001 Debian 5.14.16-1kali1
[ 302.827268] Hardware name: System manufacturer System Product Name/PRIME B450-PLUS, BIOS 1607 06/17/2019
[ 302.827271] Call Trace:
[ 302.827276] dump_stack_lvl+0x46/0x5a
[ 302.827285] print_bad_pte.cold+0x6b/0xc6
[ 302.827291] ? __mod_lruvec_page_state+0x7f/0xa0
[ 302.827299] unmap_page_range+0x749/0xc80
[ 302.827308] unmap_vmas+0x78/0xf0
[ 302.827314] exit_mmap+0x9c/0x1f0
[ 302.827320] mmput+0x56/0x130
[ 302.827325] do_exit+0x2fa/0xa90
[ 302.827330] do_group_exit+0x33/0xa0
[ 302.827336] get_signal+0x170/0x8d0
[ 302.827341] ? amdgpu_cs_find_mapping+0x110/0x110 [amdgpu]
[ 302.827634] arch_do_signal_or_restart+0xf0/0x7a0
[ 302.827641] ? ktime_get_mono_fast_ns+0x4e/0x90
[ 302.827646] exit_to_user_mode_prepare+0x119/0x180
[ 302.827651] syscall_exit_to_user_mode+0x23/0x40
[ 302.827656] do_syscall_64+0x48/0xc0
[ 302.827660] entry_SYSCALL_64_after_hwframe+0x44/0xae
[ 302.827666] RIP: 0033:0x7f7471f3f957
[ 302.827670] Code: Unable to access opcode bytes at RIP 0x7f7471f3f92d.
[ 302.827672] RSP: 002b:00007f7462b7d3c8 EFLAGS: 00000246 ORIG_RAX: 0000000000000010
[ 302.827677] RAX: 0000000000000000 RBX: 00007f7462b7d430 RCX: 00007f7471f3f957
[ 302.827679] RDX: 00007f7462b7d430 RSI: 00000000c0186444 RDI: 0000000000000017
[ 302.827681] RBP: 00000000c0186444 R08: 00007f7462b7d560 R09: 00007f7462b7d508
[ 302.827684] R10: 0000396e000ea300 R11: 0000000000000246 R12: 0000396e001c0000
[ 302.827686] R13: 0000000000000017 R14: 00000000fffffffd R15: 0000396e001ac090
[ 302.827690] Disabling lock debugging due to kernel taint
[ 302.832961] BUG: Bad rss-counter state mm:00000000635aa6d8 type:MM_FILEPAGES val:-1`

Relationships

related to 0007445 resolveddaniruiz linux-image-5.14.0-kali4-amd64 breaks amdgpu 

Activities

VT

2021-12-21 15:39

reporter   ~0015552

This issue is still not fixed, if I upgrade the kernel same issues starting to happen again and as I see keeps happening to other Kali users as well.... I guess we'll just have to wait for newer kernel release 5.15

daniruiz

2022-01-07 09:00

manager   ~0015604

The issue https://bugs.kali.org/view.php?id=7445 was solved with the latest kernel. Does the new version fix the issue for you?

Jey-Be

2022-01-11 15:01

reporter   ~0015623

Actually I wanted to answer to bug id 7486 / last post of daniruiz (same problem like here and 7445), but these bugs are closed already. First of all, thank you very much for finally fixing this long lasting damn amd bug which forced me to use BlackArch because new installations of Kali 2021.4 didn't boot (not even live USB). But as VT already wrote in bug 7486, we would expect a much faster fix, if you really can't test these fundamental things in advance (all AMD users can't boot anymore is not only a small bug) because of manpower and hardware which I understand. But what I really don't understand is, how your team could ignore this big issue for nearly 1.5-2 months and even release 2021.4 although this was reported 1 month before 2021.4 release and a fix being available long time ago in Debian testing (bookworm) as I wrote before->bug fixed much too slow.

I know Kali is for free, but our company really pays much money for OSCP/OSEP/etc. courses for our employees to take your expensive courses which cost tousands of $ and thus also finance the Kali development indirectly. It's really frustrating if you only have a few months (1-3) and can't complete the course as regular because Kali is full of bugs which you have to fix yourself all the time (also the VMware image in the past, so we tried native Kali). Because of that, I'll write to Ms. Rubio of OffSec that our company won't order any Learn One/Unlimited courses at the moment. I hope QA perhaps gets better/faster in the future. Anyway thanks for the hard work your team does, which I appreciate much.

daniruiz

2022-01-18 09:23

manager   ~0015645

Thank you for your feedback. I've shared it with the rest of the Kali team and we had a conversation about how to avoid this happening again. It is true that the issue was hard to find as it only affected laptops with AMD graphic cards, but once the fix was released on Debian it should have arrived to Kali much earlier.

I'm closing this now that's fixed

Issue History

Date Modified Username Field Change
2021-11-17 13:12 VT New Issue
2021-12-21 15:39 VT Note Added: 0015552
2022-01-07 09:00 daniruiz Note Added: 0015604
2022-01-07 09:03 daniruiz Relationship added related to 0007445
2022-01-09 09:47 daniruiz Assigned To => daniruiz
2022-01-09 09:47 daniruiz Status new => assigned
2022-01-11 15:01 Jey-Be Note Added: 0015623
2022-01-18 09:23 daniruiz Note Added: 0015645
2022-01-18 09:23 daniruiz Status assigned => resolved
2022-01-18 09:23 daniruiz Resolution open => fixed