View Issue Details

IDProjectCategoryView StatusLast Update
0007530Kali Linux[All Projects] Kali Package Bugpublic2022-01-28 00:11
ReporterStantheMan Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2021.4 
Target VersionFixed in Version 
Summary0007530: Dpkg: errors on apt update
DescriptionSince I installed Wireguard for my WSL2 Kali-linux with xfce4 desktop, I always get dpkg error processing linux-image
saying
 dpkg: dependency problems prevent configuration of linux-image-cloud-amd64:

Steps To Reproducesudo apt update (or any apt install)

Additional Informationuname -a
Linux CAPTS-CABIN 5.13.0-rc1-next-20210513-microsoft-cbl 0000001 SMP Thu May 13 18:43:09 MST 2021 x86_64 GNU/Linux
❯ sudo apt install -y kali-desktop-xfce
[sudo] password for kali:
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
kali-desktop-xfce is already the newest version (2022.1.0).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-image-5.15.0-kali2-cloud-amd64 (5.15.5-2kali2) ...
I: /initrd.img is now a symlink to boot/initrd.img-5.15.0-kali2-cloud-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.15.0-kali2-cloud-amd64
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.15.0-kali2-cloud-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-5.15.0-kali2-cloud-amd64 (--configure):
 installed linux-image-5.15.0-kali2-cloud-amd64 package post-installation script subprocess returned error exit status 1
Setting up linux-image-5.14.0-kali4-cloud-amd64 (5.14.16-1kali1) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-5.14.0-kali4-cloud-amd64
/etc/kernel/postinst.d/dkms:
dkms: WARNING: Linux headers are missing, which may explain the above failures.
      please install the linux-headers-5.14.0-kali4-cloud-amd64 package to fix this.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.14.0-kali4-cloud-amd64
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.14.0-kali4-cloud-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-5.14.0-kali4-cloud-amd64 (--configure):
 installed linux-image-5.14.0-kali4-cloud-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-cloud-amd64:
 linux-image-cloud-amd64 depends on linux-image-5.15.0-kali2-cloud-amd64 (= 5.15.5-2kali2); however:
  Package linux-image-5.15.0-kali2-cloud-amd64 is not configured yet.

dpkg: error processing package linux-image-cloud-amd64 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-5.15.0-kali2-cloud-amd64
 linux-image-5.14.0-kali4-cloud-amd64
 linux-image-cloud-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

Activities

antbhlk

2022-01-12 10:47

reporter   ~0015630

fix

Whiteboy_hacker

2022-01-20 03:16

reporter   ~0015656

sudo dpkg --configure -a
This should fix it

StantheMan

2022-01-20 10:00

reporter   ~0015658

Sorry whiteboy

the dpkg configure idea gives the same inconsistency?


sudo dpkg --configure -a
[sudo] password for kali:
Setting up linux-image-5.15.0-kali2-cloud-amd64 (5.15.5-2kali2) ...
I: /initrd.img is now a symlink to boot/initrd.img-5.15.0-kali2-cloud-amd64
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.15.0-kali2-cloud-amd64
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.15.0-kali2-cloud-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-5.15.0-kali2-cloud-amd64 (--configure):
 installed linux-image-5.15.0-kali2-cloud-amd64 package post-installation script subprocess returned error exit status 1
Setting up linux-image-5.14.0-kali4-cloud-amd64 (5.14.16-1kali1) ...
I: /initrd.img.old is now a symlink to boot/initrd.img-5.14.0-kali4-cloud-amd64
/etc/kernel/postinst.d/dkms:
dkms: WARNING: Linux headers are missing, which may explain the above failures.
      please install the linux-headers-5.14.0-kali4-cloud-amd64 package to fix this.
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.14.0-kali4-cloud-amd64
E: /usr/share/initramfs-tools/hooks/plymouth failed with return 1.
update-initramfs: failed for /boot/initrd.img-5.14.0-kali4-cloud-amd64 with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-5.14.0-kali4-cloud-amd64 (--configure):
 installed linux-image-5.14.0-kali4-cloud-amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-cloud-amd64:
 linux-image-cloud-amd64 depends on linux-image-5.15.0-kali2-cloud-amd64 (= 5.15.5-2kali2); however:
  Package linux-image-5.15.0-kali2-cloud-amd64 is not configured yet.

dpkg: error processing package linux-image-cloud-amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of wireguard:
 wireguard depends on wireguard-modules (>= 0.0.20191219) | wireguard-dkms (>= 0.0.20200121-2); however:
  Package wireguard-modules is not installed.
  Package linux-image-cloud-amd64 which provides wireguard-modules is not configured yet.
  Package wireguard-dkms is not installed.

dpkg: error processing package wireguard (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-image-5.15.0-kali2-cloud-amd64
 linux-image-5.14.0-kali4-cloud-amd64
 linux-image-cloud-amd64
 wireguard

Whiteboy_hacker

2022-01-20 14:04

reporter   ~0015659

sudo apt remove wireguard-dkms --purge && sudo apt autoremove -y && sudo apt update -y
This should fix it

steev

2022-01-28 00:11

manager   ~0015672

Also note that the kernel used by WSL is *not* something from Kali, and it is unlikely you will be able to run the wireguard module inside it. Your best bet is to likely use a windows wireguard implementation.

Issue History

Date Modified Username Field Change
2022-01-08 12:04 StantheMan New Issue
2022-01-12 10:47 antbhlk Note Added: 0015630
2022-01-20 03:16 Whiteboy_hacker Note Added: 0015656
2022-01-20 10:00 StantheMan Note Added: 0015658
2022-01-20 14:04 Whiteboy_hacker Note Added: 0015659
2022-01-28 00:11 steev Note Added: 0015672