View Issue Details

IDProjectCategoryView StatusLast Update
0007716Kali Linux[All Projects] General Bugpublic2022-05-20 14:22
Reporterfaceless Assigned Todaniruiz  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version2022.2 
Target VersionFixed in Version 
Summary0007716: Soundcard not fully recognized by system
DescriptionYesterday I had to reinstall Kali on a new device because the memory of my old notebook failed.
Now I am running into the issue, that whatever I do (tried for more than 5 hours with several different forums) my soundcard is not fully
recognized by the system and I don't have ANY sound.

Below a few outputs of commands I used to analyze this:

sudo dmesg |grep snd
[ 8.215362] snd_hda_intel 0000:00:1f.3: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead
[ 8.215376] snd_hda_intel 0000:00:1f.3: enabling device (0000 -> 0002)
[ 8.215530] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[ 8.230105] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230127] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230147] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230168] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230189] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230209] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230230] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230251] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230273] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 8.230293] snd_hda_intel 0000:00:1f.3: spurious response 0x0:0x0, last cmd=0xfff0005
[ 9.240141] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to polling mode: last cmd=0x200f0000
[ 10.252150] snd_hda_intel 0000:00:1f.3: No response from codec, disabling MSI: last cmd=0x200f0000
[ 11.264176] snd_hda_intel 0000:00:1f.3: azx_get_response timeout, switching to single_cmd mode: last cmd=0x200f0000
[ 11.264571] snd_hda_intel 0000:00:1f.3: no codecs initialized

sudo lspci -s 00:1f.3 -vvv
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21) (prog-if 80)
        Subsystem: Dell Sunrise Point-LP HD Audio
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32
        Interrupt: pin A routed to IRQ 16
        IOMMU group: 10
        Region 0: Memory at dc428000 (64-bit, non-prefetchable) [size=16K]
        Region 4: Memory at dc400000 (64-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000 Data: 0000
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel, snd_soc_skl

aplay -l
aplay: device_list:274: no soundcard found ..

cat /proc/asound/cards
--- no soundcards ---

cat /proc/asound/modules
EMPTY

By now I am getting desperate because I am running out of ideas and out of unread links on Google.
What I found out to be quite interesting to me, this issue seems to be the same as a bug that existed in an older kernel-version in Ubuntu:
Bug 1957058

Activities

faceless

2022-05-19 09:51

reporter   ~0016168

This can be closed/seems like my hardware is having issues all over the place. Very weird things start happening so I don't want to say Kali is at fault. Seems like Dell is at "fault"

Issue History

Date Modified Username Field Change
2022-05-18 14:09 faceless New Issue
2022-05-19 09:51 faceless Note Added: 0016168
2022-05-20 14:22 daniruiz Assigned To => daniruiz
2022-05-20 14:22 daniruiz Status new => closed
2022-05-20 14:22 daniruiz Resolution open => fixed