View Issue Details

IDProjectCategoryView StatusLast Update
0007736Kali LinuxQueued Tool Additionpublic2023-08-16 13:34
Reportergeeklucky Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2022.2 
Fixed in Version2022.3 
Summary0007736: sparrow wifi advanced feature falcon can't be turned on
Description

With the latest version of kali 2022.2, apt installed sparrow-wifi
But the falcon function is not available, it opens with a zsh terminal error

Activities

geeklucky

geeklucky

2022-06-05 04:18

reporter  

j_jito

j_jito

2022-06-05 10:13

reporter   ~0016227

I found a temporary fix:

comment out line 891, 893, 894 and 901 of /usr/share/sparrow-wifi/plugins/falconwifidialogs.py

geeklucky

geeklucky

2022-06-05 23:59

reporter   ~0016228

Thank you for the answer.
It's working.
It looks like there's a bug in the window layout and it's not displaying properly.

j_jito

j_jito

2022-06-06 13:33

reporter   ~0016230

Exactly. It seems the maintainer has abandoned the project since last year, because there is a non-treated issue about the falcon plugin.
Kali can release a patch with the commented lines of falconwifidialogs.py to prevent crashes.

sbrun

sbrun

2022-06-20 10:05

manager   ~0016307

Fixed in version 0.0~git20220114-0kali3 (will be available in kali-rolling in few hours)

Issue History

Date Modified Username Field Change
2022-06-05 04:18 geeklucky New Issue
2022-06-05 04:18 geeklucky File Added: Snipaste_2022-06-05_12-18-19.png
2022-06-05 10:13 j_jito Note Added: 0016227
2022-06-05 23:59 geeklucky Note Added: 0016228
2022-06-06 13:33 j_jito Note Added: 0016230
2022-06-15 19:09 daniruiz Assigned To => sbrun
2022-06-15 19:09 daniruiz Status new => assigned
2022-06-20 10:05 sbrun Note Added: 0016307
2022-06-21 12:58 sbrun Status assigned => resolved
2022-06-21 12:58 sbrun Resolution open => fixed
2022-06-21 12:58 sbrun Fixed in Version => 2022.3
2023-08-16 13:34 g0tmi1k Category New Tool Requests => Queued Tool Addition