View Issue Details

IDProjectCategoryView StatusLast Update
0007737Kali Linux[All Projects] New Tool Requestspublic2022-06-06 13:22
Reporterironman_uestc Assigned Tore4son  
Status assignedResolutionopen 
Product Version2022.2 
Target VersionFixed in Version 
Summary0007737: Always fail to start PostgreSQL server on Kali Nethunter for OnePlus 7P
DescriptionSince late of 2020, PostgreSQL server can NOT be launched on Kali Nethunter of OnePlus 7P. I tried to solve this f*uking problem via install MySQL/MariaDB to replace PostgreSQL. However, Metasploit DO NOT support databases except for PostgreSQL. And this f*cking problem have been bothering me all the time for I DO NOT love andrax, the opponent of Kali.
Steps To ReproduceStep 1: Run the terminal or SSH to access Kali Nethunter deployed on OnePlus 7P
Step 2: Try to start the PostgreSQL server via service or systemctl
Step 3: Tips for errors occurred as below:
sudo service postgresql start
[sudo] password for kali:
Starting PostgreSQL 14 database server: mainError: /usr/lib/postgresql/14/bin/pg_ctl /usr/lib/postgresql/14/bin/pg_ctl start -D /var/lib/postgresql/14/main -l /var/log/postgresql/postgresql-14-main.log -s -o -c config_file="/etc/postgresql/14/main/postgresql.conf" exited with status 1: 2022-06-05 15:28:56.333 UTC [19831] FATAL: could not create shared memory segment: Function not implemented 2022-06-05 15:28:56.333 UTC [19831] DETAIL: Failed system call was shmget(key=4056492, size=56, 03600). 2022-06-05 15:28:56.333 UTC [19831] LOG: database system is shut down pg_ctl: could not start server Examine the log output. ... failed!

Additional InformationAfter dozens of tests, things seem to be that OxygenOS 10/11 DO NOT implement functions for shared memory of System V(sysv), so the function call of shmget failed due to Function not implemented. Then I use the command “ipcs” to get cross-process info, it approved what I guess. By the way, Kali Linux deploied on the PC DO NOT suffer from this bothering problem.
However, the Andrax I deploy on the same phone of OnePlus 7P seem to solve the problem itself. As you see above, I can successfully start the PostgreSQL, and it goes very well with msfconsole. And I use ipcs command to check the cross-process info, no shared memory created. So, can this fucking problem on Kali Nethunter since 2020 be solved? Or, should I go to PostgreSQL team for this problem?
 Guys, I am a super fan of Kali Nethunter and Kali Linux, I love the openness of Kali, so plz solve this f*cking problem or give me some suggestions on this f*cking problem.


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-06-05 16:24 ironman_uestc New Issue
2022-06-06 13:22 daniruiz Assigned To => re4son
2022-06-06 13:22 daniruiz Status new => assigned