View Issue Details

IDProjectCategoryView StatusLast Update
0007871Kali LinuxGeneral Bugpublic2023-05-31 14:56
ReporterMarcio Assigned To 
Status closedResolutionopen 
Product Version2022.3 
Summary0007871: zsh: segmentation fault

I ran the following parameters a few times:

echo 0.{1..254}.{1..254}.{1..254} | tr ' ' '\n' | sed "s/^/https:\/\//" | tee list

I ran it a few times, but then it started to overflow

Steps To Reproduce

execute echo 0.{1..254}.{1..254}.{1..254} | tr ' ' '\n' | sed "s/^/https:\/\//"

wait 10 seconds, and make CTRL + C

execute again

execute echo 0.{1..254}.{1..254}.{1..254} | tr ' ' '\n' | sed "s/^/https:\/\//"

and look

zsh: segmentation fault echo 0.{1..254}.{1..254}.{1..254} |
zsh: done tr ' ' '\n' | sed "s/^/https:\/\//"




2022-08-26 21:33

manager   ~0016658

How much memory does your system have? Because I can't reproduce this issue here, but my system seems to also be able to resolve it.

Can you show the dmesg output after the segfault?



2023-05-31 14:56

administrator   ~0018095

This report has been filed against an old version of Kali. We will be closing this ticket due to inactivity.

Please could you see if you are able to replicate this issue with the latest version of Kali Linux (

If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing, and also give information about your setup?
For more information, please read:

Issue History

Date Modified Username Field Change
2022-08-17 02:27 Marcio New Issue
2022-08-26 21:33 steev Note Added: 0016658
2023-05-31 14:56 g0tmi1k Note Added: 0018095
2023-05-31 14:56 g0tmi1k Status new => closed