View Issue Details

IDProjectCategoryView StatusLast Update
0007942Kali Linux[All Projects] General Bugpublic2022-09-23 16:15
Reporterkevinds Assigned Todaniruiz  
Status resolvedResolutionfixed 
Product Version2022.3 
Target VersionFixed in Version2022.4 
Summary0007942: Sierra Wireless WWAN Doesn't Work in 2022.x
DescriptionSierra Wireless MC7355 and MC7354 WWAN cards do not work in Kali 2022 versions, I assume others are broken, but these are the cards I have.

Installing a 2021.x version or previous the cards work. Installing 2022.1 or later the connection shows in Network Manager but just shows the Network Disconnected message when trying to use, or it is just greyed out.

Installing 2021.3 for example and then apt update and apt upgrade, the card also stops working after rebooting.

I have tried holding the ModemManager and NetworkManager so they don't get updated, but the WWAN still stops working after reboot.

Steps To ReproduceInstall 2022.x


Install before 2022.x and upgrade.



2022-09-23 09:52

reporter   ~0016810

I want to close/delete this now go back to my own testing, just re-installed again, held linux-image-5.10.0-kali9-amd64, apt update && apt upgrade a few times..

Rebooted, uname -r shows 5.18.0-kali7-amd64 and my MC7354 card is still working, thinking it was fixed between 5.17 and 5.18.. Will put my MC7355 back and try it again too.


2022-09-23 13:03

reporter   ~0016811

It's not related to Kali, but ModemManager.

I had the same issue with my EM7455. ModemManager introduced fcc-unlock operation before using mobile data.
So you have to do the following:

ln -s /usr/share/ModemManager/fcc-unlock.available.d/1199\:9079 /etc/ModemManager/fcc-unlock.d/

That should fix the problem after rebooting your kali


2022-09-23 13:30

reporter   ~0016812

No, it was fixed with the linux-image-5.18.0-kali7-amd64 update. 5.18.0-kali5-amd64 was still broken, I never tried kali6. I was slow at doing this bug report, but it appears to now be fixed.

I had read that and initially held the ModemManager back so I was running the old version without that annoyance.. New kernel still broke it.


2022-09-23 16:14

manager   ~0016816

Seems solved so I'm closing this issue

Issue History

Date Modified Username Field Change
2022-09-23 06:25 kevinds New Issue
2022-09-23 09:52 kevinds Note Added: 0016810
2022-09-23 13:03 j_jito Note Added: 0016811
2022-09-23 13:30 kevinds Note Added: 0016812
2022-09-23 16:14 daniruiz Note Added: 0016816
2022-09-23 16:15 daniruiz Assigned To => daniruiz
2022-09-23 16:15 daniruiz Status new => resolved
2022-09-23 16:15 daniruiz Resolution open => fixed
2022-09-23 16:15 daniruiz Fixed in Version => 2022.4