View Issue Details

IDProjectCategoryView StatusLast Update
0007999Kali LinuxGeneral Bugpublic2023-01-31 08:19
ReporterFred_Sheehan Assigned Toarnaudr  
Status resolvedResolutionfixed 
Product Version2022.3 
Summary0007999: Anytime installation using the speech selection, no matter what options chosen always end at a minimum base install text console

On the Kali forum several users have asked how to get Orca working on their Kali install, and whilst that is possible, it doesn't actually 'speak' the username field on the log in screen even when Orca is workinbg after the log in has completed.
Without the screen reader features working on that screen, they then cannot log in to their account, making the now working install, not accessable from a reboot.

Steps To Reproduce

From the Kali installer screen, choose the speech accesability option for install, the install process speech works, but no matter which options are chosen at the software selection screen, after it has installed and wants to reboot, the user is left at a basic install prompt without the ability to log in to any kind of desktop.

Additional Information

The only way that works properly is to install Kali without speech option and only after its booted to to a desktop, to then install and configure any missing software. As a sighted user this is clearly no problem for me, but is not apropriate for users who need the screen reader functions.

I have tried several versions of Kali including some earlier releases, and all seem to show the same behaviour.




2022-11-30 06:00

manager   ~0017108

Hey, just to let you know that we're working on that, there are different things broken with speech synthesis install at the moment, as you noticed. Unfortunately it won't be fixed in time for the upcoming 2022.4 release, but I hope we'll have a functional weekly image shortly afterward. I'll ping again on this channel. Thanks for your patience!



2023-01-31 08:18

manager   ~0017443

Hello, the issue should be fixed in the weekly image (2023-W05). I just tested the installer image and it worked, there was speech synthesis during installation, and also in the XFCE greeter (aka. lightdm), and also after logging in XFCE. Please give it a try:

Feel free to re-open this issue if needed, if ever there's more things to fix.

Thanks for your patience!

Issue History

Date Modified Username Field Change
2022-10-10 23:28 Fred_Sheehan New Issue
2022-11-30 06:00 arnaudr Note Added: 0017108
2023-01-31 08:18 arnaudr Note Added: 0017443
2023-01-31 08:19 arnaudr Assigned To => arnaudr
2023-01-31 08:19 arnaudr Status new => resolved
2023-01-31 08:19 arnaudr Resolution open => fixed