View Issue Details

IDProjectCategoryView StatusLast Update
0008002Kali LinuxGeneral Bugpublic2022-10-24 07:02
Reporterkiytony Assigned Todaniruiz  
Status resolvedResolutionfixed 
Product Version2022.3 
Fixed in Version2022.4 
Summary0008002: Media playback not working

Video media in all browsers doesn't play. And the media on my device plays, but without sound. I tried different solutions from Linux forums, but nothing seems to fix it.

Steps To Reproduce
  1. Install the update released on 12 October 2022.
  2. Try opening media on youtube




2022-10-13 13:00

manager   ~0016974

How are you running Kali Linux? In a virtual machine? Which one? Or installed baremetal?

Just to be sure, can you type the following command in a terminal, and paste the result here:

dpkg -l | grep pulse




2022-10-13 13:17

reporter   ~0016975

I'm running it directly on my device. Not virtually!
Here are the results of the command:
dpkg -l | grep pulse
ii gstreamer1.0-pulseaudio:amd64 1.20.3-1 amd64 GStreamer plugin for PulseAudio (transitional package)
ii libcanberra-pulse:amd64 0.30-10 amd64 PulseAudio backend for libcanberra
ii libpulse-mainloop-glib0:amd64 16.1+dfsg1-2 amd64 PulseAudio client libraries (glib support)
ii libpulse0:amd64 16.1+dfsg1-2 amd64 PulseAudio client libraries
ii libpulse0:i386 16.1+dfsg1-2 i386 PulseAudio client libraries
ii libpulsedsp:amd64 16.1+dfsg1-2 amd64 PulseAudio OSS pre-load library
ii pulseaudio 16.1+dfsg1-2 amd64 PulseAudio sound server
ii pulseaudio-module-bluetooth 16.1+dfsg1-2 amd64 Bluetooth module for PulseAudio sound server
ii pulseaudio-utils 16.1+dfsg1-2 amd64 Command line tools for the PulseAudio sound server
ii xfce4-pulseaudio-plugin:amd64 0.4.5-1 amd64 Xfce4 panel plugin to control pulseaudio




2022-10-13 13:53

manager   ~0016976

The latest major release of pulseaudio landed in Kali a week ago (version 16.1+dfsg1-2), so it's possible that it broke the sound for you. Now, as to how to solve it... I really don't know. I can't really help with that.

If it's not a big deal for you, you can just wait, cross your fingers and hope that the next point release will fix it. Otherwise, if you have some time, you can roll up your sleeves, look into the logs (probably run journalctl, check the status of systemd services related to sound), find what's the relevant error message somewhere, and maybe report it to the upstream bugtracker ? Also try to run the programs that you want to play sound with from a terminal: if you're lucky it will output some error message.

You said you « tried different solutions from Linux forum », you can keep trying. Just try to narrow down your researches to pulseaudio 16, or to discussions that are less than 6 months old.

Maybe check the Debian bugtracker for pulseaudio:;ordering=raw;package=pulseaudio, limit yourself to bug numbers above 1,000,000.

Good luck!



2022-10-13 14:04

reporter   ~0016977

I'll try everything I can and see!
Thanks for the help!!!



2022-10-15 01:46

reporter   ~0016979

The issue was fixed with the October 15 update!

Issue History

Date Modified Username Field Change
2022-10-13 10:15 kiytony New Issue
2022-10-13 13:00 arnaudr Note Added: 0016974
2022-10-13 13:17 kiytony Note Added: 0016975
2022-10-13 13:53 arnaudr Note Added: 0016976
2022-10-13 14:04 kiytony Note Added: 0016977
2022-10-15 01:46 kiytony Note Added: 0016979
2022-10-24 07:02 daniruiz Assigned To => daniruiz
2022-10-24 07:02 daniruiz Status new => resolved
2022-10-24 07:02 daniruiz Resolution open => fixed
2022-10-24 07:02 daniruiz Fixed in Version => 2022.4