View Issue Details

IDProjectCategoryView StatusLast Update
0008091Kali Linux[All Projects] General Bugpublic2022-12-10 08:12
Reporterryanb Assigned Tog0tmi1k  
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version2022.4 
Target VersionFixed in Version 
Summary0008091: AWS AMI fails to start SSH - kali-last-snapshot-amd64-2022.4.0-804fcc46-63fc-4eb6-85a1-50e66d6c7215
DescriptionBelow is the system log from starting an EC2 instance with the AMI kali-last-snapshot-amd64-2022.4.0-804fcc46-63fc-4eb6-85a1-50e66d6c7215, where the ssh service fails to start.

[ 2.747437] xenbus_probe_frontend: Device with no driver: device/vbd/51712
[ 2.757574] xenbus_probe_frontend: Device with no driver: device/vif/0
[ 2.770675] Freeing unused decrypted memory: 2036K
[ 2.775387] Freeing unused kernel image (initmem) memory: 2532K
[ 2.790018] Write protecting the kernel read-only data: 22528k
[ 2.796432] Freeing unused kernel image (text/rodata gap) memory: 2040K
[ 2.802501] Freeing unused kernel image (rodata/data gap) memory: 64K
[ 2.810174] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[ 2.815471] x86/mm: Checking user space page tables
[ 2.819583] x86/mm: Checked W+X mappings: passed, no W+X pages found.
[ 2.824657] Run /init as init process
Loading, please wait...
Starting systemd-udevd version 252.1-1
[ 3.043794] SCSI subsystem initialized
[ 3.059436] Invalid max_queues (4), will use default max: 1.
[ 3.066732] xen_netfront: Initialising Xen virtual ethernet driver
[ 3.075065] cryptd: max_cpu_qlen set to 1000
[ 3.097554] AVX2 version of gcm_enc/dec engaged.
[ 3.110732] AES CTR mode by8 optimization enabled
[ 3.119945] scsi host0: ata_piix
[ 3.125374] scsi host1: ata_piix
[ 3.130133] ata1: PATA max MWDMA2 cmd 0x1f0 ctl 0x3f6 bmdma 0xc100 irq 14
[ 3.137556] ata2: PATA max MWDMA2 cmd 0x170 ctl 0x376 bmdma 0xc108 irq 15
[ 3.184640] blkfront: xvda: barrier or flush: disabled; persistent grants: disabled; indirect descriptors: enabled; bounce buffer: disabled;
[ 3.261288] GPT:Primary header thinks Alt. header is not at the end of the disk.
[ 3.266571] GPT:25165823 != 41943039
[ 3.269315] GPT:Alternate GPT header not at the end of the disk.
[ 3.273195] GPT:25165823 != 41943039
[ 3.275821] GPT: Use GNU Parted to correct GPT errors.
[ 3.279719] xvda: xvda1 xvda14 xvda15
Begin: Loading essential drivers ... done.
Begin: Running /scripts/init-premount ... done.
Begin: Mounting root file system ... Begin: Running /scripts/local-top ... done.
Begin: Running /scripts/local-premount ... done.
Begin: Will now check root file system ... fsck from util-linux 2.38.1
[/sbin/fsck.ext4 (1) -- /dev/xvda1] fsck.ext4 -a -C0 /dev/xvda1
/dev/xvda1: clean, 292214/778240 files, 2434629/3112704 blocks
done.
[ 3.972246] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Quota mode: none.
done.
Begin: Running /scripts/local-bottom ... [ 4.199986] EXT4-fs (xvda1): unmounting filesystem.
GROWROOT: WARNING: resize failed: failed [flock:127] flock -x 9
/sbin/growpart: line 714: flock: not found
FAILED: Error while obtaining exclusive lock on /dev/xvda
[ 4.259186] GPT:Primary header thinks Alt. header is not at the end of the disk.
[ 4.266010] GPT:25165823 != 41943039
[ 4.269510] GPT:Alternate GPT header not at the end of the disk.
[ 4.275450] GPT:25165823 != 41943039
[ 4.279308] GPT: Use GNU Parted to correct GPT errors.
[ 4.284378] xvda: xvda1 xvda14 xvda15
[ 4.330604] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Quota mode: none.
done.
Begin: Running /scripts/init-bottom ... done.
[ 4.623038] Not activating Mandatory Access Control as /sbin/tomoyo-init does not exist.
[ 8.728892] systemd[1]: Inserted module 'autofs4'
[ 8.933171] systemd[1]: systemd 252.1-1 running in system mode (+PAM +AUDIT +SELINUX +APPARMOR +IMA +SMACK +SECCOMP +GCRYPT -GNUTLS +OPENSSL +ACL +BLKID +CURL +ELFUTILS +FIDO2 +IDN2 -IDN +IPTC +KMOD +LIBCRYPTSETUP +LIBFDISK +PCRE2 -PWQUALITY -P11KIT +QRENCODE +TPM2 +BZIP2 +LZ4 +XZ +ZLIB +ZSTD -BPF_FRAMEWORK -XKBCOMMON +UTMP +SYSVINIT default-hierarchy=unified)
[ 8.953404] systemd[1]: Detected virtualization xen.
[ 8.957287] systemd[1]: Detected architecture x86-64.

Welcome to Kali GNU/Linux Rolling!

[ 8.966755] systemd[1]: Hostname set to <kali>.
[ 9.067341] systemd[1]: Initializing machine ID from random generator.
[ 9.071808] systemd[1]: Installed transient /etc/machine-id file.
[ 12.087401] systemd[1]: Queued start job for default target Graphical Interface.
[ 12.092689] systemd[1]: Created slice Slice /system/getty.
[ OK ] Created slice Slice /system/getty.
[ 12.098683] systemd[1]: Created slice Slice /system/modprobe.
[ OK ] Created slice Slice /system/modprobe.
[ 12.105056] systemd[1]: Created slice Slice /system/serial-getty.
[ OK ] Created slice Slice /system/serial-getty.
[ 12.111587] systemd[1]: Created slice Slice /system/systemd-growfs.
[ OK ] Created slice Slice /system/systemd-growfs.
[ 12.117911] systemd[1]: Created slice User and Session Slice.
[ OK ] Created slice User and Session Slice.
[ 12.124214] systemd[1]: Started Dispatch Password Requests to Console Directory Watch.
[ OK ] Started Dispatch Password …ts to Console Directory Watch.
[ 12.131791] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[ OK ] Started Forward Password R…uests to Wall Directory Watch.
[ 12.139395] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[ OK ] Set up automount Arbitrary…s File System Automount Point.
[ 12.147629] systemd[1]: Reached target Local Encrypted Volumes.
[ OK ] Reached target Local Encrypted Volumes.
[ 12.153770] systemd[1]: Reached target Local Integrity Protected Volumes.
[ OK ] Reached target Local Integrity Protected Volumes.
[ 12.163013] systemd[1]: Reached target Path Units.
[ OK ] Reached target Path Units.
[ 12.170174] systemd[1]: Reached target Slice Units.
[ OK ] Reached target Slice Units.
[ 12.177062] systemd[1]: Reached target TLS tunnels for network services - per-config-file target.
[ OK ] Reached target TLS tunnels…ices - per-config-file target.
[ 12.187727] systemd[1]: Reached target Swaps.
[ OK ] Reached target Swaps.
[ 12.194455] systemd[1]: Reached target Local Verity Protected Volumes.
[ OK ] Reached target Local Verity Protected Volumes.
[ 12.204874] systemd[1]: Listening on Syslog Socket.
[ OK ] Listening on Syslog Socket.
[ 12.217392] systemd[1]: Listening on fsck to fsckd communication Socket.
[ OK ] Listening on fsck to fsckd communication Socket.
[ 12.224932] systemd[1]: Listening on initctl Compatibility Named Pipe.
[ OK ] Listening on initctl Compatibility Named Pipe.
[ 12.232117] systemd[1]: Listening on Journal Audit Socket.
[ OK ] Listening on Journal Audit Socket.
[ 12.238022] systemd[1]: Listening on Journal Socket (/dev/log).
[ OK ] Listening on Journal Socket (/dev/log).
[ 12.243950] systemd[1]: Listening on Journal Socket.
[ OK ] Listening on Journal Socket.
[ 12.249852] systemd[1]: Listening on udev Control Socket.
[ OK ] Listening on udev Control Socket.
[ 12.260693] systemd[1]: Listening on udev Kernel Socket.
[ OK ] Listening on udev Kernel Socket.
[ 12.272220] systemd[1]: Mounting Huge Pages File System...
         Mounting Huge Pages File System...
[ 12.284091] systemd[1]: Mounting POSIX Message Queue File System...
         Mounting POSIX Message Queue File System...
[ 12.296777] systemd[1]: Mounting Kernel Debug File System...
         Mounting Kernel Debug File System...
[ 12.308737] systemd[1]: Mounting Kernel Trace File System...
         Mounting Kernel Trace File System...
[ 12.321012] systemd[1]: Kernel Module supporting RPCSEC_GSS was skipped because of an unmet condition check (ConditionPathExists=/etc/krb5.keytab).
[ 12.335639] systemd[1]: Starting Set the console keyboard layout...
         Starting Set the console keyboard layout...
[ 12.348963] systemd[1]: Starting Create List of Static Device Nodes...
         Starting Create List of Static Device Nodes...
[ 12.371092] systemd[1]: Starting Load Kernel Module configfs...
         Starting Load Kernel Module configfs...
[ 12.386850] systemd[1]: Starting Load Kernel Module drm...
         Starting Load Kernel Module drm...
[ 12.399405] systemd[1]: Starting Load Kernel Module efi_pstore...
         Starting Load Kernel Module efi_pstore...
[ 12.413117] systemd[1]: Starting Load Kernel Module fuse...
         Starting Load Kernel Module fuse...
[ 12.421223] systemd[1]: File System Check on Root Device was skipped because of an unmet condition check (ConditionPathExists=!/run/initramfs/fsck-root).
[ 12.430321] systemd[1]: Starting Journal Service...
         Starting Journal Service...
[ 12.449823] systemd[1]: Starting Load Kernel Modules...
         Starting Load Kernel Modules...
[ 12.461915] systemd[1]: Starting Remount Root and Kernel File Systems...
         Starting Remount Root and Kernel File Systems...
[ 12.476155] systemd[1]: Repartition Root Disk was skipped because no trigger condition checks were met.
[ 12.490825] fuse: init (API version 7.36)
[ 12.495798] systemd[1]: Starting Coldplug All udev Devices...
         Starting Coldplug All udev Devices...
[ 12.509441] systemd[1]: Mounted Huge Pages File System.
[ OK ] Mounted Huge Pages File System.
[ 12.519814] systemd[1]: Mounted POSIX Message Queue File System.
[ OK ] Mounted POSIX Message Queue File System.
[ 12.526823] systemd[1]: Mounted Kernel Debug File System.
[ OK ] Mounted Kernel Debug File System.
[ 12.533280] systemd[1]: Mounted Kernel Trace File System.
[ OK ] Mounted Kernel Trace File System.[ 12.560839] EXT4-fs (xvda1): re-mounted. Quota mode: none.

[ 12.575155] systemd[1]: Finished Set the console keyboard layout.
[ OK ] Finished Set the console keyboard layout.
[ 12.598633] systemd[1]: Started Journal Service.
[ OK ] Started Journal Service.
[ OK ] Finished Create List of Static Device Nodes.
[ OK ] Finished Load Kernel Module configfs.
[ OK ] Finished Load Kernel Module drm.
[ OK ] Finished Load Kernel Module efi_pstore.
[ OK ] Finished Load Kernel Module fuse.
[ OK ] Finished Load Kernel Modules.
[ OK ] Finished Remount Root and Kernel File Systems.
         Mounting FUSE Control File System...
         Mounting Kernel Configuration File System...
         Starting Initial cloud-init job (pre-networking)...
         Starting Grow File System on /...
         Starting Flush Journal to Persistent Storage...
         Starting Load/Save Random Seed...
[ 12.675015] systemd-journald[314]: Received client request to flush runtime journal.
         Starting Apply Kernel Variables...
         Starting Create System Users...
[ OK ] Mounted FUSE Control File System.
[ OK ] Mounted Kernel Configuration File System.
[ OK ] Finished Coldplug All udev Devices.
         Starting Helper to synchronize boot up for ifupdown...
[ OK ] Finished Helper to synchronize boot up for ifupdown.
[ OK ] Finished Apply Kernel Variables.
[ OK ] Finished Load/Save Random Seed.
[ OK ] Finished Flush Journal to Persistent Storage.
[ 12.944229] EXT4-fs (xvda1): resizing filesystem from 3112704 to 3112704 blocks
[ OK ] Finished Create System Users.
         Starting Create Static Device Nodes in /dev...
[ OK ] Finished Grow File System on /.
[ OK ] Finished Create Static Device Nodes in /dev.
[ OK ] Reached target Preparation for Local File Systems.
         Starting Rule-based Manage…for Device Events and Files...
[ OK ] Started Rule-based Manager for Device Events and Files.
[ OK ] Found device /dev/ttyS0.
[ OK ] Found device /dev/disk/by-uuid/AB3B-17A3.
         Mounting /boot/efi...
[ 14.770672] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input3
[ OK ] Mounted /boot/efi.[ 14.799609] ACPI: button: Power Button [PWRF]

[ 14.828268] input: Sleep Button as /devices/LNXSYSTM:00/LNXSLPBN:00/input/input4
[ 14.840774] RAPL PMU: API unit is 2^-32 Joules, 0 fixed counters, 655360 ms ovfl timer
[ OK ] Reached target Local File Systems.
[ 14.949382] ACPI: button: Sleep Button [SLPF]
         Starting Set console font and keymap...
         Starting Set Up Additional Binary Formats...
         Starting Commit a transient machine-id on disk...
         Starting Create Volatile Files and Directories...
[ OK ] Finished Set console font and keymap.
         Mounting Arbitrary Executable File Formats File System...
[ OK ] Mounted Arbitrary Executable File Formats File System.
[ OK ] Finished Create Volatile Files and Directories.
         Mounting RPC Pipe File System...
         Starting Record System Boot/Shutdown in UTMP...
[ OK ] Finished Record System Boot/Shutdown in UTMP.
[ OK ] Finished Set Up Additional Binary Formats.
[ OK ] Found device /sys/subsystem/net/devices/eth0.
[ OK ] Finished Commit a transient machine-id on disk.
[ 15.820642] RPC: Registered named UNIX socket transport module.
[ 15.826639] RPC: Registered udp transport module.
[ 15.831750] RPC: Registered tcp transport module.
[ 15.837328] RPC: Registered tcp NFSv4.1 backchannel transport module.
[ OK ] Mounted RPC Pipe File System.
[ OK ] Reached target rpc_pipefs.target.
[ OK ] Reached target NFS client services.
[ OK ] Reached target Preparation for Remote File Systems.
[ OK ] Reached target Remote File Systems.
[ 23.261235] cloud-init[403]: Cloud-init v. 22.2 running 'init-local' at Thu, 08 Dec 2022 00:08:56 +0000. Up 23.22 seconds.
[ OK ] Finished Initial cloud-init job (pre-networking).
[ OK ] Reached target Preparation for Network.
[ OK ] Started ifup for eth0.
         Starting Raise network interfaces...
[ OK ] Finished Raise network interfaces.
[ OK ] Reached target Network.
         Starting Initial cloud-ini… (metadata service crawler)...
[ 26.825062] cloud-init[619]: Cloud-init v. 22.2 running 'init' at Thu, 08 Dec 2022 00:09:00 +0000. Up 26.79 seconds.
[ 26.843459] cloud-init[619]: ci-info: +++++++++++++++++++++++++++++++++++++++++++++Net device info++++++++++++++++++++++++++++++++++++++++++++++
[ 26.859976] cloud-init[619]: ci-info: +--------+------+-------------------------------------------+---------------+--------+-------------------+
[ 26.879528] cloud-init[619]: ci-info: | Device | Up | Address | Mask | Scope | Hw-Address |
[ 26.889535] cloud-init[619]: ci-info: +--------+------+-------------------------------------------+---------------+--------+-------------------+
[ 26.911806] cloud-init[619]: ci-info: | eth0 | True | 172.31.33.44 | 255.255.240.0 | global | 0a:a2:8e:68:51:e2 |
[ 26.931969] cloud-init[619]: ci-info: | eth0 | True | 2406:da18:6e3:c01:b709:906e:4a68:cb92/128 | . | global | 0a:a2:8e:68:51:e2 |
[ 26.947554] cloud-init[619]: ci-info: | eth0 | True | fe80::8a2:8eff:fe68:51e2/64 | . | link | 0a:a2:8e:68:51:e2 |
[ 26.967993] cloud-init[619]: ci-info: | lo | True | 127.0.0.1 | 255.0.0.0 | host | . |
[ 26.983887] cloud-init[619]: ci-info: | lo | True | ::1/128 | . | host | . |
[ 27.000260] cloud-init[619]: ci-info: +--------+------+-------------------------------------------+---------------+--------+-------------------+
[ 27.007695] cloud-init[619]: ci-info: +++++++++++++++++++++++++++++Route IPv4 info+++++++++++++++++++++++++++++
[ 27.014637] cloud-init[619]: ci-info: +-------+-------------+-------------+---------------+-----------+-------+
[ 27.021157] cloud-init[619]: ci-info: | Route | Destination | Gateway | Genmask | Interface | Flags |
[ 27.027303] cloud-init[619]: ci-info: +-------+-------------+-------------+---------------+-----------+-------+
[ 27.033535] cloud-init[619]: ci-info: | 0 | 0.0.0.0 | 172.31.32.1 | 0.0.0.0 | eth0 | UG |
[ 27.039634] cloud-init[619]: ci-info: | 1 | 172.31.32.0 | 0.0.0.0 | 255.255.240.0 | eth0 | U |
[ 27.046116] cloud-init[619]: ci-info: +-------+-------------+-------------+---------------+-----------+-------+
[ 27.053897] cloud-init[619]: ci-info: ++++++++++++++++++++++++++++++++++++++++Route IPv6 info++++++++++++++++++++++++++++++++++++++++
[ 27.061786] cloud-init[619]: ci-info: +-------+---------------------------------------+-------------------------+-----------+-------+
[ 27.068349] cloud-init[619]: ci-info: | Route | Destination | Gateway | Interface | Flags |
[ 27.074409] cloud-init[619]: ci-info: +-------+---------------------------------------+-------------------------+-----------+-------+
[ 27.080022] cloud-init[619]: ci-info: | 1 | 2406:da18:6e3:c01:b709:906e:4a68:cb92 | :: | eth0 | U |
[ 27.085709] cloud-init[619]: ci-info: | 2 | 2406:da18:6e3:c01::/64 | :: | eth0 | U |
[ 27.091075] cloud-init[619]: ci-info: | 3 | fe80::/64 | :: | eth0 | U |
[ 27.096445] cloud-init[619]: ci-info: | 4 | ::/0 | fe80::8cb:5ff:fea2:41b0 | eth0 | UGe |
[ 27.101950] cloud-init[619]: ci-info: | 6 | local | :: | eth0 | U |
[ 27.107541] cloud-init[619]: ci-info: | 7 | multicast | :: | eth0 | U |
[ 27.113198] cloud-init[619]: ci-info: +-------+---------------------------------------+-------------------------+-----------+-------+
[ 29.599286] EXT4-fs (xvda1): resizing filesystem from 3112704 to 5210107 blocks
[ 30.182225] EXT4-fs (xvda1): resized filesystem to 5210107
[ 30.315956] EXT4-fs (xvda1): Invalid checksum for backup superblock 32768
[ 30.315956]
[ 30.338948] EXT4-fs error (device xvda1) in ext4_update_backup_sb:174: Filesystem failed CRC
[ 30.350048] Aborting journal on device xvda1-8.
[ 30.357947] EXT4-fs (xvda1): Remounting filesystem read-only
[ 30.366888] EXT4-fs error (device xvda1) in ext4_update_backup_sb:174: Journal has aborted
[ 30.123079] cloud-init[619]: 2022-12-08 00:09:03,584 - util.py[WARNING]: Failed to resize filesystem (cmd=('resize2fs', '/dev/xvda1'))
[ 30.259828] cloud-init[619]: 2022-12-08 00:09:03,721 - util.py[WARNING]: Running module resizefs (<module 'cloudinit.config.cc_resizefs' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_resizefs.py'>) failed
[ 30.390071] cloud-init[619]: 2022-12-08 00:09:03,850 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_disk_setup
[ 30.407099] cloud-init[619]: 2022-12-08 00:09:03,850 - util.py[WARNING]: Running module disk_setup (<module 'cloudinit.config.cc_disk_setup' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_disk_setup.py'>) failed
[ 30.426034] cloud-init[619]: 2022-12-08 00:09:03,851 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_mounts
[ 30.443636] cloud-init[619]: 2022-12-08 00:09:03,865 - util.py[WARNING]: Running module mounts (<module 'cloudinit.config.cc_mounts' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_mounts.py'>) failed
[ 30.462347] cloud-init[619]: 2022-12-08 00:09:03,867 - util.py[WARNING]: Failed to write hostname kali to /var/lib/cloud/data/previous-hostname
[ 30.478415] cloud-init[619]: 2022-12-08 00:09:03,922 - util.py[WARNING]: Running module update_etc_hosts (<module 'cloudinit.config.cc_update_etc_hosts' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_update_etc_hosts.py'>) failed
[ 30.501201] cloud-init[619]: 2022-12-08 00:09:03,936 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_ca_certs
[ 30.519428] cloud-init[619]: 2022-12-08 00:09:03,936 - util.py[WARNING]: Running module ca-certs (<module 'cloudinit.config.cc_ca_certs' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_ca_certs.py'>) failed
[ 30.556321] cloud-init[619]: 2022-12-08 00:09:03,937 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_rsyslog
[ 30.588161] cloud-init[619]: 2022-12-08 00:09:03,937 - util.py[WARNING]: Running module rsyslog (<module 'cloudinit.config.cc_rsyslog' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_rsyslog.py'>) failed
[ 30.616047] cloud-init[619]: 2022-12-08 00:09:03,938 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_users_groups
[FAILED] Failed to start Initial cl…ob (metadata service crawler).
[ 30.639460] cloud-init[619]: 2022-12-08 00:09:03,939 - util.py[WARNING]: Running module users-groups (<module 'cloudinit.config.cc_users_groups' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_users_groups.py'>) failed
See 'systemctl status cloud-init.service' for details.
[ OK ] Reached target Cloud-config availability.
[ 30.656627] cloud-init[619]: 2022-12-08 00:09:03,939 - util.py[WARNING]: Failed writing semaphore file /var/lib/cloud/instances/i-0d6ec2920bab7965f/sem/config_ssh
[ OK ] Reached target Network is Online.
[ 30.678364] cloud-init[619]: 2022-12-08 00:09:03,960 - util.py[WARNING]: Running module ssh (<module 'cloudinit.config.cc_ssh' from '/usr/lib/python3/dist-packages/cloudinit/config/cc_ssh.py'>) failed
[ OK ] Reached target System Initialization.
[ 30.704666] cloud-init[619]: Traceback (most recent call last):
[ OK ] Started Daily apt download activities.
[ 30.719396] cloud-init[619]: File "/usr/bin/cloud-init", line 33, in <module>
[ OK ] Started Daily apt upgrade and clean activities.
[ 30.736590] cloud-init[619]: sys.exit(load_entry_point('cloud-init==22.2', 'console_scripts', 'cloud-init')())
[ OK ] Started Daily dpkg database backup timer.
[ 30.756443] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 1061, in main
[ OK ] Started Periodic ext4 Onli…ata Check for All Filesystems.
[ 30.773028] cloud-init[619]: retval = util.log_time(
[ 30.776820] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2637, in log_time
[ OK ] Started Discard unused blocks once a week.
[ 30.788289] cloud-init[619]: ret = func(*args, **kwargs)
[ OK ] Started Daily rotation of log files.
[ 30.797620] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 758, in status_wrapper
[ OK ] Started Clean PHP session files every 30 mins.
[ 30.810331] cloud-init[619]: atomic_helper.write_json(status_path, status)
[ OK ] Started Update the plocate database daily.
[ 30.824612] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/atomic_helper.py", line 51, in write_json
[ OK ] Started Daily Cleanup of Temporary Directories.
[ 30.840885] cloud-init[619]: return write_file(
[ OK ] Reached target Timer Units.
[ 30.850775] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/atomic_helper.py", line 46, in write_file
[ OK ] Listening on D-Bus System Message Bus Socket.
[ 30.864263] cloud-init[619]: raise e
[ OK ] Reached target Socket Units.
[ 30.872647] cloud-init[619]: File "/usr/lib/python3/dist-packages/cloudinit/atomic_helper.py", line 27, in write_file
         Starting Notify NFS peers of a restart...
[ 30.888910] cloud-init[619]: tf = tempfile.NamedTemporaryFile(
[ OK ] Reached target Basic System.
[ 30.899916] cloud-init[619]: File "/usr/lib/python3.10/tempfile.py", line 698, in NamedTemporaryFile
         Starting Apply the settings specified in cloud-config...
[ 30.915529] cloud-init[619]: file = _io.open(dir, mode, buffering=buffering,
[ OK ] Started Regular background program processing daemon.
[ 30.935512] cloud-init[619]: File "/usr/lib/python3.10/tempfile.py", line 695, in opener
         Starting D-Bus System Message Bus...
[ 30.965370] cloud-init[619]: fd, name = _mkstemp_inner(dir, prefix, suffix, flags, output_type)
         Starting Remove Stale Onli…t4 Metadata Check Snapshots...
[ 30.996722] cloud-init[619]: File "/usr/lib/python3.10/tempfile.py", line 395, in _mkstemp_inner
         Starting Regenerate SSH host keys...
[ 31.027558] cloud-init[619]: fd = _os.open(file, flags, 0o600)
         Starting System Logging Service...
[ 31.039521] cloud-init[619]: OSError: [Errno 30] Read-only file system: '/var/lib/cloud/data/tmpxgan3y0g'
         Starting User Login Management...
         Starting Permit User Sessions...
[FAILED] Failed to start User Login Management.
See 'systemctl status systemd-logind.service' for details.
[ OK ] Finished Permit User Sessions.
[ OK ] Started Getty on tty1.
[ OK ] Started Serial Getty on ttyS0.
[ OK ] Reached target Login Prompts.
[ OK ] Stopped User Login Management.
         Starting Load Kernel Module drm...
[ OK ] Started D-Bus System Message Bus.
[ OK ] Finished Regenerate SSH host keys.
[ OK ] Finished Load Kernel Module drm.
         Starting OpenBSD Secure Shell server...
         Starting User Login Management...
[FAILED] Failed to start User Login Management.
See 'systemctl status systemd-logind.service' for details.
[ OK ] Stopped User Login Management.
         Starting Load Kernel Module drm...
[ OK ] Finished Load Kernel Module drm.
         Starting User Login Management...
[FAILED] Failed to start User Login Management.
See 'systemctl status systemd-logind.service' for details.
[ OK ] Stopped User Login Management.
         Starting Load Kernel Module drm...
[ OK ] Started System Logging Service.
[ OK ] Started Notify NFS peers of a restart.
[ OK ] Finished Load Kernel Module drm.
         Starting User Login Management...
[FAILED] Failed to start User Login Management.
See 'systemctl status systemd-logind.service' for details.
[ OK ] Stopped User Login Management.
         Starting Load Kernel Module drm...
[ OK ] Finished Load Kernel Module drm.
         Starting User Login Management...
[FAILED] Failed to start User Login Management.
[ 31.645337] cloud-init[682]: Traceback (most recent call last):
See 'systemctl status systemd-logind.service' for details.
[ 31.661314] cloud-init[682]: File "/usr/bin/cloud-init", line 33, in <module>
[ OK ] Stopped User Login Management.
[ 31.700582] cloud-init[682]: sys.exit(load_entry_point('cloud-init==22.2', 'console_scripts', 'cloud-init')())
         Starting Load Kernel Module drm...
[ 31.747746] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 1061, in main
[FAILED] Failed to start OpenBSD Secure Shell server.
[ 31.796108] cloud-init[682]: retval = util.log_time(
See 'systemctl status ssh.service' for details.
[ 31.807526] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2637, in log_time
[FAILED] Failed to start Apply the …ngs specified in cloud-config.
[ 31.828055] cloud-init[682]: ret = func(*args, **kwargs)
See 'systemctl status cloud-config.service' for details.
[ 31.837637] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 675, in status_wrapper
[ OK ] Finished Load Kernel Module drm.
[ 31.854861] cloud-init[682]: util.ensure_dirs(
[FAILED] Failed to start User Login Management.
[ 31.871702] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 1704, in ensure_dirs
See 'systemctl status systemd-logind.service' for details.
[ 31.889378] cloud-init[682]: ensure_dir(d, mode)
[ 31.897145] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 1767, in ensure_dir
[ 31.908355] cloud-init[682]: chmod(path, mode)
[ 31.913867] cloud-init[682]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2029, in chmod
[ 31.924736] cloud-init[682]: os.chmod(path, real_mode)
[ 31.931858] cloud-init[682]: OSError: [Errno 30] Read-only file system: '/var/lib/cloud/data'
[ OK ] Stopped OpenBSD Secure Shell server.
         Starting OpenBSD Secure Shell server...
[FAILED] Failed to start OpenBSD Secure Shell server.
See 'systemctl status ssh.service' for details.
[ OK ] Finished Remove Stale Onli…ext4 Metadata Check Snapshots.
[ OK ] Reached target Multi-User System.
[ OK ] Reached target Graphical Interface.
         Starting Execute cloud user/final scripts...
         Starting Record Runlevel Change in UTMP...
[ OK ] Finished Record Runlevel Change in UTMP.
[ 32.300135] cloud-init[707]: Traceback (most recent call last):
[ 32.327760] cloud-init[707]: File "/usr/bin/cloud-init", line 33, in <module>
[ OK ] Stopped OpenBSD Secure Shell server.
[ 32.350986] cloud-init[707]: sys.exit(load_entry_point('cloud-init==22.2', 'console_scripts', 'cloud-init')())
         Starting OpenBSD Secure Shell server...
[ 32.429664] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 1061, in main
[FAILED] Failed to start Execute cloud user/final scripts.
[ 32.448354] cloud-init[707]: retval = util.log_time(
See 'systemctl status cloud-final.service' for details.
[ 32.461660] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2637, in log_time
[FAILED] Failed to start OpenBSD Secure Shell server.
[ 32.477109] cloud-init[707]: ret = func(*args, **kwargs)
See 'systemctl status ssh.service' for details.
[ 32.491257] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 675, in status_wrapper
[ OK ] Reached target Cloud-init target.
[ 32.507656] cloud-init[707]: util.ensure_dirs(
[ 32.636976] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 1704, in ensure_dirs
[ 32.652642] cloud-init[707]: ensure_dir(d, mode)
[ 32.662251] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 1767, in ensure_dir
[ 32.700327] cloud-init[707]: chmod(path, mode)
[ 32.704305] cloud-init[707]: File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2029, in chmod
[ 32.711424] cloud-init[707]: os.chmod(path, real_mode)


Kali GNU/Linux Rolling kali ttyS0

kali login: root (automatic login)


[ 32.727791] cloud-init[707]: OSError: [Errno 30] Read-only file system: '/var/lib/cloud/data'
Linux kali 6.0.0-kali3-cloud-amd64 0000001 SMP PREEMPT_DYNAMIC Debian 6.0.7-1kali1 (2022-11-07) x86_64

The programs included with the Kali GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Kali GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
┏━(Message from Kali developers)

┃ This is a cloud installation of Kali Linux. Learn more about
┃ the specificities of the various cloud images:
┃ ⇒ https://www.kali.org/docs/troubleshooting/common-cloud-setup/

┗━(Run: “touch ~/.hushlogin” to hide this message)
                                                                                



Steps To ReproduceLaunch an EC2 from the AMI kali-last-snapshot-amd64-2022.4.0-804fcc46-63fc-4eb6-85a1-50e66d6c7215

Activities

ryanb

2022-12-08 00:42

reporter   ~0017225

the ami works when the volume size is 12gb (the default), the system log from above is from attempting to launch with a volume size of 20gb.
maybe the following line is relevant
GROWROOT: WARNING: resize failed: failed [flock:127] flock -x 9
/sbin/growpart: line 714: flock: not found

michiiii

2022-12-08 18:03

reporter   ~0017231

I have the exact same issue. With the old ami there were absolutely no issues using a custom volume size.

g0tmi1k

2022-12-08 21:45

administrator   ~0017232

Thanks for reporting this issue.
We believe we have found the issue (kernel)
We have updated and pushed out a package update
We will re-build the AWS tomorrow, test and publish if succesfull

g0tmi1k

2022-12-09 12:28

administrator   ~0017236

Just submitted 2022.4b AWS Marketplace (AMI: ami-0d2b15a7903d3783b)

ryanb

2022-12-10 04:07

reporter   ~0017239

the new ami works, thank you!

g0tmi1k

2022-12-10 08:12

administrator   ~0017240

And public ~ https://aws.amazon.com/marketplace/pp/prodview-fznsw3f7mq7to

We have updated our workflow to catch this bug going forwards.

Please open a new ticket if this hasn't address the issue completely.

Issue History

Date Modified Username Field Change
2022-12-08 00:25 ryanb New Issue
2022-12-08 00:42 ryanb Note Added: 0017225
2022-12-08 18:03 michiiii Note Added: 0017231
2022-12-08 21:45 g0tmi1k Note Added: 0017232
2022-12-09 12:28 g0tmi1k Note Added: 0017236
2022-12-10 04:07 ryanb Note Added: 0017239
2022-12-10 08:12 g0tmi1k Note Added: 0017240
2022-12-10 08:12 g0tmi1k Assigned To => g0tmi1k
2022-12-10 08:12 g0tmi1k Status new => closed
2022-12-10 08:12 g0tmi1k Resolution open => fixed