View Issue Details

IDProjectCategoryView StatusLast Update
0008342Kali LinuxKali Package Bugpublic2023-06-06 16:13
ReporterleFrench Assigned Toarnaudr  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2023.2 
Summary0008342: No Sound on Hyper-V VM , Dell E7470 Laptop


I've got no sound on my vm. I tried to plug my usb headset ( Jabra Evolve 20 SE MS) nope doesn't work either.

I've followed your guide, and also this one :

Still nothing. Here's my terminal output :

aplay -l
aplay: device_list:274: no soundcards found...

cat /proc/asound/cards
--- no soundcards ---

wpctl status
PipeWire 'pipewire-0' [0.3.65, kali@kali, cookie:2687037098]
└─ Clients:

  1. pipewire [0.3.65, kali@kali, pid:843]
  2. WirePlumber [0.3.65, kali@kali, pid:842]
  3. WirePlumber [export] [0.3.65, kali@kali, pid:842]
  4. xfce4-pulseaudio-plugin [0.3.65, kali@kali, pid:1046]
  5. xdg-desktop-portal [0.3.65, kali@kali, pid:1541]
  6. Google Chrome input [0.3.65, kali@kali, pid:2904]
  7. Google Chrome [0.3.65, kali@kali, pid:2904]
  8. wpctl [0.3.65, kali@kali, pid:5995]

├─ Devices:

├─ Sinks:
│ * 35. Dummy Output [vol: 1.39]

├─ Sink endpoints:

├─ Sources:

├─ Source endpoints:

└─ Streams:

  1. Google Chrome
    1. output_FL > Dummy Output:playback_FL [active]
    2. output_FR > Dummy Output:playback_FR [active]

├─ Devices:

├─ Sinks:

├─ Sink endpoints:

├─ Sources:

├─ Source endpoints:

└─ Streams:

└─ Default Configured Node Names:

  1. Audio/Sink auto_null
  2. Audio/Source auto_null

└─$ ps -fp $(pgrep wire)
lightdm 720 704 0 22:28 ? S<sl 0:00 /usr/bin/pipewire
lightdm 721 704 0 22:28 ? S<sl 0:00 /usr/bin/wireplumber
lightdm 722 704 0 22:28 ? S<sl 0:00 /usr/bin/pipewire-pulse
kali 841 825 0 22:30 ? Ssl 0:04 /usr/bin/pipewire
kali 842 825 0 22:30 ? Ssl 0:00 /usr/bin/wireplumber
kali 843 825 1 22:30 ? SLsl 0:09 /usr/bin/pipewire-pulse

└─$ systemctl --user status -n 100 pipewire-pulse
● pipewire-pulse.service - PipeWire PulseAudio
Loaded: loaded (/usr/lib/systemd/user/pipewire-pulse.service; enabled; preset: enabled)
Drop-In: /usr/lib/systemd/user/pipewire-pulse.service.d
Active: active (running) since Fri 2023-06-02 22:30:23 CEST; 13min ago
TriggeredBy: ● pipewire-pulse.socket
Main PID: 843 (pipewire-pulse)
Tasks: 2 (limit: 9392)
Memory: 8.1M
CPU: 10.394s
CGroup: /user.slice/user-1000.slice/[email protected]/session.slice/pipewire-pulse.service
└─843 /usr/bin/pipewire-pulse

Jun 02 22:30:23 kali systemd[825]: Started pipewire-pulse.service - PipeWire PulseAudio.
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal>
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: found session bus but no portal
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: RTKit error: org.freedesktop.DBus.Error.AccessDenied
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: could not set nice-level to -11: Permission denied
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: RTKit error: org.freedesktop.DBus.Error.AccessDenied
Jun 02 22:30:23 kali pipewire-pulse[843]: mod.rt: could not make thread 860 realtime using RTKit: Permission denied





2023-06-03 06:49

reporter   ~0018139

Based on the information you provided, it seems that your system is running PipeWire as the audio server. However, there may be some configuration issues preventing your sound card from being detected properly. Here are a few suggestions you can try:

Check Virtual Machine Settings: Ensure that the virtual machine is configured to pass through the USB headset to the guest operating system. Double-check the settings to make sure the headset is properly connected to the VM.

Install Additional Packages: Make sure you have the necessary packages installed for audio support in the virtual machine. You can try installing the pulseaudio package if it's not already installed.

sudo apt update
sudo apt install pulseaudio

Restart Audio Services: Restarting the audio services might help resolve any configuration issues. Try restarting the PulseAudio and PipeWire services.

systemctl --user restart pulseaudio
systemctl --user restart pipewire

Check Permissions: Make sure the user running the virtual machine has the necessary permissions to access the audio devices. You can try adding the user to the audio group.

sudo usermod -aG audio <username>
Replace <username> with your actual username.

Verify Audio Devices: Use the aplay -l command to verify if the system recognizes the audio devices.

Copy code
aplay -l
If the command still doesn't detect any sound cards, there might be a deeper issue with the virtual machine configuration or compatibility.

Consult Virtual Machine Documentation: Check the documentation or support resources specific to the virtual machine software you are using. There may be additional steps or settings required to enable audio support within the VM.

If none of these steps resolve the issue, it may be helpful to provide more details about your virtual machine setup (e.g., the software you're using, any specific configurations) so that further troubleshooting can be done.



2023-06-03 08:57

manager   ~0018145

@leFrench Please ignore the message above, looks like chatGPT output, or some other kind of AI. None of those suggestions will help.

From your output:

cat /proc/asound/cards
--- no soundcards ---

That looks like the issue, there should be a soundcard. Check your VM configuration, does your VM actually has a sound card enabled?

Otherwise: how did you setup your VM? Did you install from the Kali Linux installer iso? Or did you use the pre-built VMware VM? Did you upgrade your system, or did you just set it up from the 2023.2 release? Or was it a weekly image? I need all those details so that I can do the same on my side, and see if I reproduce your issue.




2023-06-03 09:02

reporter   ~0018146

I used the Hyper V installer, I didn't modify anything related to the sound card. On my other windows VM there's no issue.



2023-06-03 09:19

manager   ~0018147

Last edited: 2023-06-03 09:43

I used the Hyper V installer

Ah so you mean the Hyper-V image from there: ? It's a new image, so it's possible that there are some glitches. We also switched from pulseaudio to pipewire in 2023.2, and I think that's the issue here.

If you have a little time, would you be kind enough to try those steps: To sum it up here:


Install build environment

sudo apt install git pkg-config autotools-dev libtool make gcc

Install dependencies

sudo apt install libpipewire-0.3-dev libspa-0.2-dev


git clone
cd pipewire-module-xrdp


sudo make install

After that, I suppose a reboot of the VM is in order. Does that fix the issue? If that's the case, we'll package this for Kali so that everyone can benefit. Thanks in advance!

EDITED the code snippet above, forgot 'git clone'



2023-06-03 10:14

reporter   ~0018148


Yes it does the trick ! :)

Merci beaucoup !



2023-06-06 04:15

manager   ~0018158

There is now a package pipewire-module-xrdp in Kali, so for anyone having the issue, the right fix is now:

sudo apt update
sudo apt install -y pipewire-module-xrdp

@leFrench: I suggest you do a "sudo make uninstall" (if ever there's a 'uninstall' target defined), and then install the package instead, now that the package is ready. This way you'll get updates.



2023-06-06 16:13

manager   ~0018161

To finish: I uploaded a new Hyper--V image where pipewire-module-xrdp is pre-installed. This image has version 2023.2a, and it's what people will get if they download it from, starting now.

So I'm closing this ticket. Thanks again @leFrench for the report, and helping to test pipewire-module-xrdp!

Issue History

Date Modified Username Field Change
2023-06-02 20:55 leFrench New Issue
2023-06-03 06:49 goushikrishh Note Added: 0018139
2023-06-03 08:57 arnaudr Note Added: 0018145
2023-06-03 09:02 leFrench Note Added: 0018146
2023-06-03 09:19 arnaudr Note Added: 0018147
2023-06-03 09:43 arnaudr Note Edited: 0018147
2023-06-03 10:14 leFrench Note Added: 0018148
2023-06-06 04:15 arnaudr Note Added: 0018158
2023-06-06 16:13 arnaudr Note Added: 0018161
2023-06-06 16:13 arnaudr Assigned To => arnaudr
2023-06-06 16:13 arnaudr Status new => assigned
2023-06-06 16:13 arnaudr Status assigned => resolved
2023-06-06 16:13 arnaudr Resolution open => fixed