View Issue Details

IDProjectCategoryView StatusLast Update
0008349Kali LinuxGeneral Bugpublic2023-06-09 02:39
ReporterVm001 Assigned Toarnaudr  
Status resolvedResolutionfixed 
Product Version2023.2 
Summary0008349: Kali Crash After Full-upgrade

I've been using this Kali Linux VM in VMware for long , I've upgraded it earlier also multiple times(which worked fine), This time when i launched the command Sudo apt full-upgrade it downloaded all of the packages which were required and then started to install them , after few minutes it crashed the sytem and popped the error (PFA) and I am unable to get back into the system since then. I tried rescue mode or Advance options for kali GNU/Linux mode by which i tried apt update it gave me unmet dependencies error and same in apt upgrade after that i tried apt --fix missing but no luck it throw me error related to python3 numpy .
I dont want to reset/clean or reinstall the whole OS .Please help and suggest the best to fix.

Attached Files
Steps (639,508 bytes)
image.png (12,233 bytes)   
image.png (12,233 bytes)   


Username Taken

Username Taken

2023-06-08 13:21

reporter   ~0018168

I have an issue. I can't report an issue on this site. Why am I not surprised.



2023-06-09 02:39

manager   ~0018170

@Vm001 Did you just run out of disk space or something? I can't help really. The "Oh no" screen shows that GNOME can't boot, so you need to instead open a console: type <Ctrl>+<Shift>+<Fx> (Fx being F1, F2, F3, just pick one), except that in VM you can't type that as far as I know, so instead you need to click around, until you find how to send this sequence to the VM. At least, that's how it is with QEMU, I don't really know about VMware. Anyway. Then, after you manage to get a console, log in, then check the logs and understand what's wrong.

This requires technical skills. You can try to get supports from the community ( for example). But at this point, your problem is not related to Kali, it's more generally "How to debug a Linux OS that doesn't boot".

In any case, what you report is not a bug in Kali, and here is not the place for general Linux support, so I'm closing the issue. Good luck.

Issue History

Date Modified Username Field Change
2023-06-07 10:25 Vm001 New Issue
2023-06-07 10:25 Vm001 File Added: Steps
2023-06-07 10:25 Vm001 File Added: image.png
2023-06-08 13:21 Username Taken Note Added: 0018168
2023-06-09 02:39 arnaudr Note Added: 0018170
2023-06-09 02:39 arnaudr Assigned To => arnaudr
2023-06-09 02:39 arnaudr Status new => resolved
2023-06-09 02:39 arnaudr Resolution open => fixed