View Issue Details

IDProjectCategoryView StatusLast Update
0008638Kali LinuxKali Package Bugpublic2024-02-21 10:43
Reportervanguard Assigned Todaniruiz  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionno change required 
Summary0008638: Firefox: No plugins in statusbar

Dear maintainers,

I am not sure if it is a bug or a feature. The issue is: I can not see the buttons of plugins in the statusbar of mozilla firefox in kali.

(plugins are i.e. noscript, beaglebasger or ublock). Thus thea can not be confugured during browsing.

As far as I read, this happens when in private mode and/or history is disabled.

Although I am NOT in private mode and history is enabled, buttons are still not appearing.

What did I miss? I searched in about:config, but could not find any required setting.

Thanks for any help.

Best regards





2024-02-21 08:23

reporter   ~0018926

They should be located under the "Extensions" icon (by your search bar, next to the "hamburger" icon (i.e., most right icon)). It looks like a puzzle piece.

Regardless, this is not a Kali issue, and I cannot replicate your problem on a freshly installed Kali Linux XFCE.



2024-02-21 10:10

reporter   ~0018927

Hi Arszilla,
yes, this feedback did help. Although the extension symbol did show all plugins, I first could not find a button for the settings during browsing (what I mean is an option to allow or disallow URLs in noscript). I only found
activation and deactivation.

However, in the extension tab, there was the option for all plugins, to stick them to the menubar, which I did. This option is NOT available in the settings menu of firefox, when you go to "plugins and themes".

So, it was like I thought: not a bug, just a special setting in the version of firefox in kali and so I allowed me, to ask here.

Thius issue can safely be closed. Thank you for the fast and helpfull response.

Best regards




2024-02-21 10:23

reporter   ~0018928

Again: This is not a Kali specific issue. This change was introduced by Mozilla a few months back and its multi-platform. I have observed it on Windows and Linux.

Issue History

Date Modified Username Field Change
2024-02-19 19:27 vanguard New Issue
2024-02-21 08:23 Arszilla Note Added: 0018926
2024-02-21 10:10 vanguard Note Added: 0018927
2024-02-21 10:23 Arszilla Note Added: 0018928
2024-02-21 10:43 daniruiz Assigned To => daniruiz
2024-02-21 10:43 daniruiz Status new => closed
2024-02-21 10:43 daniruiz Resolution open => no change required