View Issue Details

IDProjectCategoryView StatusLast Update
0008648Kali LinuxKali Package Bugpublic2024-04-29 11:56
Reportervanguard Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Summary0008648: Kali-menu: double entries in xfce4-whiskermenu-plugin

Dear maintainers,

due to a crash in kali I had to purge and reinstall kali-menu and its dependencies kali-desktop-lde, kali-desktop-kde and kali-desktop-xfce.

This brought back all the menues in whisker menu in FCE4, but now several entries are double. Double means, they are identical.

Is there any way to get rid of them? Trying to remove ~.config, ~.cache and ~.local did no success. So I believe, it is a system problem.

Tried also to create a new user, which got the same issue.

And of course I tried menulibre, but this made things worse. If you are using menulibre, then ALL menus are gone. (menulibre was the reason, why I had to reinstall the packages
mentioned above).

I am not understanding, how whisker is morking, and where it gets its information, which packages it shall show. And of course I would like to know, why some entries are shown
double, and some not, so that I may find a solution by myself the next time.

Thank you very much for any help and/or hints!

Best regards





2024-02-28 11:58

reporter   ~0018947

Now I believe, this is a bug in package "kali-menu". I tested several things. First, I created a fresh user = same issue. Then purged kali-menu and it`s dependencies and as expected, all whisker entrieds where gone.

After this reinstalled only kali-menu = kali entries appeared again, same issue.

To make sure, needed libs and so are installed, I reinstalled kali-desktop-xfce = same issue. Then reinstalled kali-desktop-lxde and kali-deskto-kde, as they where deinstalled by deinstalling kali-menu (dependencies).

To make sure, that kali-menu or whisker will not read double entries, I deleted entries of double shown applications. First try, move entry in /usr/share/kali-menu/applications away, then moved back and moved the same
entry away in /usr/share/applications/. Both tries got no changes, the issue stayed.

Wha, do I believe, this might be an issue in the package? Well, I am running another computer with same configuration (XFCE4 and whisker plugin). Although this computer was only upgraded (no manual configuration done by me ever), the same issue is showing there, too.

Please note, that the double entries are only shown in whisker-menu, but NOT in standard XFCE application menu. I checked with KDE, LXDE and XFCE (as said, standard menu).

Of course, might be also a problem with the package "xfce4-whiskermenu-plugin", but I can not prove it.

Hope, this helps a little bit.

Best regards




2024-02-28 18:43

reporter   ~0018949

The double entries appear, when you have set either "listview" or "icon view" in the settings of whsikermenu. They do not appear, if you set "tree view", which is preconfigured in kali.
Maybe because this, this issue was not discovered before?

Issue History

Date Modified Username Field Change
2024-02-27 19:03 vanguard New Issue
2024-02-28 08:33 daniruiz Assigned To => daniruiz
2024-02-28 08:33 daniruiz Status new => assigned
2024-02-28 11:58 vanguard Note Added: 0018947
2024-02-28 18:43 vanguard Note Added: 0018949
2024-04-29 11:56 daniruiz Assigned To daniruiz =>