Dependency Graph

Dependency Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0003728Kali LinuxGeneral Bugpublic2017-03-07 15:54
ReporterPrEZeX Assigned Torhertzog  
Status closedResolutionduplicate 
Product Version2016.2 
Summary0003728: Booting from Kali Live, encrypted, persistent USB generates decrypting error

I've followed the official installation guides (, trying to make an encrypted, persistent live usb without success (partly). I've used three different usb-drives (2x8gb and 16gb) to exclude any hardware problems. I've tested the installation steps through a live kali usb, live ubuntu usb (both on PC, laptop and VM) and also on an installed ubuntu (on my laptop and VM). After going through all the installation steps and trying to boot my usb I've got an error: "There was an error decrypting /dev/sdb3 ... Retry? [Y/n] no key available with this passphrase." At first I though that i typed the wrong password or that there's a problem with key-mapping so I made a easy "test1234" password just to test it. That password still didn't work. I've tried to boot form both my PC and my laptop with the same error appearing. When I booted in live mode i could without any problems open up the encrypted partition from within Kali. When I tested booting up the usb through the VM it worked... I then thought that I missed some BIOS settings preventing booting so I've tried disabling and enabling everything i could think of (UEFI Boot, Secure Boot, Legacy Boot, 3.0 USB, etc.) to no avail. I even removed my HDD from my laptop and booted with only the USB connected... I just don't understand why the encryption password works when booting in my VM but not on my PC or laptop.


duplicate of 0003729 resolvedrhertzog Booting from Kali Live, encrypted, persistent USB generates decrypting error 


There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-11-16 19:12 PrEZeX New Issue
2017-02-13 19:58 rhertzog Assigned To => rhertzog
2017-02-13 19:58 rhertzog Status new => assigned
2017-03-07 15:54 rhertzog Status assigned => closed
2017-03-07 15:54 rhertzog Resolution open => duplicate
2017-03-07 15:54 rhertzog Relationship added duplicate of 0003729