Relationship Graph

Relationship Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0005805Kali LinuxQueued Tool Additionpublic2020-11-11 23:50
Reportertjnull Assigned Tosbrun  
Status resolvedResolutionfixed 
Fixed in Version2020.3 
Summary0005805: Joplin - open source note taking

Joplin is an open source note taking and to-do application, which can handle a large number of notes organised into notebooks. The notes are searchable, can be copied, tagged and modified either from the applications directly or from your own text editor. The notes are in Markdown format.

Main Page:


Steps To Reproduce

Download the app image

run it as an executable for short term testing.

Looking for ways to have it packaged manually in Kali as we speak.


has duplicate 0006194 closed joplin: a free, open source note taking and to-do application, which can handle a large number of notes organised into notebooks 




2019-12-09 13:14

administrator   ~0011609

Last edited: 2020-01-06 13:12

@kali-team, please could this be packaged up.
@author, If you want to help the packaging process, you can check the documentation here ~



2020-02-07 08:15

administrator   ~0012035

Upstream provides build instructions:

Arch Linux seems to have an unofficial package:
(that example might help to build some initial packaging for Debian, even though we would prefer to rely on node-* packages available in Debian rather than stuff downloaded via npm)



2020-03-02 04:15

reporter   ~0012372

Just wanted to provide an update to this situation:

Recently a bug was discovered in Joplin that would not allow Debian Users to run the program.

tjnull@conops:~/Downloads$ ./Joplin-1.0.179.AppImage
[3061:0227/] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_JoplinThf4iS/chrome-sandbox is owned by root and has mode 4755.
Trace/breakpoint trap

This was due to the appimage sandbox permission that had to be modified in the app image. While working on the issue I had a person in the community by the name of whiskers confirm the issues and the changes to make it work. The changes were able to resolve the bug and got it to run in Kali Linux.

Whiskers was actually able to find a way to repackage the application from source and the permissions be preserved in the program as a deb file. He will be working with the developers later this week to see if they can be able to support the continued package to create the deb File. In case they say no we have the source and can be able to package this for further releases if we need to do so.

I can confirm and verify that the application he compiled and repackage does work properly if we want to use it since the program is FOSS.

Here is a link to download the application:

Shout out to whiskers for taking the time and effort to look into this!



2020-03-04 22:50

reporter   ~0012385

It seems the creators of Joplin will not be building a deb package at this time. Therefore, whiskers (InitInfosec) has been given approval by the creators to create and update the main Joplin Deb package at this time.

You can find the official support here:

I will continue to work with him if he has any questions or concerns.



2020-03-15 23:12

reporter   ~0012417

Whiskers (initinfosec) has just placed a bug in for this package:



2020-03-18 17:04

reporter   ~0012433

apologies for the duplicate,, I had started a new issue to request addition of the tool. Please note that the github repo mention above has changed from joplin-debian to joplin-kali.

- [Name] - Joplin
  • [Version] - 1.0.193-0kali1
  • [Homepage] -
  • [Package] -
  • [Author] - initinfosec
  • [License] - MIT License
  • [Description] - Joplin for Desktop, originally developed by Laurent Cozic. This package is an unofficially supported port of the original application from source, maintained by initinfosec, and OK'd by the original author.
  • [Dependencies] - Requires: libgtk-3-0, libnotify4, libnss3, libxss1, libxtst6, xdg-utils, libatspi2.0-0, libuuid1, kde-cli-tools | kde-runtime | trash-cli | libglib2.0-bin | gvfs-bin
  • [Similar tools] - CherryTree
  • [Activity] - Initial commit/stable debian port from official latest stable sources (1.0.193)
  • [How to use] - joplin (or launch from App Menu)

Let me know if you need anything further on my end.

~initinfosec / "whiskers"



2020-04-27 14:54

manager   ~0012682

joplin version 1.0.201-0kali2 is in kali-experimental: only for amd64 for the moment.
It can't be built for armel (nodejs is not available).



2020-04-28 15:29

manager   ~0012689

joplin version 1.0.201-0kali6 in kali-experimental: on amd64, arm64 and armhf.
The build on i386 fails with segmentation fault.



2020-04-28 16:25

reporter   ~0012690

Thanks for the hard work @sbrun - would be curious to hear what you did/where I went wrong sometime,

Curious if you have logs for the i386 failure? I believe I got it to work successfully once when testing, but I only did it once, and it was for one of the older 1.0.18X releases IIRC



2020-04-28 17:05

manager   ~0012691

I'm not sure that the i386 failure is related to joplin. I think it's a npm's failure, maybe specific to the Debian package npm (?)
the segmentation fault occurs if I run "npm install" directly in source directory, or if I run "npm install" in the directories ReactiveNativeClient or ElectronClient.
I will try to investigate soon.



2020-05-19 08:12

manager   ~0012807

Now we have joplin for amd64, arm64, armhf
joplin-cli is available for amd64, arm64, armhf AND i386.

FTR: the "npm install" command seems to fail on i386 when there are many packages to install. I tried to make several "npm install" instead of one command to avoid the failure.

Issue History

Date Modified Username Field Change
2019-11-21 16:12 tjnull New Issue
2019-12-09 13:14 g0tmi1k Category New Tool Requests => Queued Tool Addition
2019-12-09 13:14 g0tmi1k Note Added: 0011609
2019-12-10 11:57 g0tmi1k Priority immediate => normal
2019-12-10 11:57 g0tmi1k Severity major => feature
2019-12-10 11:58 g0tmi1k Summary Add Joplin to Kali Linux => Joplin - open source note taking
2020-01-06 13:06 g0tmi1k Product Version kali-dev =>
2020-01-06 13:07 g0tmi1k Status new => acknowledged
2020-01-06 13:12 g0tmi1k Note Edited: 0011609
2020-02-07 08:15 rhertzog Note Added: 0012035
2020-03-02 04:15 tjnull Note Added: 0012372
2020-03-04 22:50 tjnull Note Added: 0012385
2020-03-15 23:12 tjnull Note Added: 0012417
2020-03-18 16:57 g0tmi1k Relationship added has duplicate 0006194
2020-03-18 17:04 initinfosec Note Added: 0012433
2020-04-24 08:08 sbrun Assigned To => sbrun
2020-04-24 08:08 sbrun Status acknowledged => assigned
2020-04-27 14:54 sbrun Note Added: 0012682
2020-04-28 15:29 sbrun Note Added: 0012689
2020-04-28 16:25 initinfosec Note Added: 0012690
2020-04-28 17:05 sbrun Note Added: 0012691
2020-05-19 08:12 sbrun Status assigned => resolved
2020-05-19 08:12 sbrun Resolution open => fixed
2020-05-19 08:12 sbrun Note Added: 0012807
2020-11-11 23:50 g0tmi1k Fixed in Version => 2020.3