Relationship Graph

Relationship Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0007427Kali LinuxKali Package Bugpublic2023-05-08 01:17
ReporterAssraful Assigned To 
Status closedResolutionduplicate 
Product Version2020.3 
Summary0007427: kex --sl does not start seamless mode on Windows 10 WSL2

Using latest kali linux on Windows 10 x64 Version 2004 Build 19041.508), followed steps to install kex as given here:

running kex as soon as I login to WSL works pretty fine, it launches window mode GUI and work flawlessly.

Where as when I try the seamless mode, VcXsrv crashes showing fatal error message box. (attached screenshot for your reference).

Please help me resolve this.

Steps To Reproduce
  1. Install WSL and kali linux on Windows 10 (professional edition)
    1. Install Kex following steps given here:
  2. kex --sl

VcXsrv crashes with fatal error. (screenshot attached)

Additional Information

OS: Kali GNU/Linux Rolling on Windows 10 x86_64
Kernel: 4.19.104-microsoft-standard
Uptime: 23 mins
Packages: 1131 (dpkg)
Shell: bash 5.0.18
Terminal: /dev/pts/0
CPU: Intel i7-9750H (12) @ 2.592GHz
Memory: 93MiB / 6248MiB

winver: Windows 10 x64 Version 2004 Build 19041.508)

Attached Files
Screenshot 2020-10-02 153508.jpg (128,397 bytes)   
Screenshot 2020-10-02 153508.jpg (128,397 bytes)   


duplicate of 0006767 assignedsteev kex --sl does not start seamless mode on Windows 10 WSL2 




2020-10-02 10:19

reporter   ~0015365

The error log file when VcXsrv failed to lanuch.

win-kexsl.log (1,503 bytes)   
Welcome to the VcXsrv X Server
Vendor: The VcXsrv Project

OS: Windows NT 6.2 build 9200 (64-bit)
Contact: [email protected]

LoadPreferences: C:\Users\pavan\AppData\Roaming\.XWinrc not found
LoadPreferences: Loading \\wsl$\kali-linux\usr\lib\win-kex\VcXsrv\system.XWinrc
Warning: Locale not supported by X, falling back to 'C' locale.
(II) AIGLX: Testing pixelFormatIndex 5
(II) GLX: enabled GLX_SGI_make_current_read
(II) GLX: enabled GLX_SGI_swap_control
(II) GLX: enabled GLX_MESA_swap_control
(II) GLX: enabled GLX_SGIX_pbuffer
(II) GLX: enabled GLX_ARB_multisample
(II) GLX: enabled GLX_SGIS_multisample
(II) GLX: enabled GLX_ARB_fbconfig_float
(II) GLX: enabled GLX_EXT_fbconfig_packed_float
(II) GLX: enabled GLX_ARB_create_context
(II) GLX: enabled GLX_ARB_create_context_profile
(II) GLX: enabled GLX_ARB_create_context_robustness
(II) GLX: enabled GLX_EXT_create_context_es2_profile
(II) AIGLX: enabled GLX_MESA_copy_sub_buffer
(II) 670 pixel formats reported by wglGetPixelFormatAttribivARB
(II) GLX: Initialized Win32 native WGL GL provider for screen 0
winClipboardThreadProc - DISPLAY=
Using Composite redirection
OS maintains clipboard viewer chain: yes
winMultiWindowXMsgProc - Fatal error 1 on xcb connection
winClipboardProc - setjmp returned for IO Error Handler.
(II) winClipboardProc - Failed opening the display, giving up
Server terminated successfully (0). Closing log file.
win-kexsl.log (1,503 bytes)   


2020-10-02 20:32

manager   ~0015366

There should be a fix for this coming - can you rm the win-kex.log file and do again? This seems to stem from running kex seamless as root, and root owning the log file, so when you try to run it as a normal user, it can't write to the log.



2020-10-03 06:33

reporter   ~0015367

Tried removing the log files, this time it ran without any errors, however, nothing appeared on the desktop. No Xfce desktop bar for seamless usage. Even tried starting a program from console and received error "Error: no DISPLAY environment variable specified".

when is the fix arriving? any planned dates?



2020-10-03 06:34

reporter   ~0015368

I must thank you for your swift reply though. Highly appreciated!



2021-06-24 19:09

manager   ~0015369

Can you reproduce this with the latest version of kex?



2021-10-23 20:06

reporter   ~0015370

hello @pavangr did you resolve the issue?? please let me know if you did.
thank you



2021-10-23 22:00

reporter   ~0015371

@igt1400 @steev let me re-check and report.



2021-10-23 22:25

reporter   ~0015372

Yep!! that's working great!! wow!! Thanks guys!!



2021-10-23 22:32

reporter   ~0015373

I open other native programs like file manager..etc and then open the Firefox browser. The browser don't come-up but other windows opened before freezes and eventually vcx server crashes.



2021-10-23 22:33

reporter   ~0015374

vcxserver crash window..



2021-10-24 08:38

reporter   ~0015375

I have 4K monitor and wondering why it is not taking my native resolution. it would be great if it identify the native resolutions.

Screenshot 2021-10-24 140548.jpg (205,057 bytes)   
Screenshot 2021-10-24 140548.jpg (205,057 bytes)   


2021-10-25 13:58

manager   ~0015376

Are you using an Nvidia GPU on that system? We've seen some issues running Firefox and Nvidia GPUs but we aren't sure where the issue is exactly.



2021-10-25 19:42

reporter   ~0015377

you are right, I am using nvidia.



2023-05-06 10:11

reporter   ~0017885

Yet another wrongly cloned issue...

Duplicate of 0006767

Issue History

Date Modified Username Field Change
2021-10-27 05:19 Assraful New Issue
2021-10-27 05:19 Assraful Issue generated from: 0006767
2023-05-06 10:11 kali-bugreport Note Added: 0017885
2023-05-08 01:17 arnaudr Assigned To steev =>
2023-05-08 01:17 arnaudr Status assigned => closed
2023-05-08 01:17 arnaudr Resolution open => duplicate
2023-05-08 01:17 arnaudr Relationship added duplicate of 0006767