View Issue Details

IDProjectCategoryView StatusLast Update
0007427Kali Linux[All Projects] Kali Package Bugpublic2023-05-08 01:17
ReporterAssraful Assigned To 
Status closedResolutionduplicate 
Product Version2020.3 
Target VersionFixed in Version 
Summary0007427: kex --sl does not start seamless mode on Windows 10 WSL2
DescriptionUsing latest kali linux on Windows 10 x64 Version 2004 Build 19041.508), followed steps to install kex as given here:

running kex as soon as I login to WSL works pretty fine, it launches window mode GUI and work flawlessly.

Where as when I try the seamless mode, VcXsrv crashes showing fatal error message box. (attached screenshot for your reference).

Please help me resolve this.

Steps To Reproduce1. Install WSL and kali linux on Windows 10 (professional edition)
2. 2. Install Kex following steps given here:
3. kex --sl

VcXsrv crashes with fatal error. (screenshot attached)
Additional InformationOS: Kali GNU/Linux Rolling on Windows 10 x86_64
Kernel: 4.19.104-microsoft-standard
Uptime: 23 mins
Packages: 1131 (dpkg)
Shell: bash 5.0.18
Terminal: /dev/pts/0
CPU: Intel i7-9750H (12) @ 2.592GHz
Memory: 93MiB / 6248MiB

winver: Windows 10 x64 Version 2004 Build 19041.508)


duplicate of 0006767 assignedsteev kex --sl does not start seamless mode on Windows 10 WSL2 



2020-10-02 10:12



2020-10-02 10:19

reporter   ~0015365

The error log file when VcXsrv failed to lanuch.

win-kexsl.log (1,503 bytes)


2020-10-02 20:32

manager   ~0015366

There should be a fix for this coming - can you rm the win-kex.log file and do again? This seems to stem from running kex seamless as root, and root owning the log file, so when you try to run it as a normal user, it can't write to the log.


2020-10-03 06:33

reporter   ~0015367

Tried removing the log files, this time it ran without any errors, however, nothing appeared on the desktop. No Xfce desktop bar for seamless usage. Even tried starting a program from console and received error "Error: no DISPLAY environment variable specified".

when is the fix arriving? any planned dates?


2020-10-03 06:34

reporter   ~0015368

I must thank you for your swift reply though. Highly appreciated!


2021-06-24 19:09

manager   ~0015369

Can you reproduce this with the latest version of kex?


2021-10-23 20:06

reporter   ~0015370

hello @pavangr did you resolve the issue?? please let me know if you did.
thank you


2021-10-23 22:00

reporter   ~0015371

@igt1400 @steev let me re-check and report.


2021-10-23 22:25

reporter   ~0015372

Yep!! that's working great!! wow!! Thanks guys!!

Screenshot 2021-10-24 035449.png (1,952,547 bytes)


2021-10-23 22:32

reporter   ~0015373

I open other native programs like file manager..etc and then open the Firefox browser. The browser don't come-up but other windows opened before freezes and eventually vcx server crashes.

Screenshot 2021-10-24 040008 (Medium).png (389,194 bytes)


2021-10-23 22:33

reporter   ~0015374

vcxserver crash window..


2021-10-24 08:38

reporter   ~0015375

I have 4K monitor and wondering why it is not taking my native resolution. it would be great if it identify the native resolutions.


2021-10-25 13:58

manager   ~0015376

Are you using an Nvidia GPU on that system? We've seen some issues running Firefox and Nvidia GPUs but we aren't sure where the issue is exactly.


2021-10-25 19:42

reporter   ~0015377

you are right, I am using nvidia.


2023-05-06 10:11

reporter   ~0017885

Yet another wrongly cloned issue...

Duplicate of 0006767

Issue History

Date Modified Username Field Change
2021-10-27 05:19 Assraful New Issue
2021-10-27 05:19 Assraful Issue generated from: 0006767
2023-05-06 10:11 kali-bugreport Note Added: 0017885
2023-05-08 01:17 arnaudr Assigned To steev =>
2023-05-08 01:17 arnaudr Status assigned => closed
2023-05-08 01:17 arnaudr Resolution open => duplicate
2023-05-08 01:17 arnaudr Relationship added duplicate of 0006767