Dependency Graph

Dependency Graph
related to related to child of child of duplicate of duplicate of

View Issue Details

IDProjectCategoryView StatusLast Update
0008137Kali LinuxKali Package Bugpublic2023-01-10 21:28
Reporterenropash Assigned Todaniruiz  
Status closedResolutionduplicate 
Product Version2022.4 
Summary0008137: problem with Covenant on Kali wsl

Lately I've been running Windows Subsystem for Linux (wsl) Kali (using "kex --esm") and that is working great.

Except for one app that I've tried - covenant-kbx which runs, but whose listeners will only listen on Docker's loopback IP address If I try to listen on an eth0 IP or tun0 IP, that doesn't work.

Steps To Reproduce
  1. sudo service docker start
    Starting Docker: docker.

  2. sudo covenant-kbx start

    Starting covenant
    Please wait during the start, it can take a long time...
    Opening with a web browser
    covenant/default started
    Press ENTER to exit

  3. Create listener using default settings. (baseline showing expected bahavior)
    Connecting to will show that the web server is listening on port 80

--2022-12-19 19:32:08--
Connecting to connected.
HTTP request sent, awaiting response... 404 Not Found
2022-12-19 19:32:08 ERROR 404: Not Found.

  1. Delete listener and create new listener using the IP address of any interface other than docker0

Connecting to will show there is no server listening on port 80

wget ↵ 4
--2022-12-19 19:38:48--
Connecting to failed: Connection refused.


duplicate of 0008109 resolvedarnaudr problem with Covenant on Kali wsl 




2023-01-06 02:39

manager   ~0017375

I updated the package so that covenant-kbx can listen on the host network. Please run "sudo apt update && sudo apt install covenant-kbx" in a terminal, that should get you the latest version of the package (ie. version 0.6-0kali6). Tell me if it fixes the issue. Thanks!



2023-01-06 02:50

reporter   ~0017376

Thanks for the update!

(ran above commands as directed)

The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 788 not upgraded.
Need to get 26.1 MB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 kali-rolling/main amd64 covenant-kbx amd64 0.6-0kali6 [26.1 MB]
Fetched 26.1 MB in 1s (26.4 MB/s)
(Reading database ... 475365 files and directories currently installed.)
Preparing to unpack .../covenant-kbx_0.6-0kali6_amd64.deb ...
Unpacking covenant-kbx (0.6-0kali6) over (0.6-0kali5) ...
Setting up covenant-kbx (0.6-0kali6) ...

sudo service docker start
Starting Docker: docker.

sudo covenant-kbx start

Starting covenant
Please wait during the start, it can take a long time...
Traceback (most recent call last):
File "/usr/bin/kaboxer", line 33, in <module>
sys.exit(load_entry_point('kaboxer==1.1.2', 'console_scripts', 'kaboxer')())
File "/usr/lib/python3/dist-packages/kaboxer/", line 2204, in main
File "/usr/lib/python3/dist-packages/kaboxer/", line 363, in go
File "/usr/lib/python3/dist-packages/kaboxer/", line 480, in cmd_run
container = self.docker_conn.containers.create(image, opts2)
File "/usr/lib/python3/dist-packages/docker/models/", line 877, in create
create_kwargs = _create_container_args(kwargs)
File "/usr/lib/python3/dist-packages/docker/models/", line 1095, in _create_container_args
create_kwargs['host_config'] = HostConfig(
File "/usr/lib/python3/dist-packages/docker/types/", line 336, in init
raise host_config_incompatible_error(
docker.errors.InvalidArgument: "host" network_mode is incompatible with port_bindings

Is there something special I will need to do for port bindings?



2023-01-06 05:30

manager   ~0017377

Last edited: 2023-01-06 05:31

Oups! Please open (as root) the file /usr/share/kaboxer/covenant.kaboxer.yaml, and comment out (ie. add a '#' at the beginning of the lines) these 3 lines:


  • 7443
  • 443

Does that work?



2023-01-06 06:26

reporter   ~0017378


It appears that worked like a charm. Will need to do some real testing to confirm but this looks promising.

╭─kali@BOB-GRAM /home/kali [ Jan 05 22:17 ]
╰─$ sudo covenant-kbx start

Starting covenant
Please wait during the start, it can take a long time...
Opening with a web browser
covenant/default started
Press ENTER to exit

╭─kali@BOB-GRAM /home/kali [ Jan 05 22:18 ]
╰─$ ss -tunlp
Netid State Recv-Q Send-Q Local Address:Port Peer Address:Port Process

tcp LISTEN 0 512 <<<--- listener running on tun0 IP
tcp LISTEN 0 512

╭─kali@BOB-GRAM /home/kali [ Jan 05 22:18 ]



2023-01-06 08:08

manager   ~0017379

Great to hear, thanks for the feedback! I just uploaded version 0.6-0kali7 with the fix.



2023-01-06 17:00

reporter   ~0017380

Thank you for the fix.

I have confirmed I am able to install the latest using sudo apt update && sudo apt install covenant-kbx

Covenant starts up with no issues and is able to listen on interface tun0 and eth0.

Gratitude and respect to you and happy New ear.



2023-01-06 17:01

reporter   ~0017381

LOL happy New Year I mean



2023-01-09 10:02

manager   ~0017382

Thanks for your feedback! No new ear for this year for me ;) I wish you a great 2023!



2023-01-10 21:05

reporter   ~0017392

Yet another wrongly cloned issue...

Dup of 0008109

Issue History

Date Modified Username Field Change
2023-01-10 09:52 enropash New Issue
2023-01-10 09:52 enropash Issue generated from: 0008109
2023-01-10 21:05 kali-bugreport Note Added: 0017392
2023-01-10 21:28 daniruiz Assigned To => daniruiz
2023-01-10 21:28 daniruiz Status new => closed
2023-01-10 21:28 daniruiz Resolution open => duplicate
2023-01-10 21:28 daniruiz Relationship added duplicate of 0008109