View Issue Details

IDProjectCategoryView StatusLast Update
0001060Kali Linux[All Projects] New Tool Requestspublic2020-03-18 17:46
ReporterKALIMERO Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0001060: remmina-plugin-rdp does not work, no remmina rdp plugin available after install
DescriptionThere is no RDP plugin available in the remmina desktop client after installing remmina-plugin-rdp - so login to a RDP server is not possible with this tool.

There is a workaround for that installing the Debian libfreerdp1 package
https://packages.debian.org/wheezy/libfreerdp1
but I had some troubles with package updates, fixing the Kali Package would be the much welcomed solution to this problem.
Steps To Reproduceinstall remmina-plugin-rdp and start remmina, look into the plugins menu - no RDP protocol plugin available.
Additional InformationRemmina is a very handy tool for organizing lots of remote connection clients - it would be very useful to have such a basic tool working flawlessly in a professional network toolset like kali linux.

Activities

KALIMERO

2014-03-05 12:05

reporter   ~0001595

Last edited: 2014-03-05 12:15

View 2 revisions

Hi, is there any chance of getting this fixed ASAP? I need RDP daily and have dozens of sessions configured with Remmina, it makes me crazy not having this in Kali.

I mean, this is not any seldom-used and completely distro-unrelated spacken-tool, Remmina is the defacto standard RDP client for Linux - it should work flawless on a network tool like Kali, shouldn't it?

It's like a Porsche not able to drive german Autobahns because of built-in speed limit or something like this. Even if you are using Kali for "Hacking" RDP will be a pleasure to use instead of any other tool to connect to your owned windows boxes... (I use Kali mainly because of the good wireless driver support and for security testing of my own networks only).

Thanks!

g0tmi1k

2018-01-29 15:12

administrator   ~0008461

To help speed up the process of evaluating the tool, please make sure to include the following information (the more information you include, the more beneficial it will for us):

- [Name] - The name of the tool
- [Version] - What version of the tool should be added?
--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
- [Homepage] - Where can the tool be found online? Where to go to get more information?
- [Download] - Where to go to get the tool?
- [Author] - Who made the tool?
- [Licence] - How is the software distributed? What conditions does it come with?
- [Description] - What is the tool about? What does it do?
- [Dependencies] - What is needed for the tool to work?
- [Similar tools] - What other tools are out there?
- [How to install] - How do you compile it?
- [How to use] - What are some basic commands/functions to demonstrate it?

g0tmi1k

2020-03-18 17:46

administrator   ~0012449

No response since 2018 (2 years).... Closing.

Please reopen if the information can be provided.

Issue History

Date Modified Username Field Change
2014-02-26 10:55 KALIMERO New Issue
2014-03-05 12:05 KALIMERO Note Added: 0001595
2014-03-05 12:15 KALIMERO Note Edited: 0001595 View Revisions
2014-03-05 13:03 muts Priority high => low
2014-03-05 13:03 muts Severity major => trivial
2014-03-05 13:03 muts Category Kali Package Bug => New Tool Requests
2018-01-29 15:12 g0tmi1k Note Added: 0008461
2018-02-21 09:35 g0tmi1k Product Version 1.0.6 =>
2019-12-09 13:29 g0tmi1k Priority low => normal
2019-12-09 13:30 g0tmi1k Severity trivial => feature
2020-03-18 17:46 g0tmi1k Status new => closed
2020-03-18 17:46 g0tmi1k Resolution open => suspended
2020-03-18 17:46 g0tmi1k Note Added: 0012449