View Issue Details

IDProjectCategoryView StatusLast Update
0000197Kali Linux[All Projects] Kali Package Bugpublic2013-10-08 10:22
Reportersaberzaid Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000197: w3af - bleeding edge
Descriptionhello dev

after doing apt-get update and apt-get upgrade , i have found an update for w3af , from bleeding edge source , so after the upgrade and when clicking on w3af it not start , its only showing the start up screen and then it gone

Additional Informationthe log :


root@kali:~# w3af
Starting w3af, running on:
  Python version:
    2.7.3 (default, Jan 2 2013, 16:53:07)
    [GCC 4.7.2]
  GTK version: 2.24.10
  PyGTK version: 2.24.0

w3af - Web Application Attack and Audit Framework
  Version: 1.2
  Revision: unknown
  Distribution: Debian
  Author: Andres Riancho and the w3af team.
Traceback (most recent call last):
  File "/usr/share/w3af/w3af_gui", line 84, in <module>
    errCode = main()
  File "/usr/share/w3af/w3af_gui", line 81, in main
    core.ui.gtkUi.main.main(profile, doupdate)
  File "/usr/share/w3af/core/ui/gtkUi/main.py", line 858, in main
    MainApp(profile, do_upd)
  File "/usr/share/w3af/core/ui/gtkUi/main.py", line 406, in __init__
    self.pcbody = pluginconfig.PluginConfigBody(self, self.w3af)
  File "/usr/share/w3af/core/ui/gtkUi/pluginconfig.py", line 620, in __init__
    self.pan = self._buildpan()
  File "/usr/share/w3af/core/ui/gtkUi/pluginconfig.py", line 638, in _buildpan
    self.std_plugin_tree = PluginTree(self.w3af, "standard", self.config_panel)
  File "/usr/share/w3af/core/ui/gtkUi/pluginconfig.py", line 241, in __init__
    if self._getEditablePlugin(plugin, plugintype):
  File "/usr/share/w3af/core/ui/gtkUi/pluginconfig.py", line 296, in _getEditablePlugin
    plugin = self.w3af.plugins.getPluginInstance(pname, ptype)
  File "/usr/share/w3af/core/controllers/coreHelpers/plugins.py", line 237, in getPluginInstance
    pluginInst = factory('plugins.' + pluginType + '.' + pluginName)
  File "/usr/share/w3af/core/controllers/misc/factory.py", line 49, in factory
    raise w3afException('There was an error while importing '+ moduleName + ': "' + str(ie) + '".')
w3afException: There was an error while importing plugins.discovery.wordnet: "No module named nltk.corpus.util"

Activities

saberzaid

2013-04-04 12:55

reporter   ~0000323

please fix this bug asap , kind regards

deadlock

2013-04-13 08:11

reporter   ~0000362

Try to delete or rename ~/.w3af directory. It may contain references to a plugins that are not in w3af anymore.

saberzaid

2013-04-13 11:56

reporter   ~0000364

i did , and also i remove it and reinstall it again . still the same problem

this tool is nice , only need to fix those problems

note: this bug happend only when i update it from bleeding edge source,

toxic

2013-04-19 07:07

reporter   ~0000390

hi, i have exactly the same behavior than saberzaid, since the same time,
i had updated whith bleeding edge source.
i did the advise of deadlock, but as saberzaid still same problem.

"w3afException: There was an error while importing plugins.discovery.wordnet: "No module named nltk.corpus.util""

Unr3achabl3

2013-05-30 11:57

reporter   ~0000479

Last edited: 2013-05-30 11:58

View 2 revisions

i have the same problem after updating it from bleeding edge source

saberzaid

2013-05-31 08:20

reporter   ~0000481

the final fix for this and for the new ver also is :


2013-05-09 07:25

    before upgrading w3af, this is the req steps to make the latest w3af work without any problem :

apt-get install python2.7-dev libsqlite3-dev python-setuptools python-pip


pip install PyGithub GitPython pybloomfiltermmap esmre nltk pdfminer futures guess-language cluster msgpack-python python-ntlm

pip install -e git+git://github.com/ramen/phply.git#egg=phply [^]

pip install xdot

just follow those steps < i have report about it on http://bugs.kali.org/view.php?id=344

rhertzog

2013-10-08 10:22

administrator   ~0000970

Duplicate of 0000344. We're tracking the w3af update there.

Issue History

Date Modified Username Field Change
2013-03-27 16:41 saberzaid New Issue
2013-03-27 18:40 muts Summary w3af => w3af - bleeding edge
2013-04-04 12:55 saberzaid Note Added: 0000323
2013-04-13 08:11 deadlock Note Added: 0000362
2013-04-13 11:56 saberzaid Note Added: 0000364
2013-04-19 07:07 toxic Note Added: 0000390
2013-05-30 11:57 Unr3achabl3 Note Added: 0000479
2013-05-30 11:58 Unr3achabl3 Note Edited: 0000479 View Revisions
2013-05-31 08:20 saberzaid Note Added: 0000481
2013-10-08 10:22 rhertzog Note Added: 0000970
2013-10-08 10:22 rhertzog Status new => closed
2013-10-08 10:22 rhertzog Assigned To => rhertzog
2013-10-08 10:22 rhertzog Resolution open => duplicate