View Issue Details

IDProjectCategoryView StatusLast Update
0002039Kali Linux[All Projects] New Tool Requestspublic2018-01-29 10:55
Reporterpedropt Assigned Tog0tmi1k  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0002039: Router Keygen
DescriptionRouter Keygen generate default WPA/WEP keys for the following router:

    Thomson based routers ( this includes Thomson, SpeedTouch, Orange, Infinitum, BBox, DMax, BigPond, O2Wireless, Otenet, Cyta , TN_private, Blink )
    DLink ( only some models )
    Pirelli Discus
    Eircom
    Verizon FiOS ( only some routers supported)
    Alice AGPF
    FASTWEB Pirelli and Telsey
    Huawei (some InfinitumXXXX)
    Wlan_XXXX or Jazztel_XXXX
    Wlan_XX ( only some are supported)
    Ono ( P1XXXXXX0000X )
    WlanXXXXXX, YacomXXXXXX and WifiXXXXXX
    Sky V1 routers
    Clubinternet.box v1 and v2 ( TECOM-AH4XXXX )
    InfostradaWifi
    CONN-X
    Megared
    EasyBox, Arcor and Vodafone
    PBS (Austria)
    MAXCOM
    PTV
    TeleTu/Tele2
    Axtel, Axtel-xtremo
    Intercable
    OTE
    Cabovisao Sagem
    Alice in Germany (new)
    Speedport (new)


https://github.com/routerkeygen/routerkeygenPC

https://code.google.com/p/android-thomson-key-solver/
Additional InformationThis tool is very interesting and use it a lot when i go to work on remote locations where i can not get free Net or i am unable to crack wps protections on some routers due the fact that new models have more heavy protections on wps attacks .
Also capturing the handshake and decrypting it with hashcat will take much time because usually passwords are between 8 and 10 characters .
Router keygen can decrypt the default wifi password of some routers models .

This is a must have tool in kali , i use it on my nexus 7 , but they have also a version that works with linux .

Relationships

duplicate of 0004082 resolvedsbrun RouterKeygenPC - Router Keygen generate default WPA/WEP keys 

Activities

Gar

2015-02-02 14:55

reporter   ~0002982

I totally agree that Kali should have a "Default Key Calculator for Routers".
There was a similar request in 2013, suggesting "UFO WarDriving 4" (https://bugs.kali.org/view.php?id=370), which I have been successfully using as well.
In many cases out there, it saves one so much time...

pedropt

2015-02-02 18:24

reporter   ~0002983

Last edited: 2015-02-02 18:26

View 2 revisions

I am testing it all the time to make sure that it deserves to be in kali repo .
Even today i was i Lisbon and i was testing the app , it works perfectly as long as the default router password is not changed .
It also only works on those models that creator mentioned .
This app is really a "must have" because it saves us from a lot of time of cracking (even when it is possible) , and is good because the creator found the algorithm that allow him to know the default password just by using network name and mac address of the device .
To install the package in kali is not easy , because the kali repo does not have the most of the packages needed for the program to Run , i mean these packages :
build-essential qt5-default qtscript5-dev libnm-gtk-dev qttools5-dev qttools5-dev-tool

So for this program be added in Kali repo , those packages also must be in Kali repo and must not be in conflict with other gnome packages .

g0tmi1k

2018-01-29 10:55

administrator   ~0007944

Duplicate (0004082)
Closing

Issue History

Date Modified Username Field Change
2015-02-02 00:28 pedropt New Issue
2015-02-02 14:55 Gar Note Added: 0002982
2015-02-02 18:24 pedropt Note Added: 0002983
2015-02-02 18:26 pedropt Note Edited: 0002983 View Revisions
2015-02-23 17:27 rhertzog Product Version kali-dev =>
2015-11-09 13:44 Mr.Joe Issue cloned: 0002833
2018-01-26 11:25 g0tmi1k Relationship added duplicate of 0004082
2018-01-29 10:55 g0tmi1k Assigned To => g0tmi1k
2018-01-29 10:55 g0tmi1k Status new => closed
2018-01-29 10:55 g0tmi1k Resolution open => duplicate
2018-01-29 10:55 g0tmi1k Note Added: 0007944