View Issue Details

IDProjectCategoryView StatusLast Update
0002349Kali Linux[All Projects] New Tool Requestspublic2020-03-18 17:56
Reporterverg Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0002349: InstaRecon v0.1.1 - automated digital reconnaissance
DescriptionHi there. I'd like to suggest my tool to be part of Kali. It's called InstaRecon https://github.com/vergl4s/instarecon.

Its focus is to automate getting the 'low-hanging fruit' of recon. After gathering common DNS/Whois results, it queries Google to get subdomains and urls (using the 'site:*.<domain> -www.<domain> -etc.<domain>' dork), and it does DNS queries recursively on every new possible target found. It gets open ports and banners from Shodan as well, among other things.

Some, but not all, of the functionality overlap a little with dnsenum and recon-ng, however the idea of being a simple, non-modular script that gathers the most information with as little effort as possible makes it a very good option to start a reconnaissance with.

It's a breeze to install dependencies in Kali (pip install -r requirements.txt). Please give it a try, I think it can be very useful.

For latest .zip releases go to https://github.com/vergl4s/instarecon/releases.

Activities

stormtide

2015-07-07 20:57

reporter   ~0003484

We need to install the dependencies in Kali (pip install -r requirements.txt).

instarecon.py works for me without any issues.

rhertzog

2017-07-08 18:12

administrator   ~0006878

Waiting ack from g0tmi1k.

g0tmi1k

2017-07-18 14:23

administrator   ~0006923

For the time being, sticking with dnsenum and recon-ng

g0tmi1k

2018-01-29 17:49

administrator   ~0008547

To help speed up the process of evaluating the tool, please make sure to include the following information (the more information you include, the more beneficial it will for us):

- [Name] - The name of the tool
- [Version] - What version of the tool should be added?
--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
- [Homepage] - Where can the tool be found online? Where to go to get more information?
- [Download] - Where to go to get the tool?
- [Author] - Who made the tool?
- [Licence] - How is the software distributed? What conditions does it come with?
- [Description] - What is the tool about? What does it do?
- [Dependencies] - What is needed for the tool to work?
- [Similar tools] - What other tools are out there?
- [How to install] - How do you compile it?
- [How to use] - What are some basic commands/functions to demonstrate it?

g0tmi1k

2020-03-18 17:56

administrator   ~0012464

No response since 2018 (2 years).... Closing.

Please reopen if the information can be provided.

Issue History

Date Modified Username Field Change
2015-06-21 01:45 verg New Issue
2015-07-07 20:57 stormtide Note Added: 0003484
2017-06-22 14:20 g0tmi1k Assigned To => sbrun
2017-06-22 14:20 g0tmi1k Status new => assigned
2017-07-08 18:12 rhertzog Status assigned => feedback
2017-07-08 18:12 rhertzog Note Added: 0006878
2017-07-18 14:23 g0tmi1k Note Added: 0006923
2017-07-18 14:23 g0tmi1k Assigned To sbrun =>
2017-07-18 14:23 g0tmi1k Status feedback => new
2018-01-29 15:00 g0tmi1k Note View State: 0006923: public
2018-01-29 17:49 g0tmi1k Note Added: 0008547
2019-12-09 13:30 g0tmi1k Severity minor => feature
2020-03-18 17:56 g0tmi1k Status new => closed
2020-03-18 17:56 g0tmi1k Resolution open => suspended
2020-03-18 17:56 g0tmi1k Note Added: 0012464