View Issue Details

IDProjectCategoryView StatusLast Update
0002546Kali Linux[All Projects] General Bugpublic2016-05-30 07:22
Reporterkurobeats Assigned Tomuts  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002546: Kali Linux 2.0 momentarily freezing (Except Mouse) Gnome 3.14
DescriptionAs described here: https://forums.kali.org/showthread.php?26536-Kali-Linux-2-0-Freezing-%28Except-Mouse%29-Gnome-3-14, I am also experiencing momentary lockups. They feel like memory/CPU spikes as the issue doesn't last more than a minute.

Steps To ReproduceAs others in the previously mentioned thread have posted, it's not an easy issue to reproduce but am happy to run any commands and report back with results.
Additional InformationA few people have posted specs here with memtests if it helps: https://forums.kali.org/showthread.php?26536-Kali-Linux-2-0-Freezing-%28Except-Mouse%29-Gnome-3-14

Activities

ebonywarrior

2015-08-16 18:47

reporter   ~0003789

Last edited: 2015-08-17 11:27

View 2 revisions

I am also having the same issue. For me the display except for the mouse freezes indefinitely. I don't know if its related, but I am noticing the freezes with programs that don't use the system standard window frame, ie custimized close buttons... I was using iceweasle just fine, but when I opened chrome alongside iceweasle, it wasnt but 2 seconds to a hard freeze.

Edit: I did play around to try to see what actions were causing it. There is definitely something going on with non system windows... I set chrome options to use system window settings and it made a significant difference. There were freezes, but they weren't hard freezes, they would resolve in a few seconds. I did not try any other programs as I ran out of time, but as I try them I'll list the effects here

g0tmi1k

2015-08-17 09:17

administrator   ~0003797

Last edited: 2015-08-17 11:01

View 3 revisions

I believe tracker-store is to blame.

I notice the service using a load more CPU when git cloning a large repo (eg. metasploit)

Forum posting: https://forums.kali.org/showthread.php?26536-Kali-Linux-2-0-Freezing-%28Except-Mouse%29-Gnome-3-14
Possible useful information: https://askubuntu.com/questions/346211/tracker-store-and-tracker-miner-fs-eating-up-my-cpu-on-every-startup

xorz57

2015-08-17 15:55

reporter   ~0003800

I can confirm that too on my Dell Inspiron 15 3543 ... i also couldnt use my touchpad while in graphical installation

Yves Soete

2015-08-17 18:50

reporter   ~0003801

Last edited: 2015-08-17 18:51

View 2 revisions

Please do this:
cat /sys/module/usbcore/parameters/autosuspend

If the output is anything else than -1, then edit following file:

/etc/default/grub

modify this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet usbcore.autosuspend=-1"

After the edit update the grub loader:

sudo update-grub

Reboot, now check with cat /sys/module/usbcore/parameters/autosuspend it should now report -1

The problem is with the USB autosuspend state in usbcore.

Let me know if that fixes it.

Thanks.

Yves Soete

lillypad

2015-08-24 12:36

reporter   ~0003830

Bump* having the same issue here.

Memory: 4.8GB
Processor: AMD Phenom II x6 1090T
Graphics: GeForce GT 630
Base system: Kali GNU/Linux 2.0 (sana) 64-bit

ebonywarrior

2015-09-05 23:31

reporter   ~0003953

Last edited: 2015-09-05 23:53

View 2 revisions

*edit* I spoke too soon. It just froze.

I think you are on to something with tracker-store. I disabled search and indexing and so far, knock on wood, I haven't had a freeze yet in over 4 hours. That beats 20 minutes like a few weeks ago,

ebonywarrior

2015-09-06 00:41

reporter   ~0003954

Last edited: 2015-09-07 16:49

View 2 revisions

I was digging around other forums after watching the system monitor and noticing gnome-shell process using increasing amounts of memory. The last freeze I was using 160mb+ memory.

Some of the forums are saying its a memory leak in conjuntion to NVIDIA drivers.

I'm going to try the install the nouveau driver instead and see what happens

https://bbs.archlinux.org/viewtopic.php?id=122269

*edit below*
here's what happened when I switched drivers
Apparently I was using the default Kali driver -Nouveau. There is a memory leak in between the nouveau driver and causing gnome shell lock up

I installed nvidia 352.41 driver which slowed the leak. also the screen stopped freezing. This is good news. for a work around I would suggest installing the NVIDIA proprietary driver and the 32 bit compatability drivers for those on 64 bit systems. set a ULIMIT for gnome shell to restart when at 300-500 mb memory. I've been running for 48 hours and no freeze as compared to 20 minutes to freeze before.

If you want to get spunky I did try out a few other desktop environments
- cinnamon works without freezing, however there is a small delay between click and activating object (ex texboxes, dropdowns, open close windows) and the lock screen on cinnamon is blank some of the time. I did not test cinnamon with nouveau.... once I got things working managably I quit messing with things :D

gunshine

2016-05-28 22:49

reporter   ~0005292

@Yves Soete,

How do you edit that line during boot? Because once I click anything after boot, it freezes indefinitely.

muts

2016-05-30 07:22

administrator   ~0005297

This issue is old and no longer relevant. Gnome versions have been updated since and we do not support obsolete versions of Kali. Please feel free to open a new bug report if you are still experiencing this issue with the latest version of Kali rolling.

Issue History

Date Modified Username Field Change
2015-08-16 02:24 kurobeats New Issue
2015-08-16 18:47 ebonywarrior Note Added: 0003789
2015-08-17 09:17 g0tmi1k Note Added: 0003797
2015-08-17 11:00 g0tmi1k Note Edited: 0003797 View Revisions
2015-08-17 11:01 g0tmi1k Note Edited: 0003797 View Revisions
2015-08-17 11:27 ebonywarrior Note Edited: 0003789 View Revisions
2015-08-17 15:55 xorz57 Note Added: 0003800
2015-08-17 18:50 Yves Soete Note Added: 0003801
2015-08-17 18:51 Yves Soete Note Edited: 0003801 View Revisions
2015-08-24 12:36 lillypad Note Added: 0003830
2015-09-05 23:31 ebonywarrior Note Added: 0003953
2015-09-05 23:53 ebonywarrior Note Edited: 0003953 View Revisions
2015-09-06 00:41 ebonywarrior Note Added: 0003954
2015-09-07 16:49 ebonywarrior Note Edited: 0003954 View Revisions
2016-05-28 22:49 gunshine Note Added: 0005292
2016-05-30 07:22 muts Note Added: 0005297
2016-05-30 07:22 muts Status new => closed
2016-05-30 07:22 muts Assigned To => muts
2016-05-30 07:22 muts Resolution open => fixed