View Issue Details

IDProjectCategoryView StatusLast Update
0002557Kali LinuxGeneral Bugpublic2015-08-31 11:53
Reporterprakashkhadka Assigned Torhertzog  
PrioritylowSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.1.0 
Fixed in Version2.0 
Summary0002557: problem related with msf

Shall the new role be a superuser? (y/n) Shall the new role be a superuser? (y/n) Shall the new role be a superuser? (y/n) Shall the new role be a superuser? (y/n) Shall the new role be a superuser? (y/n) .....

Steps To Reproduce

i just upgraded to kali sana. May be upgrading lower version of kali to kali 2 may reproduce the issue. idk

Additional Information

FYI this is not fresh installation. I have upgraded using apt-get update and apt-getdist-upgrade and yes I have changed /etc/apt/source-lists according to the official link.

here is link to forum

Attached Files
Temp.png (461,981 bytes)


has duplicate 0002605 closedg0tmi1k "msfdb init " command gives recurring output in the terminal 




2015-08-19 07:01

reporter   ~0003810

Well, I was restless therefore I have re-installed fresh copy of kali linux. May be some other people will get the errors after upgrading to kali sana.



2015-08-25 03:43

reporter   ~0003832

I have solved the bug, but I don't know where can I submit the patch.

The solution is adding some parameters on the 57 line in msfdb.

  • printf "%s\n%s\n" "$DB_PASS" "$DB_PASS" | pg_cmd createuser -P $DB_USER >/dev/null

  • printf "%s\n%s\n" "$DB_PASS" "$DB_PASS" | pg_cmd createuser -s -d -P $DB_USER >/dev/null

I am not sure whether the new user should be superuser or not, I just pick the parameters as I think suit.



2015-08-25 05:49

reporter   ~0003833

Well, after a few tests, I think there may be also nessary to add following codes at the end of msfdb init:

rm /opt/metasploit/apps/pro/ui/config/database.yml
ln -s /usr/share/metasploit-framework/config/database.yml /opt/metasploit/apps/pro/ui/config/database.yml

However, I think the best solution should be: if you upgrade from 1.x to Kali Sana, don't execute msfdb, it's useless......



2015-08-25 07:54

reporter   ~0003834

well thanks, but it is not only msf. After upgrade to kali sana there are other things too which are missing. You can check out the forum link I have provided.



2015-08-31 11:53

administrator   ~0003852

I have just uploaded metasploit-framework 4.11.4-2015071403-0kali3 to fix this issue. It will shortly land in sana.

Issue History

Date Modified Username Field Change
2015-08-17 09:29 prakashkhadka New Issue
2015-08-19 07:01 prakashkhadka Note Added: 0003810
2015-08-25 03:39 Gh0u1L5 File Added: Temp.png
2015-08-25 03:43 Gh0u1L5 Note Added: 0003832
2015-08-25 05:49 Gh0u1L5 Note Added: 0003833
2015-08-25 07:10 rhertzog Assigned To => rhertzog
2015-08-25 07:10 rhertzog Status new => assigned
2015-08-25 07:54 prakashkhadka Note Added: 0003834
2015-08-30 11:25 g0tmi1k Relationship added has duplicate 0002605
2015-08-31 11:53 rhertzog Note Added: 0003852
2015-08-31 11:53 rhertzog Status assigned => resolved
2015-08-31 11:53 rhertzog Fixed in Version => 2.0
2015-08-31 11:53 rhertzog Resolution open => fixed