View Issue Details

IDProjectCategoryView StatusLast Update
0000262Kali Linux[All Projects] New Tool Requestspublic2020-03-18 17:49
Reportervanguard Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0000262: jnetmap
DescriptionDear maintainers,

it would be nice, if you could add the following tool and its dependencies to kali:

jnetmap

This tool is very easy to use and you can easily create a network overview of the required network. It is also capable to make a network sheet for yourself.

Addtionally there is the possibility to add new useful plugins, which make this little tool rather mighty.

It would be nice, if you could take a look at it and if you think it as usefull as me ( I do not want to miss it, really), then add it into kali.

Maybe you might want to add the plugins, too.

For easy installation there is already a debian compliant package available.

Jnetmap is released under GPL. You can find it and its plugins here:
http://www.rakudave.ch/jnetmap/introduction

Thank you for reading this!

Best regards

Hans

Activities

vanguard

2013-06-22 09:25

reporter   ~0000589

I found another way to implement this package into kali.
On the other hand I suggest to implement it into kali as well, as this tool is very usefull. It is easy to handel and makes a quick graphical overview of a network structure. IMO better than nmap handles this option.

Best

Hans

vanguard

2013-08-26 17:39

reporter   ~0000797

Hi all,

for those, who build kali themselves and wants "jNetMap" in your live-file-iso:

1. rename the downloaded debfile from sourceforge by dpkg:

dpkg-name jnetmap-0.5.3.deb

2. put the new created "jnetmap-*****.deb into ~/live-build-config/config/packages.chroot/

3. do a normal build with lb build.

In the new kali-live-Cd-iso you will find it below "Internet". Works for both - i386 and amd64.

Have fun!

If you do not want to add this package into the repo, please be so kind and tell me why.

You can close this bugreport, when you want.

Best regards

Hans

gattaca

2013-09-11 23:17

reporter   ~0000857

Hi, I went to have a look but, all of the related download links were non-functional.

vanguard

2013-09-12 08:55

reporter   ~0000858

You can download it here:

http://sourceforge.net/projects/jnetmap/

Or simply just google at "jnetmap".

Best

Hans

gattaca

2013-09-12 11:13

reporter   ~0000860

Yes, thanks. We had managed to puzzle that out.

At the time we were trying it wasn't accessible.

vanguard

2014-01-19 10:31

reporter   ~0001424

Hi!
I have uploaded a working debian package on my site. As it cannot be uploaded here due to restrisctions of the upload size, here is the download link:

http://www.ullrich-it.de/files/downloads/latest/jnetmap_0.5.3_all.deb

Would be nice, if you might add it into your repo.

Thanks for reading this message.

Best

Hans

vanguard

2016-06-29 19:43

reporter   ~0005438

Hello,
I am still in contact with the developer of jnetmap. Many improvements are implemented and jnetmap is still under heavy development.

And it is very usefull, as no other tool covers these features in that form.

So I allow me to ask again, to add jnetmap to kali.

Adding will be very easy, as David is already building debian packages and will be pleased if it will be in next kali version.

Thanks for reading this.

Best

Hans

g0tmi1k

2018-01-29 15:08

administrator   ~0008451

To help speed up the process of evaluating the tool, please make sure to include the following information (the more information you include, the more beneficial it will for us):

- [Name] - The name of the tool
- [Version] - What version of the tool should be added?
--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
- [Homepage] - Where can the tool be found online? Where to go to get more information?
- [Download] - Where to go to get the tool?
- [Author] - Who made the tool?
- [Licence] - How is the software distributed? What conditions does it come with?
- [Description] - What is the tool about? What does it do?
- [Dependencies] - What is needed for the tool to work?
- [Similar tools] - What other tools are out there?
- [How to install] - How do you compile it?
- [How to use] - What are some basic commands/functions to demonstrate it?

vanguard

2018-01-29 20:35

reporter   ~0008553

- [Name] - The name of the tool

jnetmap
- [Version] - What version of the tool should be added?
0.5.4

--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
Dunno.


- [Homepage] - Where can the tool be found online? Where to go to get more information?
http://www.rakudave.ch/jnetmap/?file=introduction

- [Download] - Where to go to get the tool?
http://www.rakudave.ch/jnetmap/?file=download

also on sourceforge

- [Author] - Who made the tool?
David Raku (or similar, ask him directly please)

- [Licence] - How is the software distributed? What conditions does it come with?

GPL

- [Description] - What is the tool about? What does it do?
NetMap helps you to keep an eye on your network. You can draw a graphical representation of your network, and jNetMap will periodically check if the devices are still up or a service is still running. You can also set up E-mail notifications or let jNetMap execute a script when a device goes down or comes up again. Additionally, you may attach notes to a device, initiate an RDP/VNC/SSH connection to a device and much more.



- [Dependencies] - What is needed for the tool to work?
As far as I know, it needs Java.

- [Similar tools] - What other tools are out there?
Nmap, maybe Zabbix or Nagios.

- [How to install] - How do you compile it?

Dunno, used just the binary. However, you have to change the version syntax. See
my description of the prior mails.

- [How to use] - What are some basic commands/functions to demonstrate it?
Take a look at the homepage, it is self explaining. I am using it mostly for network discovery (pings the stations and creates automatically a network chart).
Similar as nmap does, but the result is looking much more clearer. Check for yourself, then you will recognize the advantage.

Best

Hans

g0tmi1k

2020-03-18 17:00

administrator   ~0012430

Last release: 28.03.2015

g0tmi1k

2020-03-18 17:49

administrator   ~0012456

No update from upstream since 2015

Issue History

Date Modified Username Field Change
2013-04-14 09:12 vanguard New Issue
2013-06-22 09:25 vanguard Note Added: 0000589
2013-08-26 17:39 vanguard Note Added: 0000797
2013-09-11 23:17 gattaca Note Added: 0000857
2013-09-12 08:55 vanguard Note Added: 0000858
2013-09-12 11:13 gattaca Note Added: 0000860
2014-01-19 10:31 vanguard Note Added: 0001424
2016-06-29 19:43 vanguard Note Added: 0005438
2018-01-29 15:08 g0tmi1k Note Added: 0008451
2018-01-29 20:35 vanguard Note Added: 0008553
2018-01-30 08:40 g0tmi1k Summary Please add tool jnetmap to kali => jnetmap
2019-12-09 13:30 g0tmi1k Severity minor => feature
2020-03-18 17:00 g0tmi1k Note Added: 0012430
2020-03-18 17:49 g0tmi1k Status new => closed
2020-03-18 17:49 g0tmi1k Resolution open => suspended
2020-03-18 17:49 g0tmi1k Note Added: 0012456